Zanikanie internetu przez Wifi

Jeśli już na pewno nie da się umieścić posta wyżej.
Conamorek
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 15 kwie 2017, 23:17
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Fluxbox
Architektura: x86_64

Zanikanie internetu przez Wifi

Postautor: Conamorek » 15 kwie 2017, 23:28

Witam Panowie!

Jestem nowym użytkownikiem Ubuntu 16.04 i jeszcze dobrze nie zaznajomiłem się z tym oprogramowaniem, a już pojawiły się pierwsze problemy ;).
Mianowicie chodzi o to, że jestem podłączony do internetu poprzez Wifi w komputerze PC do routera UPC i co około 10 minut nie mam internetu, tzn. połączenie jest, ale internetu po prostu nie ma.
Dopiero po ponownym połączeniu z siecią internet działa na kolejne 10~ minut.

Poradźcie coś, proszę.
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3531
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: jacekalex » 16 kwie 2017, 02:48

Bez logów z systemu to raczej ciężko coś powiedzieć.

Jaki to komputer i jaka karta wifi?

Zainstaluj program lshw:

Kod: Zaznacz cały

sudo apt-get install lshw

potem pokaż wynik:

Kod: Zaznacz cały

sudo lshw -c network

w znacznikach Code.
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Conamorek
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 15 kwie 2017, 23:17
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Fluxbox
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: Conamorek » 16 kwie 2017, 17:16

Komputer to:
CPU: Intel Core i5 2400 podkręcony do 3,5 GHz
GPU: Radeon HD 7850
Płyta główna: AS Rock Z68 Pro3 Gen3
HDD: jakiś stary Samsung 500 GB
Karta sieciowa podana w logu poniżej.
Karta Wifi : TP Link WN-722N

Dodam, że na Windowsie 8.1 wszystko grało jak należy.

Kod: Zaznacz cały

*-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: enp5s0
       version: 06
       serial: 00:25:22:f8:3a:09
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:29 ioport:d000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@2:1.6
       logical name: wlx18d6c70c06b9
       serial: 18:d6:c7:0c:06:b9
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=ath9k_htc driverversion=4.8.0-46-generic firmware=1.4 ip=192.168.1.27 link=yes multicast=yes wireless=IEEE 802.11
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3531
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: jacekalex » 16 kwie 2017, 18:39

Mam taką samą kartę wifi :

Kod: Zaznacz cały

 description: Wireless interface
       physical id: 3
       bus info: usb@1:6
       logical name: wlan0_sta
       serial: ec:08:6b:17:66:e2
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=ath9k_htc driverversion=4.9.22-gr1 firmware=1.4 link=yes multicast=yes wireless=IEEE 802.11

i chodzi jak burza z hostapd, udostępniając neta na dwa Andkowe graty, jest widoczna jako trzy różne interfejsy:

Kod: Zaznacz cały

ifconfig -a | grep wlan -A1
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether ec:08:6b:17:66:e1  txqueuelen 1000  (Ethernet)
--
wlan0_ap: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       ether ec:08:6b:17:66:e3  txqueuelen 1000  (Ethernet)

--
wlan0_sta: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether ec:08:6b:17:66:e2  txqueuelen 1000  (Ethernet)


Biorąc pod uwagę, że mamy ten sam sterownik z tym samym firmware, to podejrzewam jakiś błąd w programie Network Manager, albo kłopot z samą kartą.

Musimy tylko wyeliminować inne ryzyka:
Czy tak karta na Windowsie chodzi normalnie (jeśli posiadasz Windowsa)?
Na jakimś innym Linuxie? (na dysku 500GB łatwo wygospodarować ze 20GB na zapasowego Linuxa np stabilnego Debiana, to na wypadek, jak główny system się"skicha" przy aktualizacjach).
Czy podobne problemy występowały na innych urządzeniach gadających z routerem, np smartfon czy tablet?

Pozdro
Ostatnio zmieniony 16 kwie 2017, 18:49 przez jacekalex, łącznie zmieniany 1 raz.
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Conamorek
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 15 kwie 2017, 23:17
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Fluxbox
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: Conamorek » 16 kwie 2017, 18:45

Na Windowsie wszystko grało jak należy, więc na pewno wina leży gdzieś w Ubuntu.
Na innym Linuxie nie sprawdzałem w zasadzie z wyżej wymienionego powodu.
Inne urządzenia nie mają problemu poza Playstation 4, aczkolwiek myślę, że to problem z samym urządzeniem, bo to bardzo częsta sprawa, że tracą połączenie/lagują.

Instalowałeś może dodatkowe sterowniki do tej karty Wifi ze strony Tp linku?
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3531
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: jacekalex » 16 kwie 2017, 19:12

Nie potrzebowałem niczego instalować, sterownik jest w każdym kernelu, zwie się ath9k_htc i chodzi jak burza.

To ten sterownik:

Kod: Zaznacz cały

modinfo ath9k-htc
filename:       /lib/modules/4.9.22-gr1/kernel/drivers/net/wireless/ath/ath9k/ath9k_htc.ko
firmware:       ath9k_htc/htc_9271-1.4.0.fw
firmware:       ath9k_htc/htc_7010-1.4.0.fw
description:    Atheros driver 802.11n HTC based wireless devices
license:        Dual BSD/GPL
author:         Atheros Communications
srcversion:     D48C8A7886AD7DDF5A768B5
alias:          usb:v0CF3p20FFd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0930p0A08d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v04DAp3904d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0411p0197d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0411p017Fd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v083ApA704d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0846p9018d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0CF3p7010d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1668p1200d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0CF3p7015d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0471p209Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v057Cp8403d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0CF3pB002d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0CF3pB003d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v040Dp3801d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v04CAp4605d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13D3p3350d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13D3p3349d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13D3p3348d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13D3p3346d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13D3p3328d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13D3p3327d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v07D1p3A10d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0846p9030d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0CF3p1006d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0CF3p9271d*dc*dsc*dp*ic*isc*ip*in*
depends:        ath9k_hw,ath9k_common,ath
intree:         Y
vermagic:       4.9.22-gr1 SMP preempt mod_unload modversions KERNEXEC_BTS REFCOUNT CONSTIFY_PLUGIN STACKLEAK_PLUGIN GRSEC RANDSTRUCT_PLUGIN_77fc7cfd1cd7e890c592dcd639f6826ec22ca003fc61cd2fb79c3c4851401310
signat:         PKCS#7
signer:         
sig_key:       
sig_hashalgo:   md4
parm:           debug:Debugging mask (uint)
parm:           nohwcrypt:Disable hardware encryption (int)
parm:           btcoex_enable:Enable wifi-BT coexistence (int)
parm:           ps_enable:Enable WLAN PowerSave (int)
parm:           use_dev_fw:Use development FW version (int)
parm:           blink:Enable LED blink on activity (int)


Żadnych specjalnych opcji do sterownika tej karty w /etc/modprobe.d/ też nie musiałem ustawiać.
Co prawda używam Gentoo a nie Ubuntu, ale jedyna istotna różnica miedzy użytkowaniem tej karty w naszych systemach jest to, ze Twoją kartą opiekuje się Network manager, a moją tylko Wpa_supplicant i Hostapd.

Na twoim miejscu bym na chwilkę zablokował działanie Network Managera w niezwykle brutalny, chamski i bezczelny sposób, a spróbował kartę skonfigurować przy pomocy Wpa_supplicanta i wpa_gui.


Na Ubuntu zrobiłbym mniej więcej tak:
Zainstalował wpa_gui:

Kod: Zaznacz cały

sudo apt-get install wpa_gui

Dodał użyszkodnika do grupy netdev:

Kod: Zaznacz cały

sudo adduser $USER netdev


Potem skonfigurował system do używania czystego wpa_supplicanta wg tego tutka (który jest napisany dla Debiana):
https://dug.net.pl/drukuj/230/konfigura ... _debianie/
PAMIĘTAJĄC, żeby wlan0 zmienić na nazwę karty wifi w systemie, u Ciebie to jest chyba wlx18d6c70c06b9.

Następnie zablokował działanie Network-managera np tak (w Ubuntu powinno zadziałać):

Kod: Zaznacz cały

sudo aa-genprof /usr/sbin/NetworkManager

po uruchomieniu nacisnął literkę F - jak (F)inish.
potem:

Kod: Zaznacz cały

sudo aa-enforce /usr/sbin/NetworkManager

i ponownie uruchomił komputer.

Prawdopodobnie po uruchomieniu nie będzie sieci w ogóle, ale łatwo to naprawić na kilka sposobów:
1. Dodając sieć przez wpa_gui.

2. Podłączając się sprawnym kablem do routera, a potem wydaniem magicznego polecenia w konsoli roota:

Kod: Zaznacz cały

dhclient enp5s0


Zobacz, czy coś osiągniesz w ten sposób.

Powrót do stanu poprzedniego wymaga odwrotnych czynności:
Usunięcia z /etc/network/interfaces tego wpisu:

Kod: Zaznacz cały

auto wlan0

iface wlan0 inet manual
   wpa-roam /etc/wpa_supplicant/wpa-roam.conf

iface default inet dhcp

i odblokowania Network Managera:

Kod: Zaznacz cały

sudo aa-disable  /usr/sbin/NetworkManager

Ponownie uruchomić kompa.
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Conamorek
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 15 kwie 2017, 23:17
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Fluxbox
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: Conamorek » 17 kwie 2017, 16:58

Dzięki wielkie za rzetelną pomoc ;).

Zrobiłem tak jak napisałeś, ale zarówno wpa jak i network-manager mieli problem ze znalezieniem sieci. Usunąłem wpisy z interfaces, włączyłem network-manager'a, zresetowałem router i nagle wszystko gra!
Jeśli znów pojawiłoby się zanikanie internetu, to się odezwę :).
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3531
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: jacekalex » 17 kwie 2017, 17:49

Czyli router coś wariował , może nie potrafił się dogadać z Linuxem, a tym winiłeś system za tymczasowy "katar" routera?

Na przyszłość zanim zaczniesz katować Linuxa, zrestartuj router. :twisted:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Conamorek
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 15 kwie 2017, 23:17
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Fluxbox
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: Conamorek » 17 kwie 2017, 22:48

Troszeczkę się pospieszyłem z oceną, bo jednak problem nadal występuje, ale w zdecydowanie mniejszej częstotliwości, tzn. dzisiaj zniknął internet 3-4 razy w ciągu całego dnia, co i tak jest ogromnym progresem.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6220
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: mario_7 » 21 kwie 2017, 22:34

Pokaż wynik polecenia dmesg gdy Internet zanika.
Czytelnia - poczytaj, Google - poszukaj
Conamorek
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 15 kwie 2017, 23:17
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Fluxbox
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: Conamorek » 23 kwie 2017, 01:42

Wyłączyłem UnPn w routerze i zniknął dziś internet tylko raz. Log, który chciałeś podaję na zewnętrznym linku, bo jest zbyt mały limit znaków na forum:
https://pastebin.com/q06nNvAe
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6220
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: mario_7 » 23 kwie 2017, 14:08

Wtedy Internet już nie działał? W logach nic nie widać na ten temat.

Ale chyba faktycznie coś jest na rzeczy, bo czasem ktoś coś zgłasza, np. tutaj https://github.com/qca/open-ath9k-htc-f ... issues/107
Czytelnia - poczytaj, Google - poszukaj
Conamorek
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 15 kwie 2017, 23:17
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Fluxbox
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: Conamorek » 26 kwie 2017, 15:38

Tak, juz internet wtedy nie działał.
Sprawdzałem link, zrobiłem co polecali, ale nic to nie dało. Nadal internet zanika mimo, że połączony status ma.

Może ma to jakiś związek z UPC?
Awatar użytkownika
pijetja
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 191
Rejestracja: 05 cze 2010, 07:04
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: XFCE
Architektura: x86_64
Lokalizacja: Altreich

Re: Zanikanie internetu przez Wifi

Postautor: pijetja » 26 kwie 2017, 17:38

Conamorek pisze:Może ma to jakiś związek z UPC?

Jeśli mieszkasz Altrajchu to tu UPC ma czkawkę na niektórych dzielnicach ;)
Nie wiem dlaczego ale mam uprzedzenie do IPv6, które to widzę w Twoim dmesg.
ppm na network managera --> Modyfikuj połączenia --> znajdź swoją sieć --> modyfikuj --> Ustawienia IPV6 z Automatyczne Na ignoruj.
Ja z założenia wyłączam to w GRUB.
Kilka Pytań pomocniczych: Jaki router? Czy hasła i klucze pozmieniana czy standardowe UPC? Jak dużo sieci wokół Ciebie?
i jeszcze wynik:

Kod: Zaznacz cały

iwconfig

popłoszę.
P.
Conamorek
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 15 kwie 2017, 23:17
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Fluxbox
Architektura: x86_64

Re: Zanikanie internetu przez Wifi

Postautor: Conamorek » 26 kwie 2017, 21:45

Nie mieszkam Altrajchu :D. Mieszkam w Warszawie.
Zrobiłem, to co zasugerowałeś i problem jest nadal :).

Router to ten od UPC, czyli wbudowany w dekoder Horizon https://www.upc.pl/pdf/upc_instrukcja_uzytkownika-skrocona-nowa.pdf?t=1493235763073
Hasła do routera są standardowe, narzucone przez UPC. Próbowałem jednokrotnie je zmienić, ale w sumie i tak wróciły do podstawowych ustawień po wypięciu go z gniazdka.
Co masz na myśli mówiąc jak dużo sieci? Podpięte do urządzenia są stale 3-4 urządzenia.

Wynik iwconfig:

Kod: Zaznacz cały

wlx18d6c70c06b9  IEEE 802.11  ESSID:"Plebania" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 44:AA:F5:71:6D:62   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=52/70  Signal level=-58 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:7   Missed beacon:0
Awatar użytkownika
pijetja
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 191
Rejestracja: 05 cze 2010, 07:04
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: XFCE
Architektura: x86_64
Lokalizacja: Altreich

Re: Zanikanie internetu przez Wifi

Postautor: pijetja » 27 kwie 2017, 05:47

Skoro mogłeś zmienić ESSID Sieci, to i hasła możesz zmienić. Chodzi mi ote do WIFI
Nie chodzi mi o to ile urządzeń jest podpiętych do routera ale ile sieci jest wokół Ciebie.

Kod: Zaznacz cały

sudo apt install wavemon
sudo wavemon

Następnie f3 i będziesz widział wszystkie sieci jaki Ci krzaczą.
A co do routera to nie wydaje mi się aby horizon był jednocześnie routerem.
I jeszcze jakbyś mógł doprecyzować
nie ma internetu
tzn strony się nie otwierają, czy pingi nie chodzą?
Jak internet pójdzie się paść to puść pinga na:

Kod: Zaznacz cały

192.168.1.1
oraz

Kod: Zaznacz cały

192.168.100.1

Wróć do „Ostatnia deska ratunku”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 2 gości