nie wykrywa karty dźwiękowej

Karty graficzne, dźwiękowe, tv, monitory etc.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6873
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: nie wykrywa karty dźwiękowej

Post autor: mario_7 » 12 sie 2011, 14:01

Polecenie, które podałem powinno przywrócić domyślną wersję bibliotek Alsy.
Czytelnia - poczytaj, Google - poszukaj
Astrall
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sie 2011, 17:25

Re: nie wykrywa karty dźwiękowej

Post autor: Astrall » 12 sie 2011, 15:28

Test teraz wygląda tak: klik Chyba wygląda trochę lepiej, ale jak nie widziało tak nie widzi karty dźwiękowej.
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3689
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: nie wykrywa karty dźwiękowej

Post autor: jacekalex » 12 sie 2011, 16:21

Najwyraźniej u Ciebie nie ładuje sterownika snd-hda-intel - ktory obsługuje tą kartę, dlaczego? diabli wiedzą.

Tu masz instrukcje, do debugowania kart hda:
http://www.alsa-project.org/main/index. ... _Intel_HDA
Może się dowiesz czegoś konkretnego.
Ten lapek wygląda na trudniejszy przypadek, pod Win$ też podobno są kłopoty ze sterami.

Spróbuj też z palca załadować sterownik w trybie debug:

Kod: Zaznacz cały

sudo modprobe snd-hda-intel  probe_mask=1 debug=2
Wszystkie opcje sterownika zobaczysz w wyniku polecenia

Kod: Zaznacz cały

modinfo snd-hda-intel
A tu jest instrukcja do różnych Linuxów:
https://help.ubuntu.com/community/HdaIntelSoundHowto
http://wiki.sabayon.org/index.php?title ... ound_Cards

Radziłbym też spróbować na innym, możliwie najnowszym kernelu.
Np z tych: http://kernel.ubuntu.com/~kernel-ppa/mainline/

Pozdro
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Astrall
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sie 2011, 17:25

Re: nie wykrywa karty dźwiękowej

Post autor: Astrall » 12 sie 2011, 17:16

ok zaraz zabiorę się za kombinowanie :)
polecenie " sudo modprobe snd-hda-intel probe_mask=1 debug=2" zwraca takie coś

Kod: Zaznacz cały

FATAL: Error inserting snd_pcm_oss (/lib/modules/2.6.38-10-generic/kernel/sound/acore/oss/snd-pcm-oss.ko): Invalid argument
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.38-10-generic/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
modinfo snd-hda-intel natomiast zwraca to:

Kod: Zaznacz cały

filename:       /lib/modules/2.6.38-10-generic/kernel/sound/pci/hda/snd-hda-intel.ko
description:    Intel HDA driver
license:        GPL
srcversion:     BDD9010D069C1A0B9B42926
alias:          pci:v00001022d*sv*sd*bc04sc03i00*
alias:          pci:v00001002d*sv*sd*bc04sc03i00*
alias:          pci:v000015ADd00001977sv*sd*bc*sc*i*
alias:          pci:v000017F3d00003010sv*sd*bc*sc*i*
alias:          pci:v00001102d00000009sv*sd*bc*sc*i*
alias:          pci:v00006549d00001200sv*sd*bc*sc*i*
alias:          pci:v000010DEd*sv*sd*bc04sc03i00*
alias:          pci:v000010B9d00005461sv*sd*bc*sc*i*
alias:          pci:v00001039d00007502sv*sd*bc*sc*i*
alias:          pci:v00001106d00003288sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA48sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA40sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA38sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA30sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA28sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA20sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA18sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA10sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA08sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA00sv*sd*bc*sc*i*
alias:          pci:v00001002d0000970Fsv*sd*bc*sc*i*
alias:          pci:v00001002d0000960Fsv*sd*bc*sc*i*
alias:          pci:v00001002d00007919sv*sd*bc*sc*i*
alias:          pci:v00001002d0000793Bsv*sd*bc*sc*i*
alias:          pci:v00001002d00004383sv*sd*bc*sc*i*
alias:          pci:v00001002d0000437Bsv*sd*bc*sc*i*
alias:          pci:v00008086d*sv*sd*bc04sc03i00*
alias:          pci:v00008086d0000811Bsv*sd*bc*sc*i*
alias:          pci:v00008086d00001D20sv*sd*bc*sc*i*
alias:          pci:v00008086d00001C20sv*sd*bc*sc*i*
depends:        snd-hda-codec,snd-pcm,snd,snd-page-alloc
vermagic:       2.6.38-10-generic SMP mod_unload modversions 686 
parm:           index:Index value for Intel HD audio interface. (array of int)
parm:           id:ID string for Intel HD audio interface. (array of charp)
parm:           enable:Enable Intel HD audio interface. (array of bool)
parm:           model:Use the given board model. (array of charp)
parm:           position_fix:DMA pointer read method.(0 = auto, 1 = LPIB, 2 = POSBUF, 3 = VIACOMBO). (array of int)
parm:           bdl_pos_adj:BDL position adjustment offset. (array of int)
parm:           probe_mask:Bitmask to probe codecs (default = -1). (array of int)
parm:           probe_only:Only probing and no codec initialization. (array of int)
parm:           single_cmd:Use single command to communicate with codecs (for debugging only). (bool)
parm:           enable_msi:Enable Message Signaled Interrupt (MSI) (int)
parm:           patch:Patch file for Intel HD audio interface. (array of charp)
parm:           beep_mode:Select HDA Beep registration mode (0=off, 1=on, 2=mute switch on/off) (default=1). (array of int)
parm:           power_save:Automatic power-saving timeout (in second, 0 = disable). (int)
parm:           power_save_controller:Reset controller in power save mode. (bool)
Dzięki za zainteresowanie :>
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3689
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: nie wykrywa karty dźwiękowej

Post autor: jacekalex » 12 sie 2011, 17:20

Spróbuj ładować ten ster zarówno bez parametrów, i zobacz, czy zaskoczy,
albo popróbuj różnych parametrów z modinfo (spróbuj bez debug=2)
Ja mam od "zawsze" wbudowany ten sterownik na stałe w kernel (nie występuje jako ładowalny), także nie sprawdzę, z jakimi parametrami wchodzi.

A poza tym, szczegóły masz w dmesg:
Unknown symbol in module, or unknown parameter (see dmesg)
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Astrall
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sie 2011, 17:25

Re: nie wykrywa karty dźwiękowej

Post autor: Astrall » 12 sie 2011, 17:31

Działa! :D wpisałem

Kod: Zaznacz cały

sudo modprobe snd-hda-intel  probe_mask=1
i załączyło, dzięki wielkie za pomoc :> jestem ci winny zimne piwo ;)

Pozdrawiam.
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3689
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: nie wykrywa karty dźwiękowej

Post autor: jacekalex » 12 sie 2011, 17:36

I co, jest dźwięk?
Czy tylko moduł się załadował, bez żadnego rezultatu?
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Astrall
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sie 2011, 17:25

Re: nie wykrywa karty dźwiękowej

Post autor: Astrall » 12 sie 2011, 17:37

Jest dźwięk :) Dzięki jeszcze raz za pomoc :D
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3689
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: nie wykrywa karty dźwiękowej

Post autor: jacekalex » 12 sie 2011, 17:42

To jesze dopisz te opcje w konfigu, żeby karta wstawała przy starcie:
np

Kod: Zaznacz cały

sudo -i
echo 'options  snd-hda-intel  probe_mask=1' >>/etc/modprobe.d/soundhda.conf
echo  'snd-hda-intel' >>/etc/modules
Powinno pomóc na przyszłość.

To by było na tyle
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Astrall
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sie 2011, 17:25

Re: nie wykrywa karty dźwiękowej

Post autor: Astrall » 12 sie 2011, 17:49

ok dopisane :) Dzięki
img007
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 07 paź 2017, 00:53
Płeć: Mężczyzna

Re: nie wykrywa karty dźwiękowej

Post autor: img007 » 09 paź 2017, 18:34

WItam
Mam bardzo podobny problem. Brak wykrywania karty dźwiękowej + głuche wyjście

Kod: Zaznacz cały

aplay -l
aplay: device_list:268: nie znaleziono żadnych kart dźwiękowych...

Kod: Zaznacz cały

lspci | grep "Audio"
00:1f.3 Audio device: Intel Corporation Device 9d70 (rev 21)
W Win 10 z którego korzystam na tym samym sprzęcie jest używana karta Relatek HD Audio (nie wiem czy to jest to samo co zostało znalezione przez ostatnie polecenie). Mam wrażenie że nie ma w ogóle sterowników zainstalowanych.
Generalnie siedzę nad tym cały dzień i próbuję różnych sposobów, które ciągle zawodzą dostając jednocześnie szewskiej pasji.
Bardzo prosiłbym o pomoc.

PS Korzystam z Ubuntu 14.04 LTS
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6873
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: nie wykrywa karty dźwiękowej

Post autor: mario_7 » 09 paź 2017, 21:31

Zacznij od sprawdzenia nowszej, a najlepiej najnowszej, wersji Ubuntu.
Czytelnia - poczytaj, Google - poszukaj
img007
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 07 paź 2017, 00:53
Płeć: Mężczyzna

Re: nie wykrywa karty dźwiękowej

Post autor: img007 » 10 paź 2017, 15:30

Mówisz o wersji 16.04 ? Niestety nie mam w tej chwili takiej możliwości, ale jak tylko będę mógł to poinformuję o rezultatach.
img007
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 07 paź 2017, 00:53
Płeć: Mężczyzna

Re: nie wykrywa karty dźwiękowej

Post autor: img007 » 14 paź 2017, 13:56

Zrobiłem upgrade do 16.04 LTS. Miałeś rację, pomogło.
Dzięki
ODPOWIEDZ

Wróć do „Multimedia - karty graficzne, dźwiękowe, telewizyjne, drukarki, skanery”