Realtek® ALC887 brak dźwięku

Karty graficzne, dźwiękowe, tv, monitory etc.
spich
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 13 cze 2017, 21:14
Wersja Ubuntu: 14.04

Realtek® ALC887 brak dźwięku

Post autor: spich » 07 sie 2017, 12:15

Hey!

Miałem U16... wszystko chodziło, ale czasem (szczególnie przy bezczynności) system się zwieszał :/ Przeszedłem na U17.04 i... zawieszanie ustało, ale nie umie znaleźć karty dźwiękowej.
Mam integre na ASUSie F2A55-M - Realtek® ALC887. System nie widzi karty :???: Co zrobić?
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3675
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: Realtek® ALC887 brak dźwięku

Post autor: jacekalex » 07 sie 2017, 12:45

spich pisze:Hey!

.....System nie widzi karty :???: Co zrobić?
Zastosować się:

https://forum.dug.net.pl/viewtopic.php? ... 51#p164151
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
spich
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 13 cze 2017, 21:14
Wersja Ubuntu: 14.04

Re: Realtek® ALC887 brak dźwięku

Post autor: spich » 10 sie 2017, 11:31

LSPCI
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8670D]
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 14)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD] FCH IDE Controller (rev 40)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] FCH PCI Bridge (rev 40)
00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 0)
00:15.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 1)
00:15.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 2)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 5
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)
04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller

LSPCI -N
00:00.0 0600: 1022:1410
00:01.0 0300: 1002:990c
00:01.1 0403: 1002:9902
00:11.0 0106: 1022:7801 (rev 40)
00:12.0 0c03: 1022:7807 (rev 11)
00:12.2 0c03: 1022:7808 (rev 11)
00:13.0 0c03: 1022:7807 (rev 11)
00:13.2 0c03: 1022:7808 (rev 11)
00:14.0 0c05: 1022:780b (rev 14)
00:14.1 0101: 1022:780c (rev 40)
00:14.2 0403: 1022:780d (rev 01)
00:14.3 0601: 1022:780e (rev 11)
00:14.4 0604: 1022:780f (rev 40)
00:15.0 0604: 1022:43a0
00:15.1 0604: 1022:43a1
00:15.2 0604: 1022:43a2
00:18.0 0600: 1022:1400
00:18.1 0600: 1022:1401
00:18.2 0600: 1022:1402
00:18.3 0600: 1022:1403
00:18.4 0600: 1022:1404
00:18.5 0600: 1022:1405
03:00.0 0200: 10ec:8168 (rev 09)
04:00.0 0c03: 1b21:1042

cat /proc/asound/cards
0 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xfeb44000 irq 32
1 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xfeb40000 irq 16

cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k4.10.0-30-generic.

uname -a
Linux spich 4.10.0-30-generic #34-Ubuntu SMP Mon Jul 31 19:38:17 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

dpkg -l | grep alsa
ii alsa-base 1.0.25+dfsg-0ubuntu5 all ALSA driver configuration files
ii alsa-utils 1.1.3-1ubuntu1 amd64 Utilities for configuring and using ALSA
ii gstreamer1.0-alsa:amd64 1.10.4-1ubuntu1 amd64 GStreamer plugin for ALSA

dpkg -l | grep pulse
ii gstreamer1.0-pulseaudio:amd64 1.10.4-1ubuntu1 amd64 GStreamer plugin for PulseAudio
ii libcanberra-pulse:amd64 0.30-3ubuntu1 amd64 PulseAudio backend for libcanberra
ii libpulse-mainloop-glib0:amd64 1:10.0-1ubuntu2 amd64 PulseAudio client libraries (glib support)
ii libpulse0:amd64 1:10.0-1ubuntu2 amd64 PulseAudio client libraries
ii libpulsedsp:amd64 1:10.0-1ubuntu2 amd64 PulseAudio OSS pre-load library
ii pulseaudio 1:10.0-1ubuntu2 amd64 PulseAudio sound server
ii pulseaudio-module-bluetooth 1:10.0-1ubuntu2 amd64 Bluetooth module for PulseAudio sound server
ii pulseaudio-utils 1:10.0-1ubuntu2 amd64 Command line tools for the PulseAudio sound server

ALSAMIXER
rozoznaje 2 karty dźwiękowe
Czip: ATI R6xx HDMI - karta graficzna
Czip: Realtek ALC887-VD

tak by to było wg https://forum.dug.net.pl/viewtopic.php? ... 51#p164151
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3675
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: Realtek® ALC887 brak dźwięku

Post autor: jacekalex » 10 sie 2017, 16:49

Chyba potrzebujesz lepsiejszego okulisty ;-) , wg tego:
https://forum.dug.net.pl/viewtopic.php? ... 51#p164151

Zrobiłbyś tak:
najpierw pobrał skrypta:

Kod: Zaznacz cały

wget http://www.alsa-project.org/alsa-info.sh
potem go uruchomił:

Kod: Zaznacz cały

bash  ~/alsa-info.sh  --with-all
Pozdro
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
spich
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 13 cze 2017, 21:14
Wersja Ubuntu: 14.04

Re: Realtek® ALC887 brak dźwięku

Post autor: spich » 11 sie 2017, 00:26

ok, wyszło to:
http://www.alsa-project.org/db/?f=995fc ... 83278ac868

Ilin napisał "Jeśli nie chcesz wklejać tyle poleceń możesz to wszystko zrobić za jednym zamachem." - ale ja chciałem ;) taka dygresja ;)

i co dalej?
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3675
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: Realtek® ALC887 brak dźwięku

Post autor: jacekalex » 11 sie 2017, 13:59

Masz tam dwa wyjścia dźwięku, w tej chwili wszystkimi kartami zajmuje się pulseaudio.

Możesz na chwilkę wyłączyć pulseaudio poleceniem:

Kod: Zaznacz cały

pulseaudio  -k
Potem uruchomić polecenie konsolowe

Kod: Zaznacz cały

alsamixer
żeby sprawdzić na obu kartach, czy jakieś kontrolki nie są wyłącozne czy ściszone.

Po czym sprawdzić, czy dźwięk w ogóle działa poleceniami:

Kod: Zaznacz cały

speaker-test -t wav -c 2 -D hw:0,3

Kod: Zaznacz cały

speaker-test -t wav -c 2 -D hw:1,0
Po którymś powinien się pojawić dźwięk górne polecenie jest do karty HDMI, dolne do jakiejś analogowej, pewnie tego Realteka.
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
spich
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 13 cze 2017, 21:14
Wersja Ubuntu: 14.04

Re: Realtek® ALC887 brak dźwięku

Post autor: spich » 11 sie 2017, 21:03

Dziękuje, udało się :)
Temat zakończony!
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3675
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

Re: Realtek® ALC887 brak dźwięku

Post autor: jacekalex » 11 sie 2017, 22:03

Jeszcze dwie uwagi:
W pierwszym poście edytujesz temat i dodajesz z przodu [SOVED] - wtedy cały świat się dowie,
że temat jest rozwiązany. :clap:

Druga sprawa, rozwiązanie, jak sobie poradziłeś: alsamixer - coś było wyciszone, czy dźwięk szedł nie na tą kartę,co trzeba, czy może coś w ustawieniach pulseaudio nie pasowało (jeśli tak, to co konkretnie). :?: :?: :?:


Każdy rozwiązany post powinien być instrukcją dla ludzi z podobnymi problemami, którzy tu jeszcze zajrzą w przyszłości, stąd takie "dziwne" obyczaje. ;-)

Pozdro
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
spich
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 13 cze 2017, 21:14
Wersja Ubuntu: 14.04

Re: Realtek® ALC887 brak dźwięku

Post autor: spich » 29 paź 2017, 08:53

ehh problem rozwiązany... no na jakiś czas tak.
co zrobiłem?

wyłaczyłem pulseaudio
uruchomiłem alsamixer i zmieniłem kartę z HDMI (choć jej nie mam fizycznie) na drugą
odpalilem speaker-test -t wav -c 2 -D hw:1,0

i wszystko chodziło...

...ale to jest bez sensu. Po odłączeniu głośników i podpięciu ich znowu nie mam dźwięku.
tym razem powyższe nie pomaga. W ogóle ubuntu wykrywa 2 karty... graficzną jako HDMI i muzyczną, przy czym ta druga jest właściwa, ale zawsze druga. Przełączenie w alsamixer nic nie daje.
Jak zmienić priorytety, tj jak ustawić właściwą kartę jako PRIMERY, a najlepiej "wywalić" HDMI?

http://www.alsa-project.org/db/?f=21280 ... caddcde0f5

Wczoraj przeszedłem na U17.10 - tak w racie co...

ma ktoś jakiś pomysł?
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6801
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Realtek® ALC887 brak dźwięku

Post autor: mario_7 » 02 lis 2017, 00:54

Czytelnia - poczytaj, Google - poszukaj
spich
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 13 cze 2017, 21:14
Wersja Ubuntu: 14.04

Re: Realtek® ALC887 brak dźwięku

Post autor: spich » 10 lis 2017, 22:31

no i fajnie...
moja właściwa karta jest jako pierwsza! super!
odpalam test:

speaker-test -t wav -c 2 -D hw:1,0

dźwięk jest...
załączam YT i cisza... inne programy... cisza!

w USTAWIENIA->DŹWIĘK zakładka WYJSCIE widnieje tylko jedno:
"Wybór urządzenia dla wyjścia dźwięku:
Głuche wyjście"

qrcze... ile można grzebać się z dźwiękiem! Zrezygnowałem z windy, bo myślałem że będzie ok, a tu najprostsze rzeczy sprawiają dalej problemy!
czegoś mi brakuje? coś doinstalować?
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6801
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Realtek® ALC887 brak dźwięku

Post autor: mario_7 » 12 lis 2017, 18:16

Zapewne mieszasz dwie rzeczy - ustawienia systemowe to PulseAudio, a ty pewnie zmiany wprwadzałeś w Alsie. Zatem zdecyduj się na jedno...
Czytelnia - poczytaj, Google - poszukaj
ODPOWIEDZ

Wróć do „Multimedia - karty graficzne, dźwiękowe, telewizyjne, drukarki, skanery”