Neofita i siec nie działa.

Przenośne komputery i problemy z nimi związane
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3948
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Neofita i siec nie działa.

Post autor: jacekalex » 16 lut 2010, 22:12

Witam

Ja w takiej małej kwestii czysto technicznej.

Średnio co kilka dni (o ile nie kilka minut) pojawia się na forum Neofita z laptopem (najczęściej) - któremu nie działa siec (zazwyczaj wifi).

I zawsze jakaś mądra głowa mu napisze:
pokaż wynik komendy:
lspci
I potem mamy listing na pół metra - pełen nieistotnych informacji o kartach graficznych, kontrolerach usb, urządzeniach dźwiękowych, i innych "sieciowych" elementach - które do sieci mają zastosowanie - jak pięść do nosa.
Czy naprawdę - podanie w miejsce komendy lspci - pytania o dokładniejszy i krótszy wynik jest bez sensu?

Przecież na kłopoty z sieciówkami najlepsze będzie np:
lspci -k | egrep -i 'network|ethernet|wireles' -A2
informacji (ilościowo 1/5 - przydatność (wyświetlane moduły przypisane do urządzeń) - znacznie większa.
A np. na kłopoty z kartą graficzną:
:~$ lspci -k | grep -i 'vga' -A2
-wynik o wiele lepszy - niż przy samym lspci.

Pomijając fakt - że o wiele lepiej się czyta 3 sensowne linijki tekstu, - niż 20 - 50 niezbyt sensownych.

To by było na tyle
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Awatar użytkownika
igotit4free
Przyjaciel
Przyjaciel
Posty: 6453
Rejestracja: 29 paź 2008, 22:51
Płeć: Mężczyzna
Architektura: x86_64
Lokalizacja: KRK

Odp: Neofita i siec nie działa.

Post autor: igotit4free » 16 lut 2010, 23:05

Czy ja wiem, czy to jest takie przydatne :
lspci -k | egrep -i 'ethernet|wireles' -A2
lspci: invalid option -- k
Usage: lspci [<switches>]

-v Be verbose
-n Show numeric ID's
-nn Show both textual and numeric ID's (names & numbers)
-b Bus-centric view (PCI addresses and IRQ's instead of those seen by the CPU)
-x Show hex-dump of the standard portion of config space
-xxx Show hex-dump of the whole config space (dangerous; root only)
-xxxx Show hex-dump of the 4096-byte extended config space (root only)
-s [[[[<domain>]:]<bus>]:][<slot>][.[<func>]] Show only devices in selected slots
-d [<vendor>]:[<device>] Show only selected devices
-t Show bus tree
-m Produce machine-readable output
-i <file> Use specified ID database instead of /usr/share/misc/pci.ids.gz
-D Always show domain numbers
-M Enable `bus mapping' mode (dangerous; root only)
-P <dir> Use specified directory instead of /proc/bus/pci
-H <mode> Use direct hardware access (<mode> = 1 or 2)
-F <file> Read configuration data from given file
-G Enable PCI access debugging

lspci -k | grep -i 'vga' -A2
lspci: invalid option -- k
Usage: lspci [<switches>]

-v Be verbose
-n Show numeric ID's
-nn Show both textual and numeric ID's (names & numbers)
-b Bus-centric view (PCI addresses and IRQ's instead of those seen by the CPU)
-x Show hex-dump of the standard portion of config space
-xxx Show hex-dump of the whole config space (dangerous; root only)
-xxxx Show hex-dump of the 4096-byte extended config space (root only)
-s [[[[<domain>]:]<bus>]:][<slot>][.[<func>]] Show only devices in selected slots
-d [<vendor>]:[<device>] Show only selected devices
-t Show bus tree
-m Produce machine-readable output
-i <file> Use specified ID database instead of /usr/share/misc/pci.ids.gz
-D Always show domain numbers
-M Enable `bus mapping' mode (dangerous; root only)
-P <dir> Use specified directory instead of /proc/bus/pci
-H <mode> Use direct hardware access (<mode> = 1 or 2)
-F <file> Read configuration data from given file
-G Enable PCI access debugging
;-)
Windows 10 @ GA-P67A-D3-B3, i3-2100 3.10GHz, 8GB RAM, Gigabyte HD6850 1GB RAM
Android 7.0 @ Motorola Moto G4+
Awatar użytkownika
kabanek
Zakręcona Traszka
Zakręcona Traszka
Posty: 591
Rejestracja: 23 cze 2009, 20:34
Płeć: Mężczyzna
Wersja Ubuntu: 13.10
Środowisko graficzne: Xfce
Architektura: x86_64
Kontakt:

Odp: Neofita i siec nie działa.

Post autor: kabanek » 16 lut 2010, 23:18

mi wyświetliło to:
bartomiej@bartek-laptop:~$ lspci -k | egrep -i 'ethernet|wireles' -A2
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8071 PCI-E Gigabit Ethernet Controller (rev 16)
Kernel driver in use: sky2
Kernel modules: sky2
03:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
Kernel driver in use: ath9k
Kernel modules: ath9k
oraz to
bartomiej@bartek-laptop:~$ lspci -k | grep -i 'vga' -A2
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Kernel driver in use: i915
Kernel modules: i915
Awatar użytkownika
Hrluc
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 206
Rejestracja: 02 maja 2008, 14:54
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Odp: Neofita i siec nie działa.

Post autor: Hrluc » 16 lut 2010, 23:20

lshw -c network
i po sprawie
Awatar użytkownika
igotit4free
Przyjaciel
Przyjaciel
Posty: 6453
Rejestracja: 29 paź 2008, 22:51
Płeć: Mężczyzna
Architektura: x86_64
Lokalizacja: KRK

Odp: Neofita i siec nie działa.

Post autor: igotit4free » 17 lut 2010, 00:10

kabanek pisze:mi wyświetliło ...
Widać były zmiany w składni lspci między wersjami zawartymi w 8.04 i 9.10 ... dlatego mądrzej będzie pozostać przy uniwersalnym lspci ewentualnie:

Kod: Zaznacz cały

lspci | grep coś_tam
.
Windows 10 @ GA-P67A-D3-B3, i3-2100 3.10GHz, 8GB RAM, Gigabyte HD6850 1GB RAM
Android 7.0 @ Motorola Moto G4+
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3948
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Odp: Neofita i siec nie działa.

Post autor: jacekalex » 17 lut 2010, 02:23

A mnie dziwnym trafem zawsze wyświetla tak:

Kod: Zaznacz cały

:~$ lspci -k | egrep -i 'network|ethernet|wireles' -A2
00:19.0 Ethernet controller: Intel Corporation 82566DC-2 Gigabit Network Connection (rev 02)
    Kernel driver in use: e1000e
    Kernel modules: e1000e
--
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    Kernel driver in use: 8139too
    Kernel modules: epl, 8139cp
07:01.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
    Kernel driver in use: 3c59x
    Kernel modules: 3c59x
- nie dość - że wyświetla tylko sieciówki - to pokazuje również moduły sterowników - prawda?

A co do "lspci: invalid option -- k" - to radzę wpisać lspci -k z klawiatury, i sprawdzić - czy działa.

Bo w 3 różnych wersjach - które mam obecnie na dysku Ubuntu Karmic/Debian Testing/Gentoo - działa zawsze.
Być może przy kopiowaniu myszką z przeglądarki jest jakiś cyrk z kodowaniem znaków.

Natomiast cały sens tego wątku - to to - żeby na przyszłość nie żądać od kogoś - kto ma problem ze sterownikiem - bezmyślnie ogólnej i w (co najmniej) 80% niepotrzebnych informacji - lecz tylko tych - które dotyczą problemu bezpośrednio.

W ten sposób samo rozwiązanie i dojście do przyczyny problemu jest wyraźnie łatwiejsze i szybsze.

Wracając składni lspci - jest ta sama od czasu - kiedy używam Linuxa - do Ubuntu 7.04.
Za to składnia kodowania znaków w przeglądarce i schowku - może się różnić - w zależności od środowiska graficznego, przeglądarki, i kilku innych rzeczy. :grin:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Awatar użytkownika
igotit4free
Przyjaciel
Przyjaciel
Posty: 6453
Rejestracja: 29 paź 2008, 22:51
Płeć: Mężczyzna
Architektura: x86_64
Lokalizacja: KRK

Odp: Neofita i siec nie działa.

Post autor: igotit4free » 17 lut 2010, 09:09

@ jacekalex:
Jeśli spojrzysz w komunikat błędu uzyskany spod 8.04 to przekonasz się, że w "podpowiedzi" brak w ogóle przełącznika k ... aplikacja nie zna takiego switcha, więc komenda nie ma waloru uniwersalności. W żadnym wypadku nie zależy to od metody wprowadzenia tekstu.

.
Windows 10 @ GA-P67A-D3-B3, i3-2100 3.10GHz, 8GB RAM, Gigabyte HD6850 1GB RAM
Android 7.0 @ Motorola Moto G4+
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3948
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Odp: Neofita i siec nie działa.

Post autor: jacekalex » 17 lut 2010, 18:29

A u mnie w 8.04 ta komenda działała, trzy dni temu sprawdzałem w Debianie Lenny - też działała.

A jeśli Ubuntu 8.04 LTS ma zwalony skrypt lspci - to czyja to wina?

To - że w jakimś programie jest błąd, to nie znaczy - że mamy się do błędów dopasowywać.

A co do Ubuntu 8.04 i 8.10, to doświadczenia z NM, PA i setką innych błędów były przyczyną akcji paper-cut,nie dlatego, - że nie miały błędów, ale dlatego - że ilość błędów zaczęła zagrażać istnieniu Ubuntu jako dystrybucji Linuxa.

A cały sens wątku - jak ktoś zgłasza problem - to pytajmy o informacje istotne dla rozwiązania problemu - a nie o tonę danych, zupełnie nie istotnych, które tylko zaśmiecają forum.
I nie upieram się tylko o lspci -k, lshw -c network też może być.

Byle informacje dotyczyły poruszanego tematu - w sposób zwięzły i ścisły.

To by było na tyle.
;)
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Awatar użytkownika
mths
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 101
Rejestracja: 18 maja 2008, 01:19
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: KDE 3/Trinity
Architektura: x86_64

Odp: Neofita i siec nie działa.

Post autor: mths » 17 lut 2010, 19:03

Kod: Zaznacz cały

> lspci
zsh: command not found: lspci
też mi nie działa. może bardziej uniwersalne byłoby użycie dmesg | grep pci albo sysctl -a | grep pci ? ;)
FreeBSD - live free or die.
Keep it simple, stupid.
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3948
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Odp: Neofita i siec nie działa.

Post autor: jacekalex » 17 lut 2010, 19:10

Wszystko jedno jak - byle był czytelny i przejrzysty wynik - pokazujący istotę problemu.

A nie tak - jak ostatnio - gdzie nie działa wifi, - ktoś pyta o lspci - wynik na pół metra, a co do Atherosa (jakimś cudem wyczaiłem go w listingu) - i tak nie wiadomo, - na jakim sterowniku nie chce chodzić.

Po za tym na "Innym OS" lspci nie chce chodzić?

Forum jest Ubuntu - dotyczy Linuksa, a czy ten InnyOS - to jest Linux - czy np. *BSD?
Bo na forum bsdguru nie widziałem - żeby ktoś pytał o wynik lscpi ;)

A zsh - to też nietypowe - jak na początkującego użytkownika Ubuntu, gdzie domyślnie dostępny jest bash.

To by było na tyle.
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Awatar użytkownika
majsza
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1193
Rejestracja: 03 cze 2008, 13:32
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Neofita i siec nie działa.

Post autor: majsza » 27 kwie 2011, 20:27

Kod: Zaznacz cały

~$ lspci -k | egrep -i 'network|ethernet|wireles' -A2
09:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
	Kernel driver in use: 8139too
	Kernel modules: 8139too, 8139cp
09:04.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
	Kernel modules: ath5k
Rzeczywiście dużo przejrzyściej :D
ODPOWIEDZ

Wróć do „Laptopy”