Problem z Pendrive'ami - "System plikow wylacznie do odczytu"

Tylko tematy nie mieszczące się powyżej.
Rafał Zarzycki
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 25 wrz 2015, 22:56

Problem z Pendrive'ami - "System plikow wylacznie do odczytu"

Post autor: Rafał Zarzycki » 05 gru 2016, 14:14

Witam Was moi drodzy!

Jestem swiezym uzytkownikiem UBUNTU 14.04 LTS (polska wersja). Mam problem z moimi pendriveami pod Ubuntu. Otoz nie moge nic na nich zapisac, ani usunac, gdyz od jakiegos czasu wyskakuje komunikat "System plikow wylacznie do odczytu".

Za Chiny nie potrafie zmienic tych uprawnien, probowalem wszystkiego.

Z tego co patrzylem przez angielskie google nie tylko ja mam z tym problem. Niestety, zadne ze znalezionych tam rozwiazan nie zadzialalo u mnie. Nie ukrywam, ze jestem lekko sfrustrowany, pierwsze zetkniecie z oslawionym Linuxem nie wypadlo tak dobrze jak oczekiwalem (oczekiwalem zwlaszcza duzej stabilnosci systemu). Na poczatku Chromium notorycznie zawieszal mi caly system, nastepnie to samo robila wtyczka Adobe Flash w Mozilli (powodowala samoczynne zamykanie sie systemu podczas proby ogladania filmikow). Do tego teraz jeszcze problem z pendriveami. Nie rozumiem dlaczego jako Administator nie moge zapisac ani skasowac danych na moich pendriveach.

Dlatego zwracam sie o pomoc do bardziej doswiadczonych uzytkownikow, jak domniemam m.in. po to chyba jest to forum :)

Pozdrawiam serdecznie,

Rafał Zarzycki
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6884
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Problem z Pendrive'ami - "System plikow wylacznie do odczytu"

Post autor: mario_7 » 07 gru 2016, 09:53

Podepnij pendrive i wykonaj polecenie:

Kod: Zaznacz cały

dmesg | tail -n 40
Pokaż co się pojawiło.
Czytelnia - poczytaj, Google - poszukaj
Rafał Zarzycki
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 25 wrz 2015, 22:56

Re: Problem z Pendrive'ami - "System plikow wylacznie do odczytu"

Post autor: Rafał Zarzycki » 07 gru 2016, 18:46

Kod: Zaznacz cały

[  591.298105] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  596.073497] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  602.075895] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  609.860402] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  628.970825] sd 5:0:0:0: [sdb] Test WP failed, assume Write Enabled
[  628.972440] sd 5:0:0:0: [sdb] Asking for cache data failed
[  628.972450] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[  669.268131] [UFW BLOCK] IN=wlan0 OUT= MAC=01:00:5e:00:00:01:9c:97:26:cd:a1:54:08:00 SRC=192.168.1.254 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=7901 DF PROTO=2 
[  681.194844] sd 5:0:0:0: [sdb] Test WP failed, assume Write Enabled
[  681.196460] sd 5:0:0:0: [sdb] Asking for cache data failed
[  681.196468] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[  733.420234] sd 5:0:0:0: [sdb] Test WP failed, assume Write Enabled
[  733.421835] sd 5:0:0:0: [sdb] Asking for cache data failed
[  733.421843] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[  784.034555] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  785.644244] sd 5:0:0:0: [sdb] Test WP failed, assume Write Enabled
[  785.645838] sd 5:0:0:0: [sdb] Asking for cache data failed
[  785.645844] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[  788.776162] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  791.679096] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  794.217822] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  794.297812] [UFW BLOCK] IN=wlan0 OUT= MAC=01:00:5e:00:00:01:9c:97:26:cd:a1:54:08:00 SRC=192.168.1.254 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=8138 DF PROTO=2 
[  797.788525] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  837.868243] sd 5:0:0:0: [sdb] Test WP failed, assume Write Enabled
[  837.869857] sd 5:0:0:0: [sdb] Asking for cache data failed
[  837.869866] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[  840.458202] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  843.338906] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  845.557281] FAT-fs (sdc1): error, fat_get_cluster: invalid cluster chain (i_pos 0)
[  890.090599] sd 5:0:0:0: [sdb] Test WP failed, assume Write Enabled
[  890.092369] sd 5:0:0:0: [sdb] Asking for cache data failed
[  890.092376] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[  913.237297] systemd-hostnamed[7385]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
[  919.327678] [UFW BLOCK] IN=wlan0 OUT= MAC=01:00:5e:00:00:01:9c:97:26:cd:a1:54:08:00 SRC=192.168.1.254 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=8154 DF PROTO=2 
[  942.316153] sd 5:0:0:0: [sdb] Test WP failed, assume Write Enabled
[  942.317753] sd 5:0:0:0: [sdb] Asking for cache data failed
[  942.317760] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[  994.538642] sd 5:0:0:0: [sdb] Test WP failed, assume Write Enabled
[  994.540256] sd 5:0:0:0: [sdb] Asking for cache data failed
[  994.540264] sd 5:0:0:0: [sdb] Assuming drive cache: write through

Dodam jeszcze tylko, ze na dana chwile mam problem z 2 z moich 5 pendrive'ow. Z tym, ze na jednym klodeczki na folderach pojawiaja sie np. po wejsciu do jakiegos katalogu i wyjsciu z niego. Zanim to zrobie moge normalnie dodawac i kasowac pliki i foldery z tego pendrive'a. Ale potem juz blokada i komunikat "System plikow wylacznie do odczytu". Natomiast na drugim pendrive caly czas jest blokada i loga klodeczek na folderach.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6884
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Problem z Pendrive'ami - "System plikow wylacznie do odczytu"

Post autor: mario_7 » 09 gru 2016, 14:26

Wygląda na to, że partycje na dyskach przenośnych są uszkodzone. Zrób kopie zapasowe istotnych danych i wykonaj fsck na problematycznych partycjach. Pamiętaj, aby odmontowywać urządzenia przed wyciągnięciem z portu USB.
Czytelnia - poczytaj, Google - poszukaj
kurzy
Sędziwy Jeż
Sędziwy Jeż
Posty: 68
Rejestracja: 03 kwie 2008, 13:04
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME

Re: Problem z Pendrive'ami - "System plikow wylacznie do odczytu"

Post autor: kurzy » 29 paź 2017, 22:45

Jeśli mogę, to "podepnę się" pod ten temat.
Po upgrade do Ubuntu 17.10 wszystkie podłączane do komputera pendrive'wy są jedynie do odczytu. Nie mogę nic skopiować do, założyć folderu etc. Za każdy razem wyskakuje komunikat: "Miejsce docelowe jest tylko do odczytu". Co mogę z tym zrobić?
Z góry dzięki za podpowiedzi.
pajak1000
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 22 paź 2012, 23:07
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Architektura: x86_64

Re: Problem z Pendrive'ami - "System plikow wylacznie do odczytu"

Post autor: pajak1000 » 30 paź 2017, 23:00

Witaj @kurzy
Właśnie przetestowałem 3 pendrive i 2 czytniki kart sd isd-hc i u mnie wszystko lata w najlepszym porządku sprawdziłem na usb 2.0 i 3.0 mogę tworzyć kopiować przenosić . Spróbuj może użyć MC comander w trybie administratora
sudo mc
/media/nazwa użytkownika/twój pendrive
ODPOWIEDZ

Wróć do „Inne”