Separate screen 1 - czarny ekran z myszką w postaci X

Tematy specyficzne dla poszczególnych window managerów: KDE, GNOME, XFCE, Fluxbox, Blackbox, IceWM, WindowMaker, itd. - wszystko tutaj.
Cuthbert75
Sędziwy Jeż
Sędziwy Jeż
Posty: 39
Rejestracja: 20 sty 2007, 06:17
Płeć: Mężczyzna
Wersja Ubuntu: 17.04
Środowisko graficzne: KDE4
Architektura: x86_64

Separate screen 1 - czarny ekran z myszką w postaci X

Post autor: Cuthbert75 » 19 cze 2017, 23:17

Witam,
Lat już kilka nie pisałem na forum znajdując do tej pory gotowe rozwiązania w internecie.
Tym razem utknąłem na dobre.
Próbuję uruchomić dodatkową sesję X na osobnym monitorze i jedyne co otrzymuję to czarny ekran po którym przesuwa się kursor w kształcie X.
Mam kubuntu16.04 i zainstalowane sterowniki nvidia. Zmiany w pliku xorg.conf wpływają na konfigurację monitorów.
Jeśli ustawię 2 monitory na X screnn 0 mam obraz na 2 monitory.
Jak tylko zmienię konfigurację aby jeden wyświetlał screen1 mam efekt pustego ekranu na monitorze dedykowanym dla screen1
Nie mam już żadnego pomysłu czego szukać w internecie aby odpalić dodatkowy serwer X na drugim monitorze.

Załączony fragment xorg.conf zawiera konfigurację drugiej karty grafiki - w pierwszej wersji chciałem mieć sesję X na 3 monitorach z użyciem opcji Mosaic ale tutaj też poległem.
Wyczytałem, że Mosaic nie odpalę na różnych kartach grafiki więc dałem sobie z tym na razie spokój. W każdym razie pusty ekran mam zawsze, niezależnie gdzie podłączę 2 monitor.

Będę bardzo wdzięczny za naprowadzenie na właściwy trop...

Kod: Zaznacz cały

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics W2242"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: unknown, VertRefresh source: unknown
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "LG Electronics L1734"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 4600"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro NVS 290"
    BusID          "PCI:3:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DVI-I-3: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6883
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Separate screen 1 - czarny ekran z myszką w postaci X

Post autor: mario_7 » 21 cze 2017, 09:02

Czytelnia - poczytaj, Google - poszukaj
Cuthbert75
Sędziwy Jeż
Sędziwy Jeż
Posty: 39
Rejestracja: 20 sty 2007, 06:17
Płeć: Mężczyzna
Wersja Ubuntu: 17.04
Środowisko graficzne: KDE4
Architektura: x86_64

Re: Separate screen 1 - czarny ekran z myszką w postaci X

Post autor: Cuthbert75 » 02 lip 2017, 22:46

MultiseatX nie wydaje mi się być odpowiedzią na mój problem.
Przynajmniej pod wskazanym linkiem nie znalazłem niczego co by mnie naprowadziło na rozwiązazanie problemu.
Również rozwiązania podane w linku dotyczą dość "archiwalnych (13.04)" wersji ubuntu

W międzyczasie zainstalowałem ubuntu 17.04 i tutaj wydaje się być trochę lepiej.
W przeciwieństwie do KDE, które na driverze Nouveau próbowało zagotować kartę grafiki NVS 290, tutaj wydaje się że wszystko pracuje poprawnie.
PIszę wydaje się, ponieważ monitor podpięty pod NVS 290 jest dalej cały czarny, ale kursor myszki jest już normalny!
Niestety nie mogę przenosić okien aplikacji na ten ekran.
Wygląda to tak jakby monitor NVS 290 pracował jako osoby screen ale nigdzie nie moge się doszukac jak włączyć go do screen1.
Od biedy inc by się nie stało gdyby pracował jako kolejny screen - mogę odżałować przenoszenie okien na rzecz uruchamiania aplikacji ale jak to zrobić!
Zdesperowany już zaczynam mysleć o przesiadce na windows na tym stanowisku i to po 15 latach użytkowania ubuntu/kubuntu!

Po zainstalowaniu sterowników nvidia jest już tylko gorzej. Monitor na NVS 290 mogę odpalić tylko jako Separate screen. Od razu pojawiają się też problemy w wyświetlaniu zawartosćci dwóch podstawowych monitorów.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6883
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Separate screen 1 - czarny ekran z myszką w postaci X

Post autor: mario_7 » 03 lip 2017, 13:35

Chyba nie wiesz o czym piszesz... osobna sesja X oznacza że nie będzie można przeciągnąć okien. To tak jakbyś drugi raz chciał uruchomić środowisko graficzne. Czarny ekran z kursorem masz pewnie dlatego, że nie uruchomiłeś nic poza samymi X-ami.

Jeśli chcesz mieć jeden wspólny pulpit, to po prostu użyj rozszerzonego ekranu.
Czytelnia - poczytaj, Google - poszukaj
Cuthbert75
Sędziwy Jeż
Sędziwy Jeż
Posty: 39
Rejestracja: 20 sty 2007, 06:17
Płeć: Mężczyzna
Wersja Ubuntu: 17.04
Środowisko graficzne: KDE4
Architektura: x86_64

Re: Separate screen 1 - czarny ekran z myszką w postaci X

Post autor: Cuthbert75 » 27 paź 2017, 21:47

Po dłuższej przerwie wynikającej z braku czasu wracam do tematu.
Przesiadłem się na kubuntu 17.04 i jest dalej to samo czyli monitor podpięty pod drugą kartę grafiki NVS 290 jest czarny a kursor na nim pojawia się w postaci dużego X.
Z tego co się doczytałem na moich kartach grafiki główna FX4600 i dodatkowa NVS 290 nie uda mi się uzyskać rozszerzonego pulpitu.
W ustawieniach nvidia x server settings ver 340.102 monitory podpięte pod kartę NVS 290 mogę ustawić tylko na screen1 lub je wyłączyć.

Godzę się na to, że nie będę mógł przesuwać okien na te monitory. Chodzi mi o to aby uruchomić na razie na nich jakąkolwiek funkcjonalność.
Spróbowałem polecenia startx -- :1 które wg mojego stanu wiedzy powinno uruchomić drugą sesję X na screen1.
Niestety uruchamia ją dokładnie tak samo jak pierwszą tzn na monitorze podpiętym pod FX4600 a na drugiej czarny ekran z myszą w postaci X, ale uwaga! przy wylogowaniu się z tej sesji POJAWIA SIĘ wybór opcji wylogowania/zamknięcia na monitorze podpiętym pod NVS 290.

Będę bardzo wdzięczny za pomoc jak to rozwiązać.
Może jest to kwestia pliku xorg.conf?
Kiedyś był w etc, potem podobno przewędrował w inne miejsce. Teraz zapisałem go z poziomu graficznego konfiguratora nvidia pod inną nazwą w katalogu domowym.
Może nowa sesja, którą próbuję uruchomić nie wie co to jest screen1?
Gdzie powinien być wgrany w tej chwili plik xorg.conf tak aby "widziało" go polecenie startx -- :1?

W tej chwili mój xorg.conf w etc/x11 wygląda jak poniżej i wg mnie monitor LG Electronics L1734 jest prawidłowo połączony z Screen1

Kod: Zaznacz cały

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 367.35  (buildd@lgw01-18)  Tue Aug  9 10:11:49 UTC 2016

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics W2242"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: unknown, VertRefresh source: unknown
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "LG Electronics L1734"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 4600"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro NVS 290"
    BusID          "PCI:3:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DVI-I-3: 1680x1050_60_0 +0+0, DVI-I-2: nvidia-auto-select +1680+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Cuthbert75
Sędziwy Jeż
Sędziwy Jeż
Posty: 39
Rejestracja: 20 sty 2007, 06:17
Płeć: Mężczyzna
Wersja Ubuntu: 17.04
Środowisko graficzne: KDE4
Architektura: x86_64

Re: Separate screen 1 - czarny ekran z myszką w postaci X

Post autor: Cuthbert75 » 01 lis 2017, 22:29

Kolejny dzień zabawy z kartami grafiki...
Sterownik nouveau w kbuntu 17.04 wyświetla na trzecim monitorze też czarny ekran ale z normalnym kursorem. Co najlepsze podczas uruchamiania systemu pojawia się na nim logo Kubuntu a potem znika. Tak samo podczas zamykania systemu pojawia się okno z wyborem opcji zamknięcia/wylogowania/itp.
A więc grafika działa jak trzeba tylko kubuntu/ubuntu/fedora26 (też jej próbowałem) nie potrafi nic na niej wyświetlić....
Aha, no i sterownik nvidia zawieszał mi system przy zamykaniu systemu więc go jednak wywaliłem na dobre.

Liczę nadal na pomoc forum.
Pozdrawiam
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6883
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Separate screen 1 - czarny ekran z myszką w postaci X

Post autor: mario_7 » 02 lis 2017, 00:07

Czy próbowałeś po prostu ustawić monitory z poziomu ustawień systemu bez kombinowania z plikiem xorg.conf?
Sprawdzałeś co zgłasza serwer X w logu: /var/log/Xorg.0.log ?
Czytelnia - poczytaj, Google - poszukaj
ODPOWIEDZ

Wróć do „Środowiska graficzne”