ADSL w Ubuntu 9.10

Neostrada, DialNet, Net24
ati81

Odp: ADSL w Ubuntu 9.10

Post autor: ati81 » 15 lis 2009, 13:24

Łuk@$z pisze:Próbował ktoś odpalić neta z Netii na łączach tp z modemem Sagem fast 800? W ciemno nie będę instalował 9.10, bo bez neta zostane :/
Tak ja, ale przez linnet

Fakt faktem troche klepania przy starcie ale chodzi..
Awatar użytkownika
Endriu48
Piegowaty Guziec
Piegowaty Guziec
Posty: 10
Rejestracja: 08 lut 2006, 17:41
Płeć: Mężczyzna
Wersja Ubuntu: 10.10
Środowisko graficzne: GNOME
Architektura: x86
Kontakt:

Odp: ADSL w Ubuntu 9.10

Post autor: Endriu48 » 16 lis 2009, 22:07

W moim przypadku Neostrada na ST330 za pomocą linnet działa z terminala root wpisaniem polecenia :
"pppd call linnet" :-)
Prawo Murphy'ego:
"Nic nie jest tak proste, jak się wydaje".
Goku024
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 21 lis 2008, 14:48
Płeć: Mężczyzna
Środowisko graficzne: Inne
Architektura: x86_64
Lokalizacja: Jasło
Kontakt:

Odp: ADSL w Ubuntu 9.10

Post autor: Goku024 » 19 lis 2009, 21:36

Kamilious mam do Ciebie pytanie a czy instalowałeś jakieś sterowniki do modemu? I jakiego modemu używasz? I czy jak się konfiguruje przez network managera to trzeba stery? Ja mam ZXDSL 852.
Kamilious
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 02 lis 2009, 14:32
Płeć: Mężczyzna
Wersja Ubuntu: 9.10
Środowisko graficzne: GNOME
Architektura: x86

Odp: ADSL w Ubuntu 9.10

Post autor: Kamilious » 20 lis 2009, 10:00

Goku024 nie instalowałem żadnych sterowników do modemu, połączyłem się "tymczasowo" z siecią komendą pppoeconf aby poszukać rozwiązania problemu, odszukałem je na zagranicznej stronie, dopisalem do repozytoriów adres z aktualizacjami dla NetworkManagera, pobrałem aktualizacje, zrestartowałem komputer, pozbyłem się wpisów po "pppoeconf" i ustawiłem połączenie z siecią za pomocą ikonki NetworkManagera w trayu, który po pobraniu poprawek działał już okej.

Mój modem to Asmax AR801MP który podłącza się do karty sieciowej w komputerze(żadne USB), sterowników żadnych nie ma, ani pod Linuxa ani pod Windowsa(tutaj tylko aplikację dostępową do internetu od Dialogu instaluję).
adrikux

Odp: ADSL w Ubuntu 9.10

Post autor: adrikux » 20 lis 2009, 10:20

necrophis pisze:Nowe UbuDSL dla 9.10 nie wyszło
Założe się, że zainstalowane z paczek dla 9.04 także zadziała.
Szarpiwar
Sędziwy Jeż
Sędziwy Jeż
Posty: 76
Rejestracja: 14 paź 2006, 08:51
Płeć: Mężczyzna
Wersja Ubuntu: 10.10
Środowisko graficzne: GNOME
Architektura: x86_64

Odp: ADSL w Ubuntu 9.10

Post autor: Szarpiwar » 20 lis 2009, 15:18

przy próbie instalacji wywala się, że nie wspiera wersji 9.10. Aczkolwiek mi po aktulace z 9.4 na 9.10 działa bez problemu, więc można próbować.
ionash.
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 200
Rejestracja: 02 mar 2007, 18:48
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: Unity
Architektura: x86

Odp: ADSL w Ubuntu 9.10

Post autor: ionash. » 20 lis 2009, 19:43

Instalacja przebiega normalnie, komunikat o nie wspieranym systemie pojawia się przy próbie konfiguracji. Jest to banalna przeszkoda, gdyż wystarczy sobie dopisać 9.10 do listy obsługiwanych systemów w pliku /usr/share/ubudsl/configs/system.ini.
Poza tym, w wątku obok podawany był link do paczek z ubudsl, które już tych zabiegów nie wymagają. Wystarczy tylko się rozejrzeć.
mszk8af
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 04 paź 2009, 16:30
Płeć: Mężczyzna
Wersja Ubuntu: 8.10
Środowisko graficzne: GNOME
Architektura: x86

Odp: ADSL w Ubuntu 9.10

Post autor: mszk8af » 27 lis 2009, 10:17

Na ubutntu 9.10 nie idzie dobrze skomplikować sterowników do ZX DSL 852 (V2). Ubuntu instaluje sterowniki, później widzi modem ale żadna dioda nawet nie mrugnie. na 8.10 wszystko działa idealnie jak ten problem rozwiązać?
michal12345
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 119
Rejestracja: 13 cze 2007, 20:57
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: GNOME
Architektura: x86
Kontakt:

Odp: ADSL w Ubuntu 9.10

Post autor: michal12345 » 27 lis 2009, 17:11

mszk8af pisze:Na ubutntu 9.10 nie idzie dobrze skomplikować sterowników do ZX DSL 852 (V2). Ubuntu instaluje sterowniki, później widzi modem ale żadna dioda nawet nie mrugnie. na 8.10 wszystko działa idealnie jak ten problem rozwiązać?

Wątek cały czytałeś? Strona wcześniej i jest odp:

viewtopic.php?p=660351#p660351
Awatar użytkownika
Bisiek
Piegowaty Guziec
Piegowaty Guziec
Posty: 4
Rejestracja: 26 lis 2009, 13:51
Płeć: Mężczyzna
Wersja Ubuntu: 9.04
Środowisko graficzne: KDE Plasma
Architektura: x86

Odp: ADSL w Ubuntu 9.10

Post autor: Bisiek » 27 lis 2009, 23:49

Czyli nie ma szans na mojego neta w 9.10 (i nowszych)? Mam ZTE ZXDSL 852 v.2.
michal12345
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 119
Rejestracja: 13 cze 2007, 20:57
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: GNOME
Architektura: x86
Kontakt:

Odp: ADSL w Ubuntu 9.10

Post autor: michal12345 » 28 lis 2009, 10:08

Bisiek pisze:Czyli nie ma szans na mojego neta w 9.10 (i nowszych)? Mam ZTE ZXDSL 852 v.2.
Na tym modemie akurat nie.
ruphert
Sędziwy Jeż
Sędziwy Jeż
Posty: 38
Rejestracja: 30 lis 2009, 07:33
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: GNOME
Architektura: x86_64

Odp: ADSL w Ubuntu 9.10

Post autor: ruphert » 30 lis 2009, 19:47

adrian5632 pisze:ZXDSL 852 (ten nowszy) nie będzie działał na Ubuntu 9.10 (i ogólnie na innych dystrybucjach z jądrami nowszymi od 2.6.2x. Sterownik wymaga łatek.
viewtopic.php?p=674682#p674682
traum
Sędziwy Jeż
Sędziwy Jeż
Posty: 33
Rejestracja: 08 lut 2008, 22:23
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Xfce
Architektura: x86_64

Odp: ADSL w Ubuntu 9.10

Post autor: traum » 02 gru 2009, 09:59

Kamilious pisze:Goku024 nie instalowałem żadnych sterowników do modemu, połączyłem się "tymczasowo" z siecią komendą pppoeconf aby poszukać rozwiązania problemu, odszukałem je na zagranicznej stronie, dopisalem do repozytoriów adres z aktualizacjami dla NetworkManagera, pobrałem aktualizacje, zrestartowałem komputer, pozbyłem się wpisów po "pppoeconf" i ustawiłem połączenie z siecią za pomocą ikonki NetworkManagera w trayu, który po pobraniu poprawek działał już okej.

Mój modem to Asmax AR801MP który podłącza się do karty sieciowej w komputerze(żadne USB), sterowników żadnych nie ma, ani pod Linuxa ani pod Windowsa(tutaj tylko aplikację dostępową do internetu od Dialogu instaluję).
mam taki sam modem (Asmax AR801MP), z komendą "pppoeconf" poszło bez problemu (tylko trzeba pamiętać żeby wykasować w konfiguratorze "username:" i dopiero potem wpisywać nazwę użytkownika (3 godziny walki:grin:)

teraz pytanie: gdzie wykasować wpisy po "pppoeconf", bo chyba mi się miesza z Network Managerem i co chwile traci sygnał i łączy się na nowo
Kamilious
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 02 lis 2009, 14:32
Płeć: Mężczyzna
Wersja Ubuntu: 9.10
Środowisko graficzne: GNOME
Architektura: x86

Odp: ADSL w Ubuntu 9.10

Post autor: Kamilious » 04 gru 2009, 09:51

Mnie udało się rozwiązać wszelkie problemy dzięki temu co tutaj zostało napisane przez naszych kolegów z zagranicy http://ubuntuforums.org/showthread.php?t=1303876&page=2 , skrótowo opisałem wszystko w moim pierwszym poście.
GosQ
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 05 mar 2008, 19:13
Płeć: Mężczyzna
Wersja Ubuntu: 9.10
Środowisko graficzne: GNOME
Architektura: x86

Odp: ADSL w Ubuntu 9.10

Post autor: GosQ » 06 gru 2009, 10:14

Adagio Dark pisze:Linnet ładnie działa, ale kiedy używam polecenia:

Kod: Zaznacz cały

./linnet -a
To po restarcie systemu internet nie działa i muszę go włączać ręcznie za pomocą odpowiedniego polecenia. Jest to trochę męczące :wall:
Można jakoś inaczej dodać linnet do autostartu?
u mnie automatycznie łączy z netem po dodaniu do programów startowych programu z komendą "pppd call linnet"
traum
Sędziwy Jeż
Sędziwy Jeż
Posty: 33
Rejestracja: 08 lut 2008, 22:23
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Xfce
Architektura: x86_64

Odp: ADSL w Ubuntu 9.10

Post autor: traum » 06 gru 2009, 15:56

Kamilious piszesz, że:
pozbyłem się wpisów po "pppoeconf"
a z opisów angielskich nie mogę nic znaleźć, pamiętasz co i gdzie usuwałeś?
Kamilious
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 02 lis 2009, 14:32
Płeć: Mężczyzna
Wersja Ubuntu: 9.10
Środowisko graficzne: GNOME
Architektura: x86

Odp: ADSL w Ubuntu 9.10

Post autor: Kamilious » 07 gru 2009, 10:09

Po aktualizacji NetworkManagera, usunąłem wszelkie wpisy zostawione przez pppoeconf sudo gedit /etc/network/interfaces

tak wygląda zawartość tego pliku aktualnie u mnie:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

oraz

używając sudo gedit/etc/NetworkManager/nm-system-settings.conf
zmieniłem "managed=flase" na "true"
później restart i konfiguracja NetworkManagera po czym połączenia w nim ustawione powinny działać.

Wszystko to jest napisane na tym forum do którego zostawiłem linka w poprzednim poście.
quacky
Piegowaty Guziec
Piegowaty Guziec
Posty: 13
Rejestracja: 28 wrz 2009, 22:58
Płeć: Mężczyzna
Wersja Ubuntu: 9.04
Środowisko graficzne: GNOME
Architektura: x86

Odp: ADSL w Ubuntu 9.10

Post autor: quacky » 08 gru 2009, 21:21

post do usunięcia
ruphert
Sędziwy Jeż
Sędziwy Jeż
Posty: 38
Rejestracja: 30 lis 2009, 07:33
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: GNOME
Architektura: x86_64

Odp: ADSL w Ubuntu 9.10

Post autor: ruphert » 10 gru 2009, 09:29

Kamilious pisze:Nie wiem, czy w tej chwili siedzisz na Ubunciaku, łącząc się dzięki komendzie pppoeconf czy piszesz np spod Windowsa, zatem postaram się to wyjaśnić w miarę zrozumiale, najwyżej któryś z bardziej doświadczonych forumowiczów poprawi mnie.
Jeśli nie działa Ci Network Manager i nie masz połączenia z siecią na swoim Ubuntu 9.10, możesz skonfigurować "tymaczasowo" połączenie za pomocą komendy sudo pppoeconf wpisanej w terminalu. Pojawi się menu konfiguracyjne wciskasz kolejno tak/yes , gdy poprosi o login dostępowy do netu i hasło, wpisujesz je(to które masz od swojego dostawcy internetu w moim przypadku od Dialogu), Po konfiguracji łączysz się z siecią komendą sudo pon dsl-provider w ten sposób powinieneś uzyskać połączenie z siecią.

Następnie musisz dopisać dwie linijki do pliku z adresami repozytoriów, komenda sudo gedit /etc/apt/sources.list

wstawiasz później te dwie linijki:

deb http://ppa.launchpad.net/network-manager/trunk/ubuntu karmic main
deb-src http://ppa.launchpad.net/network-manager/trunk/ubuntu karmic main

zapisujesz, odpalasz Menadzer Aktualizacji, powinno odświeżyć swoja bazę i pokazać nowe aktualizacji dla Network Managera, klikasz żeby je pobrał i zainstalował, robisz restart komputera o który sam poprosi.
Wpisujesz w Netowork Managerze raz jeszcze ustawienia swojego ADSL tj. login i pass po czym powinno działać.

W razie czego użyj jeszcze komendy sudo gedit /etc/NetworkManager/nm-system-settings.conf i zmień na końcu managed=false na managed=true


Jakby były jeszcze jakieś problemy to proszę badziej doświadczonych kolegów o jeszcze jaśniejsze wyjaśnienie koledze co i jak, niestety nie mam daru tłumaczenia oraz cierpliwości ;)

ps. załączam skrina na którym widać w tray ikonkę działąjącego już u mnie NM
Obrazek

To miło że Network Manager działa, ale jak napisałeś on działa tylko na modemach ADSL podłączanych przez kartę ethernet. 99% ludzi na tym forum korzysta z chamskich modemów USB i tam Network Manager nie będzie działał. Dlatego Twój opis jest niestety mało przydatny dla większości...

Mam pytanie do właścicieli modemów ZXDSL v2, czy ten modem oprócz steorwnika wymaga jeszcze jakiegoś firmware?
michal12345
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 119
Rejestracja: 13 cze 2007, 20:57
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: GNOME
Architektura: x86
Kontakt:

Odp: ADSL w Ubuntu 9.10

Post autor: michal12345 » 10 gru 2009, 17:06

ruphert pisze:Mam pytanie do właścicieli modemów ZXDSL v2, czy ten modem oprócz steorwnika wymaga jeszcze jakiegoś firmware?
Co prawda ja nie używam, ale wiem że ten modem w wersji 2 nie używa żadnego firmware.
ODPOWIEDZ

Wróć do „ADSL”