[SOLVED][Quantal][XFCE 4.10] Niedziałające guziki hibernacji

chkdsk
Piegowaty Guziec
Piegowaty Guziec
Posty: 4
Rejestracja: 01 paź 2012, 00:52
Płeć: Mężczyzna
Wersja Ubuntu: 13.04
Środowisko graficzne: XFCE
Architektura: x86_64

[SOLVED][Quantal][XFCE 4.10] Niedziałające guziki hibernacji

Post autor: chkdsk » 01 paź 2012, 01:04

Witam,

Mam problem z hibernacją w swoim Xubuntu. Sama hibernacja działa bezproblemowo, ale tylko z poziomu konsoli i wykonywana jako root lub poprzez sudo.

Nie są natomiast aktywne przyciski hibernacji w xfce4-power-manager oraz w menu końca sesji.

Ponadto nie da się wybrać hibernacji w opcjach zasilania.

Przeszukałem już kilka razy googla, ale nie mogę znaleźć rozwiązania. Co z tym fantem zrobić?
Ostatnio zmieniony 01 paź 2012, 12:53 przez chkdsk, łącznie zmieniany 1 raz.
JerryG
Zakręcona Traszka
Zakręcona Traszka
Posty: 914
Rejestracja: 28 lut 2008, 21:22
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: KDE4
Architektura: x86_64

Re: [Quantal][XFCE 4.10] Niedziałające guziki hibernacji

Post autor: JerryG » 01 paź 2012, 01:11

Nie wiem czy to u Ciebie zadziala ale mozesz sprobowac.
W swoim edytorze tworzysz plik com.ubuntu.enable-hibernate.pkla o zawartosci:

Kod: Zaznacz cały

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
i zapisujesz w

Kod: Zaznacz cały

/etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
- - - - - - - - - - - - - - - - - - -
Samsung NP-RF511-S05PL i7, GeForce GT 540M, BCM4313
chkdsk
Piegowaty Guziec
Piegowaty Guziec
Posty: 4
Rejestracja: 01 paź 2012, 00:52
Płeć: Mężczyzna
Wersja Ubuntu: 13.04
Środowisko graficzne: XFCE
Architektura: x86_64

Re: [Quantal][XFCE 4.10] Niedziałające guziki hibernacji

Post autor: chkdsk » 01 paź 2012, 02:04

Dodałem ten plik już wcześniej, zrestartowałem i niestety nic nie pomogło.
Awatar użytkownika
majsza
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1193
Rejestracja: 03 cze 2008, 13:32
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: XFCE
Architektura: x86_64
Kontakt:

Re: [Quantal][XFCE 4.10] Niedziałające guziki hibernacji

Post autor: majsza » 01 paź 2012, 10:20

Na moim Xubuntu 12.10 przycisk uaktywnił się po:

Kod: Zaznacz cały

sudo touch /etc/polkit-1/localauthority/50-local.d/com.ubuntu.desktop.pkla

Kod: Zaznacz cały

sudo nano  /etc/polkit-1/localauthority/50-local.d/com.ubuntu.desktop.pkla
Później

Kod: Zaznacz cały

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
Potem Ctrl+O. Enter przy nazwie. Nastepnie Ctrl+X.
Restart

Dowód:
http://ompldr.org/vZnBpag/hibern%202.png

:)
Asus X551CA (Intel Pentium 2117U, 4GB RAM, Intel HD Graphics)
Xubuntu 14.04.5 LTS
JerryG
Zakręcona Traszka
Zakręcona Traszka
Posty: 914
Rejestracja: 28 lut 2008, 21:22
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: KDE4
Architektura: x86_64

Re: [Quantal][XFCE 4.10] Niedziałające guziki hibernacji

Post autor: JerryG » 01 paź 2012, 10:36

U Ciebie, u mnie i innych tez dziala po utworzeniu tego pliku :razz:

Moze jeszcze do autora watku:
Sprawdz czy w /etc/initramfs-tools/conf.d masz plik /resume a w nim wpis

Kod: Zaznacz cały

RESUME=UUID=xxxxxxxx
wiecej masz tutaj
http://www.ubuntu-pomoc.org/naprawa-hibernacji/
- - - - - - - - - - - - - - - - - - -
Samsung NP-RF511-S05PL i7, GeForce GT 540M, BCM4313
chkdsk
Piegowaty Guziec
Piegowaty Guziec
Posty: 4
Rejestracja: 01 paź 2012, 00:52
Płeć: Mężczyzna
Wersja Ubuntu: 13.04
Środowisko graficzne: XFCE
Architektura: x86_64

Re: [Quantal][XFCE 4.10] Niedziałające guziki hibernacji

Post autor: chkdsk » 01 paź 2012, 12:53

Sposób kolegi majsza zadziałał idealnie. :)

Dziękuję bardzo za pomoc.

Temat do zamknięcia.
Zablokowany

Wróć do „Quantal Quetzal”