Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Awatar użytkownika
qnebra
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 177
Rejestracja: 06 maja 2012, 23:38
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: qnebra » 14 sty 2013, 15:40

Dawno, dawno, temu. Za siedmioma górami, za siedmioma lasami była sobie Aktualizacja systemu która dawała aktualizację fglrx. Ucieszony jak dziecko z cukierka nacisnąłem Instaluj. Pobrało, zainstalowało, potem się komputer zrestartowało i co się pokazało?

AMD Unsupported Hardware

By cię! Ty taki owaki, wy leniwe k******y. Szybko usuwam precz z systemu te sterowniki.
Potem szybka wizyta na stronie AMD i pobranie wersji 12.10 sterowników (ostatnia działająca), rozpakowanie archiwum i instalacja. Żąda hasła administratora, potem wyrzuca błąd Brak wymaganych zależności. Co takiego? Zawsze działało jak trzeba, a tu taki numer? Trudno. Sprawdzam logi z instalacji. Nic ciekawego, oprócz jednej pozycji.

/lib/bla bla bla/modules/linux/version.h not found

Zaintrygowany tym faktem zaglądam do rzeczonego folderu. Co się okazało? Tego pliku nie ma. Zniknął. :confused:

Dlatego też, pytam się, czy da się to jakoś naprawić?

wersja systemu: Raring Ringtail
kernel: 3.8-rc2
może jakieś braki w oprogramowaniu: wszystkie pakiety kernela zainstalowane, wszystko jest

Teraz korzystanie z Ubuntu na otwartych sterownikach do karty graficznej przypomina Survival Horror skrzyżowany z najtrudniejszą grą świata. Doświadczenie wybitnie ekstremalne.
laptop: Lenovo G565/ CPU: AMD Athlon II P 340/ RAM: 4GB/ GPU: AMD Radeon Mobility 5470
Awatar użytkownika
ethanak
Wygnańcy
Posty: 3054
Rejestracja: 04 gru 2007, 13:19
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME
Architektura: x86
Lokalizacja: Bielsko-Biała
Kontakt:

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: ethanak » 14 sty 2013, 16:12

przestań się wygłupiać - przecież używasz testowych/niestabilnych/rozwojowych wersji, więc pewnie doskonale wiesz jak naprawić zależności.
a jak nie wiesz to po kiego grzyba się pchasz w obszary zastrzeżone dla tych co wiedzą?
Awatar użytkownika
qnebra
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 177
Rejestracja: 06 maja 2012, 23:38
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: qnebra » 17 sty 2013, 20:13

ethanak pisze:przestań się wygłupiać - przecież używasz testowych/niestabilnych/rozwojowych wersji, więc pewnie doskonale wiesz jak naprawić zależności.
a jak nie wiesz to po kiego grzyba się pchasz w obszary zastrzeżone dla tych co wiedzą?
Nie wiem jak ci to powiedzieć. Wszystko zainstalowane, sprawdzane dwa razy. Nawet i trochę więcej razy, za każdym razem ten sam rezultat. Miałem zainstalowane pakiety nagłówków w odpowiedniej wersji i zawsze występował ten błąd. Jak to nazwać? Wybitny przypadek? Może jakiś błąd w paczce który wystąpił w tym jednym przypadku? Może głupiec za klawiaturą?

Nie dziwię się, czemu Linux jako desktop ma promil popularności.
laptop: Lenovo G565/ CPU: AMD Athlon II P 340/ RAM: 4GB/ GPU: AMD Radeon Mobility 5470
Awatar użytkownika
ethanak
Wygnańcy
Posty: 3054
Rejestracja: 04 gru 2007, 13:19
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME
Architektura: x86
Lokalizacja: Bielsko-Biała
Kontakt:

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: ethanak » 17 sty 2013, 20:30

a seria r już jest stabilna? qrd... chyba jakieś ważne wydarzenie opuściłem...
Awatar użytkownika
qnebra
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 177
Rejestracja: 06 maja 2012, 23:38
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: qnebra » 17 sty 2013, 21:35

Słyszałem jakieś plotki, że to wersja testowa. Pewnie agenci Windowsa nadszarpują wizerunek tym wierutnym kłamstwem, że to wersja niestabilna i problemowa.
laptop: Lenovo G565/ CPU: AMD Athlon II P 340/ RAM: 4GB/ GPU: AMD Radeon Mobility 5470
Awatar użytkownika
makson
Redaktor
Redaktor
Posty: 1538
Rejestracja: 23 mar 2009, 07:10
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: XFCE
Architektura: x86_64

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: makson » 18 sty 2013, 09:24

Szczególnie to "bla bla bla" było bardzo pomocne.
Do testowego Ubuntu masz największą szansę z instalacją testowych, a nie stabilnych sterowników. Zmiany w jądrze systemu i Xorgu wymagają dostosowania do nich sterowników. Usuwanie znaku wodnego "Unsupported Hardware" to też nie jest czarna magia:
viewtopic.php?f=133&t=164520

No i na koniec ostateczna uwaga - nie licz na to, że wersja testowa będzie Ci zawsze działać stabilnie. Normą jest, że aktualizacje będą rozwalać system. Nie stosuj tej wersji Ubuntu w celach produkcyjnych.
Miałem Linuksa, zanim stało się to modne.
Awatar użytkownika
qnebra
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 177
Rejestracja: 06 maja 2012, 23:38
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: qnebra » 18 sty 2013, 18:38

Na szczęście nie stosuję tego systemu w celach produkcyjnych, tylko do zabawy w domu. Tak więc nie muszę się przejmować stabilnością, bezpieczeństwem i tymi podobnymi rzeczami. Co by tu nie mówić, ta wersja była bardzo, ale to bardzo stabilna. Stabilniejsza nawet od LTS :shock: w moim wypadku, a nie mogłem podejrzewać, że karta straci wsparcie producenta (niestety AMD) w kolejnej wersji sterowników. Nie mogłem o tym wiedzieć. Korzystanie z sterowników otwartych zaś przypomina pobyt w tajlandzkim burdelu dla transwestytów z AIDS. Skorzystać można, ale trochę to ryzykowne.

Chyba, że się zablokuje sterowniki w ostatniej działającej wersji? Jak myślicie, przejdzie taki myk. Tylko nie wiem jak to będzie z tym xorg oraz kernelem. Bo aktualizacje są wskazane. Nawet bardzo mocno.

Te otwarte sterowniki mnie przerażają, nie korzystasz z komputera (laptopa w tym przypadku), tylko czekasz kiedy się wyłączy z przegrzania w wyniku odtwarzania muzyki i czytania PDFów.
laptop: Lenovo G565/ CPU: AMD Athlon II P 340/ RAM: 4GB/ GPU: AMD Radeon Mobility 5470
Awatar użytkownika
ethanak
Wygnańcy
Posty: 3054
Rejestracja: 04 gru 2007, 13:19
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME
Architektura: x86
Lokalizacja: Bielsko-Biała
Kontakt:

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: ethanak » 18 sty 2013, 19:02

tyle, że korzystanie z zamkniętych sterowników przypomina mi wizytę w wielce podobnym przybytku, gdzie wykidajło wywala cię kopem za drzwi bo takich zgredów nie obsługują.
i co... dowód podrabiać czy co? w końcu najważniejszy fragment systemu działa...
Awatar użytkownika
qnebra
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 177
Rejestracja: 06 maja 2012, 23:38
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: qnebra » 18 sty 2013, 22:44

Te zamknięte sterowniki nie są niezbędne, ale znacznie poprawiają komfort używania systemu. W tej chwili to oni ten system robią i wepcham się z powrotem w 13.04 po wydaniu wersji beta (mam w tej chwili 12.10), a jeżeli te sterowniki otwarte nie będą grozić wyłączaniem laptopa co parę minut to do fglrx nawet nie zajrzę.
laptop: Lenovo G565/ CPU: AMD Athlon II P 340/ RAM: 4GB/ GPU: AMD Radeon Mobility 5470
Awatar użytkownika
Shevchenko1987
Zakręcona Traszka
Zakręcona Traszka
Posty: 807
Rejestracja: 31 sty 2008, 11:52
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Lokalizacja: Warta
Kontakt:

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: Shevchenko1987 » 19 sty 2013, 23:37

Jako root dla otwartych sterowników:

Kod: Zaznacz cały

echo low > /sys/class/drm/card0/device/power_profile
Obniży temperaturę laptopa ;-)
Huawei B618s-22d / ASUS RT-AC68U E1 / Cybertech Dualna LTE-4G 15dBi / WD MyCloud 2TB / ACER Aspire V Nitro VN7-592G-53ZG
Awatar użytkownika
e X t 7 3
Przyjaciel
Przyjaciel
Posty: 4935
Rejestracja: 07 maja 2009, 23:34
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: KDE4
Architektura: x86_64
Lokalizacja: Kraków
Kontakt:

Re: Błąd podczas instalowania sterowników do GPU AMD. Brak version.h

Post autor: e X t 7 3 » 20 sty 2013, 16:12

Kod: Zaznacz cały

/lib/bla bla bla/modules/linux/version.h not found
Zatem od kerneli 3.7.x nastąpiła zmiana ... teraz plik wersji - koniczny do zbudowania modułu dla danej wersji kernela jest np.

Kod: Zaznacz cały

/usr/src/linux-headers-3.7.3-ext73-f1-22.0-brazos-ags-cfs/include/generated/uapi/linux/version.h
ale w moim v22.0 - aby uniknąć kłopotów - jest także w:

Kod: Zaznacz cały

/usr/src/linux-headers-3.7.3-ext73-f1-22.0-brazos-ags-cfs/include/linux/version.h
Poza tym mój build Catalytsów 13.1 obsługuje do kerneli 3.8.x - standardowo wersja 13.1 obsługuje jedynie do kernela 3.5.x.

Catalyst 13.1 + kernel v22.0-brazos

Pozdrawiam
Nie ma rzeczy niemożliwych ... są tylko trudne do zrobienia ;)

Moje kernele oraz skrypty:

NeteXt'73 - instalator kerneli i skryptów oraz optymalizator systemu w jednym > netext73.pl
Zablokowany

Wróć do „Raring Ringtail”