Odwrócone kolory w filmach

Grafika, film, dźwięk.
rayman112
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 02 wrz 2008, 21:16
Płeć: Mężczyzna
Wersja Ubuntu: 8.04
Środowisko graficzne: GNOME

Odwrócone kolory w filmach

Post autor: rayman112 » 05 paź 2008, 20:22

Gdy próbowałem otworzyc filmik, odtwarzał sie on w negatywie, ale z racji że go konwertowałem zignorowałem to, bo myślałem, że namieszałem przy konwersji. Wieczoerm, gdy oglądałem filmik na youtube obraz był w negatywe. Z pozostałymi filmami to samo. Co robić?

EDIT:
Problem zęściowo rozwiązany. Filmy są normalne po odinstalowaniu sterowników do karty graficznej (nvidia-glx-new), ale po ich zainstalowaniu probem powaca.:wall:

EDIT:
Problem rozwiązany w 100%(tylko dalej nie wiem co go spowodowało:craz:)
Odpowiedź znalazłem tu: http://ubuntuforums.org/showthread.php?p=4938996

Wystarczyło w konsoli napisać:

Kod: Zaznacz cały

xvattr -a XV_HUE -v 0
Turisma
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 25 lis 2008, 02:44
Płeć: Mężczyzna
Wersja Ubuntu: 10.10
Środowisko graficzne: GNOME
Architektura: x86_64

Odp: Odwrócone kolory w filmach

Post autor: Turisma » 30 gru 2008, 13:50

Chyba jednak:

Kod: Zaznacz cały

xvattr -a XV_HUE -v 1
Awatar użytkownika
mic93
Piegowaty Guziec
Piegowaty Guziec
Posty: 14
Rejestracja: 01 paź 2009, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 11.04
Środowisko graficzne: GNOME
Architektura: x86
Kontakt:

Odp: Odwrócone kolory w filmach

Post autor: mic93 » 13 paź 2009, 21:55

Witam. Mam wersję 9.10 i ten sam problem, tyle tylko że przy każdym filmie muszę tą komendę wpisywać w konsoli. Bardzo proszę o pomoc.
Ubuntu User number is # 29041|Mam na imię Michał...|Wieprze Pindowsa :D|10.04
misterx
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 10 lis 2007, 22:37
Płeć: Mężczyzna
Wersja Ubuntu: 9.10
Środowisko graficzne: GNOME
Architektura: x86

Odp: Odwrócone kolory w filmach

Post autor: misterx » 16 lis 2009, 20:35

mic93 pisze:Witam. Mam wersję 9.10 i ten sam problem, tyle tylko że przy każdym filmie muszę tą komendę wpisywać w konsoli. Bardzo proszę o pomoc.
Ja mam również ten sam problem
Zainstalowałem Ubuntu 9,10 i kolory w filmach są zmienione.
Jednak częściowo go rozwiązałem dzięki końcowym poradom z tego wątku:
http://ubuntuforums.org/showthread.php?p=4938996
Chociaż mój angielski jest raczej słaby postaram się przetłumaczyć:

1. Uruchom gstreamer-properties (Naciśnij kombinację klawiszy Alt+F2 i wpisz gstreamer-properties)
2. Przejdź na zakładkę Video
3. Zmień default output plugin na własne
4. W polu default output pipeline wpisz: videobalance hue=-1 ! autovideosink
5. Zamknij Wybór systemów multimediów

Ta zmiana działa ale nie w każdym programie. Np. w mplayer oraz VLC Palyer nic się nie zmieniło. Jednak VLC można samemu ustawić:

1. W uruchomionym programie VLC wchodzimy w Narzędzia -> Preferencje
2. Sprawdzamy ewentualnie ustawiamy w dolnej części ekranu Pokaż ustawienia na podstawowe
3. Z lewej strony wskazujemy Obraz
4. Dla części Wyświetlacz zmieniamy opcję Wyjście z Domyślnie na Wyjście obrazu OpenGL

Powyższe zmiany nie dają pełnego rozwiązania ale są łatwe do odwrócenia i są lepsze niż żadne
--------------
Pozdrawiam całą społeczność UBUNTU
jacek14
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 08 sty 2012, 11:56
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME
Architektura: x86

Re: Odwrócone kolory w filmach

Post autor: jacek14 » 08 sty 2012, 17:40

rayman112 pisze:Gdy próbowałem otworzyc filmik, odtwarzał sie on w negatywie, ale z racji że go konwertowałem zignorowałem to, bo myślałem, że namieszałem przy konwersji. Wieczoerm, gdy oglądałem filmik na youtube obraz był w negatywe. Z pozostałymi filmami to samo. Co robić?

EDIT:
Problem zęściowo rozwiązany. Filmy są normalne po odinstalowaniu sterowników do karty graficznej (nvidia-glx-new), ale po ich zainstalowaniu probem powaca.:wall:

EDIT:
Problem rozwiązany w 100%(tylko dalej nie wiem co go spowodowało:craz:)
Odpowiedź znalazłem tu: http://ubuntuforums.org/showthread.php?p=4938996

Wystarczyło w konsoli napisać:

Kod: Zaznacz cały

xvattr -a XV_HUE -v 0

potwierdzam dziś to sprawdzałem i śmiga aż miło
ODPOWIEDZ

Wróć do „Muzyka, filmy, zdjęcia, grafika”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 12 gości