Jak zainstalować Javę w wersji 1.7u79?

Tutaj można zadać pytanie, jeśli Linuksa widzi się pierwszy raz w życiu ;)
Awatar użytkownika
christin00
Piegowaty Guziec
Piegowaty Guziec
Posty: 10
Rejestracja: 16 gru 2006, 16:16
Płeć: Kobieta
Wersja Ubuntu: 16.10
Środowisko graficzne: Brak

Jak zainstalować Javę w wersji 1.7u79?

Postautor: christin00 » 11 sty 2017, 21:50

Mam problem bo domyślnie po sudo apt-get install default-jre i jdk mam javę 8.
Potrzebuję javy 1.7u79 64bit. Mam ściągniętą paczkę tar.gz ale nie można było zainstalować jak również jak daję w terminalu

Kod: Zaznacz cały

udo apt-get install openjdk-7-jre
to mam

Kod: Zaznacz cały

pakiet nie ma kandydata do instalacji


Próbowałam to zainstalować z tej instrukcji https://www.digitalocean.com/community/tutorials/how-to-install-java-with-apt-get-on-ubuntu-16-04
Nie wiem jak wywalić javę 8 runtime i dać poprawnie 7jre i sdk.
namok
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1653
Rejestracja: 01 mar 2008, 12:21
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontaktowanie:

Re: Mam problem z javą 1.7u79

Postautor: namok » 11 sty 2017, 22:59

Popraw profil bo zapewne nie używasz wersji 11.10.
W systemie możesz mieć kilka wersji javy, niczego nie musisz usuwać.
Instalację javy z pliku tar.gz masz tu: http://www.rpiblog.com/2014/03/installi ... ry-pi.html
Awatar użytkownika
christin00
Piegowaty Guziec
Piegowaty Guziec
Posty: 10
Rejestracja: 16 gru 2006, 16:16
Płeć: Kobieta
Wersja Ubuntu: 16.10
Środowisko graficzne: Brak

Re: Mam problem z javą 1.7u79

Postautor: christin00 » 11 sty 2017, 23:22

Muszę usunąć aby odpalić swoją aplikację, która nie może mieć na komputerze wersji 1.8. Od razu wykrywa. Dlatego muszę usunąć 1.8.
Ten link co podałes to 1.8
namok
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1653
Rejestracja: 01 mar 2008, 12:21
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontaktowanie:

Re: Mam problem z javą 1.7u79

Postautor: namok » 12 sty 2017, 08:28

W ten sam sposób zainstalujesz każdą inna wersję javy z paczki tar.gz: http://tecadmin.net/steps-to-install-ja ... -rhel-5-6/
Awatar użytkownika
christin00
Piegowaty Guziec
Piegowaty Guziec
Posty: 10
Rejestracja: 16 gru 2006, 16:16
Płeć: Kobieta
Wersja Ubuntu: 16.10
Środowisko graficzne: Brak

Re: Jak zainstalować Javę w zadanej wersji z pliku tar.gz?

Postautor: christin00 » 16 sty 2017, 11:56

Proszę przywrócić nazwę tematu jak zainstalować jave 1.7u79 . Paczki tar.gz ze strony nie dzialają to nie kwestia jak zainstalować tar.gz ale gdzie są poprawne źródła i alternatywa do instalacji java 1.7 u79 i odinstalowania java 1.8.
namok
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1653
Rejestracja: 01 mar 2008, 12:21
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontaktowanie:

Re: Jak zainstalować Javę w wersji 1.7u79?

Postautor: namok » 16 sty 2017, 14:40


Wróć do „Przedszkole Linuksa”

Kto jest online

Użytkownicy przeglądający to forum: Majestic-12 [Bot] i 8 gości