Hantek 6022BE - próby instalacji, openhantek

Tylko tematy nie mieszczące się powyżej.
peso
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 27 paź 2015, 17:40

Hantek 6022BE - próby instalacji, openhantek

Postautor: peso » 17 mar 2017, 17:51

Witam,
próbowałem wszystkiego - w Was ostatnia nadzieja.
Mam ubuntu 14.04LTS i chciałem zainstalować oprogramowanie/sterowniki do oscyloskopu hantek 6022be, na USB. Znalazłem jakies 6 poradników i wersji oprogramowania - nic nie działa jak należy.
Przykładowo - jedna ze stron https://github.com/OpenHantek/openhantek : jadę po kolei wg readme i nic. Wszystkie potrzebne rzeczy doinstalowane według zaleceń (0 paczek do zainstalowania, 0 do zaktualizowania) i same błędy:

-- Will not build translations! Please install Qt5LinguistTools
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
CMake Error at cmake/CPackInfos.cmake:28 (string):
string sub-command REPLACE requires at least four arguments.
Call Stack (most recent call first):
CMakeLists.txt:30 (include)


CMake Error at cmake/CPackInfos.cmake:29 (string):
string sub-command REPLACE requires at least four arguments.
Call Stack (most recent call first):
CMakeLists.txt:30 (include)

Poprzednio miałem Qt5 (i Qt5LinguistTools) ale póxniej dostałem informację, że Qt musi być w wersji >3, ale mniej niż 5. Odinstalowałem wersję 5, zainstalowałem 4 - nic nie pomogło bo wysypywało się w innym miejscu i najwyraźniej chciało wersję 5, teraz chcę przywrócić wersję qt5 (np przez apt-get install Qt5LinguistTools) ale "nie ma takiego pakietu" i non stop coś doinstalować, coś uaktualnić, coś zmienić, czegoś brakuje, coś nie rusza, coś niby rusza ale nic się nie dzieje, no żesz już tak ponad 10 godzin siedzę.

Byłby ktoś w stanie pomóc mi ogarnąć ten b...temat i wytłumaczyć mi po kolei co jest nie tak?

Z góry dziękuję .
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6343
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Hantek 6022BE - próby instalacji, openhantek

Postautor: mario_7 » 23 mar 2017, 08:15

Dlaczego chcesz kompilować kod?
Skorzystaj z gotowej paczki deb: https://github.com/OpenHantek/openhantek/releases
Czytelnia - poczytaj, Google - poszukaj

Wróć do „Inne”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 5 gości