Samba - po migracji nie wyświetla plików z polskimi znakami - na serwerze znaki ?

Instalacja i konfiguracja oprogramowania sieciowego.
krosbi
Piegowaty Guziec
Piegowaty Guziec
Posty: 1
Rejestracja: 13 kwie 2017, 08:59
Wersja Ubuntu: 16.04

Samba - po migracji nie wyświetla plików z polskimi znakami - na serwerze znaki ?

Post autor: krosbi » 13 kwie 2017, 09:55

Jako nowy - przywitam się. Cześć. Do tej pory wystarczało samo czytanie. Teraz muszę zapytać:

Robię migrację serwera Ubuntu 11.10, Samba Version 3.5.11 na nową maszynę Ubuntu 16.04.1 LTS, Samba Version 4.3.11

Problem jest taki, że nowy serwer Samba w udostępnionych zasobach nie wyświetla plików/folderów z polskimi (?) znakami.

Generalnie na starym serwerze pliki użytkowników gdzie są polskie znaki mają zamiast nich znaczki ? (zamiast każdego ąśćź jest tylko ?)
Ale w udostępnionych zasobach, w Windows znaczki ? wyświetlają się jako polskie litery prawidłowo.

Po przeniesieniu danych na nowy serwer - pliki na serwerze widzę (również zamiast ąśćź jest tylko ?, ale Samba ich nie wyświetla.
Kiedy utworzę nowy plik z polskimi znakami (żółta gęś.txt) to w Windows wyświetla się prawidłowo i na serwerze również.

Na obu maszynach locale
LANG=pl_PL.UTF-8
LANGUAGE=
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=

na starym serwerze nie widzę wpisów w /etc/samba/smb.conf

dos charset =
unix charset =
display charset =
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 6878
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Samba - po migracji nie wyświetla plików z polskimi znakami - na serwerze znaki ?

Post autor: mario_7 » 21 kwie 2017, 22:02

Skopiowałeś pliki z błędnymi znakami? Może lepiej byłoby skopiować je poprawnie i dopiero udostępnić w nowej konfiguracji.
Czytelnia - poczytaj, Google - poszukaj
ODPOWIEDZ

Wróć do „Sieci, serwery, Internet”