~/.xsession-errors

Jeśli już na pewno nie da się umieścić posta wyżej.
Franko85

~/.xsession-errors

Post autor: Franko85 » 30 cze 2007, 09:02

Bootuje system. Wpisuje login i hasło w gdm. Sesja gnome sie próbuje odpalić ale napotyka na błąd. Pojawia się gdm. Loguje się do Gnome'a. Wyświetla mi się informacja:

"Twoja sesja trwała krócej niż 10 sekund. Jeśli nie było to związane z własnoręcznym wylogowaniem się, może oznaczać problem z instalacją lub brak przestrzeni dyskowej. Spróbuj się zalogować przy użyciu jednej z sesji awaryjnych i sprawdź, czy możesz naprawić problem.

Wyświetl szczegóły (plik ~/.Xsession-errors)

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "franko"
/etc/gdm/Xsession: Beginning session setup...
SESSION_MANAGER=local/laptop:/tmp/.ICE-unix/5608
Ostrzeżenie menedżera okien: Wartość "", odnaleziona w bazie danych konfiguracji nie opisuje poprawnie skrótu klawiszowego "toggle_shaded"
Initializing gnome-mount extension

(gnome-power-manager:5681): GnomeUI-WARNING **: While connecting to session manager:
IO error occured opening connection.
Nie można otworzyć pliku file:///usr/share/applications/rhythmbox.desktop z aktywatorem panelu: No such file or directory

(update-notifier:5679): GnomeUI-WARNING **: While connecting to session manager:
IO error occured doing Protocol Setup on connection.

(gnome-cups-icon:5680): GnomeUI-WARNING **: While connecting to session manager:
IO error occured opening connection."

Jeśli nacisne ok. Gnome sie wywala i znowu mam gdm.

Systuacja sie powtarza po restarcie.



Rozwiązanie:
Może to się komuś przyda więc napisze co znalazłem w sieci.
Wszedłem na ubuntu forums i tam było kilka sposobów rozwiązania tego problemu. Ten który zadziałał brzmi tak:

rm /home/nazwa_uzytkownika/.gnome2/session

Z tego co autor napisał to feisty (gnome) ma problem z paczką odpowiedzialną za sesje.
Awatar użytkownika
Lamilami
Piegowaty Guziec
Piegowaty Guziec
Posty: 26
Rejestracja: 26 maja 2006, 08:27
Płeć: Mężczyzna
Wersja Ubuntu: 10.10
Środowisko graficzne: LXDE
Architektura: x86

Post autor: Lamilami » 30 cze 2007, 19:09

Dodaj nowego usera.
Good friend of Botticelli, Wittgenstein and Ayn Rand.
Ubuntu user #9775
Awatar użytkownika
figa
Zakręcona Traszka
Zakręcona Traszka
Posty: 549
Rejestracja: 05 lip 2006, 19:42
Płeć: Kobieta
Wersja Ubuntu: 11.04
Środowisko graficzne: GNOME
Architektura: x86

pomocy sesja trwała krócej niż 10 sek....

Post autor: figa » 07 wrz 2007, 16:41

dołacze sie do tematu - mi sie tez komputer wściekł :wub:
Ten sam komunikat
Twoja sesja trwała krócej niż 10 sekund.....
Szczegóły z pliku ./xsession - errors

Kod: Zaznacz cały


/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "kiki"
/etc/gdm/Xsession: Beginning session setup...
mkdtemp: private socket dir: No space left on device
Proszę co mam z tym zrobic bo się załamię :shu3:

Wywaliło mi się to jak nagle komputer zaczął mi sie czołgać jak slimak, zamykanie aplikacji nie działało i zrobiłam reset - chyba głupio zrobiłam :eek:

W trybie awaryjnym startuje. Jak w nautilusie dam system plików to distępne miejsce pokazuje mi 0 na dole. Nie wiem czy to ma znaczenie bo na dysku mam jeszcze miejsce. Usunęłam jeszcze kilka programów. Na domowym mam ponad 4 GB a na systemie plików troche mniej niz 1 GB. Nie wiem dokładnie.
Temat rozwiązany - dodaj do tematu [solved] za pomocą zaawansowanej edycji pierwszego wpisu wątku.
Awatar użytkownika
gibbon
Piegowaty Guziec
Piegowaty Guziec
Posty: 16
Rejestracja: 07 paź 2007, 23:27
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: KDE4
Architektura: x86

xsession-errors

Post autor: gibbon » 24 paź 2007, 15:49

jak dodac usera jak wogóle się zalogowac nie moge

[ Dodano: 24 Październik 07, 16:19 ]
figa i ja mam taki sam błond xD

[ Dodano: 24 Październik 07, 16:20 ]
tylko mi i w awarnyjnym nie startuje
10 zatrzymanych 15 nie zyje;]
inny OS= Arch linux
Awatar użytkownika
ka_o_3991
Przyjaciel
Przyjaciel
Posty: 861
Rejestracja: 01 wrz 2007, 13:34
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: GNOME
Architektura: x86

Post autor: ka_o_3991 » 24 paź 2007, 17:15

gibbon, przełącz się na konsolę(ctrl+alt+f1), tam się zaloguj i zrób

Kod: Zaznacz cały

sudo adduser nazwa_uzytkownika
Awatar użytkownika
gibbon
Piegowaty Guziec
Piegowaty Guziec
Posty: 16
Rejestracja: 07 paź 2007, 23:27
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: KDE4
Architektura: x86

~/.xsession-errors

Post autor: gibbon » 24 paź 2007, 17:57

zrobiłem ale dalej nie działa prosze pomuzcie mi z tym bo zwariuje :sad: :sad: :sad:
10 zatrzymanych 15 nie zyje;]
inny OS= Arch linux
Awatar użytkownika
Danic X
Piegowaty Guziec
Piegowaty Guziec
Posty: 15
Rejestracja: 30 cze 2007, 20:38
Płeć: Mężczyzna
Wersja Ubuntu: 8.04
Środowisko graficzne: GNOME
Kontakt:

Odp: ~/.xsession-errors

Post autor: Danic X » 31 paź 2007, 20:55

Mam to samo... Tylko problem jest w tym że w .gnome2 nie mam sessions.
Awatar użytkownika
SIARAP
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 28 cze 2007, 15:12
Płeć: Mężczyzna
Wersja Ubuntu: 7.10
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Odp: ~/.xsession-errors

Post autor: SIARAP » 06 lis 2007, 14:34

No space left on device
i
distępne miejsce pokazuje mi 0
System nie wstanie jak nie ma miejsca na dysku.Sprawdzcie czy wystapi ten sam blad po zwolnieniu miejsca.Tylko nie mowcie ze ubuntu do kitu bo pod windowsem tez tak mialem przy pelnym dysku.

@figa jesli masz osobna partycje /home to zwalnianie tam miejsca CHYBA nic nie da.Miejsce nalezy zwolnic na partycji systemowej ubuntu.
Asus P4T ,Intel Pentium 4 1,5 GHz ,256 MB RIMM ,Radeon 9700 ,WDC 80 GB
Eraden
Piegowaty Guziec
Piegowaty Guziec
Posty: 6
Rejestracja: 16 lip 2009, 13:23
Płeć: Mężczyzna
Wersja Ubuntu: 9.04
Środowisko graficzne: GNOME

Odp: ~/.xsession-errors

Post autor: Eraden » 16 lip 2009, 13:28

/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=pl_PL.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
mkdtemp: private socket dir: Permission denied
Nie pomaga nowy User
Nie pomaga zmiana własności chmod
Plik .gnome2/session nie istnieje

Próbuję wszystkiego od 5 godzin, czytałem, przeszukiwałem internet wzdłuż i wszerz i nic nie znalazłem
Błagam, pomóżcie :(
Kryzys zażegnany, jestem n00b i nie restartowałem laptopa po zmianach wprowadzając lawinę nowych i wyłączając go awaryjnie gdy przestawał oddychać

Pomogło zwykłe, banalne i wręcz chaniebne
chmod 1777 /tmp
Greengo
Sędziwy Jeż
Sędziwy Jeż
Posty: 38
Rejestracja: 14 lut 2013, 21:50
Płeć: Mężczyzna
Wersja Ubuntu: 12.10
Środowisko graficzne: GNOME

Re: ~/.xsession-errors

Post autor: Greengo » 14 lut 2013, 21:57

Dla tych którzy wyrywają sobie włosy z głowy, bo nic nie działa: podczac problemów z logowaniem, można przeinstalować całe środowisko graficzne, jednakże może równać się to z utrata plików jakie na danej sesji mieliśmy zapisane (pulpit, być może jakieś zachowane hasełka, etc)

//bear7: Chyba jesteś nowym rekordzistą... Tak głęboko jeszcze chyba nikt nie kopał. Sprawdziłeś datę ostatniego posta? Nie wspomnę już o dacie założenia wątku.

-- 17 lut 2013, o 16:08 --
Greengo pisze:Dla tych którzy wyrywają sobie włosy z głowy, bo nic nie działa: podczac problemów z logowaniem, można przeinstalować całe środowisko graficzne, jednakże może równać się to z utrata plików jakie na danej sesji mieliśmy zapisane (pulpit, być może jakieś zachowane hasełka, etc)

//bear7: Chyba jesteś nowym rekordzistą... Tak głęboko jeszcze chyba nikt nie kopał. Sprawdziłeś datę ostatniego posta? Nie wspomnę już o dacie założenia wątku.

Nie Zauważyłem xD
ODPOWIEDZ

Wróć do „Ostatnia deska ratunku”