Nvidia-drivers-430 - zainstalowany i nie działa

Karty graficzne, dźwiękowe, tv, monitory etc.
Margolka
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 10 lip 2019, 23:20
Wersja Ubuntu: 18.04

Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Margolka » 11 lip 2019, 00:09

witam,
w Ubuntu 18.04 zainstalowałam sterowniki Nvidia-drivers-430 dla GTX1650.
Mimo zakończonej instalacji, rebootu, sterowniki nie działają....

komenda: nvidia-settings
ERROR: Unable to load info from any available system
(nvidia-settings:2748): GLib-GObject-CRITICAL **: 22:55:50.149: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 22:55:50.154: PRIME: No offloading required. Abort
** Message: 22:55:50.154: PRIME: is it supported? no

otwiera mi się okno NVIDIA X server settings całkowicie puste i na tym koniec.

Są to moje początki z systemem Linux i będę wdzięczna za wszelką pomoc w uruchomieniu/konfiguracji tej grafiki.
Awatar użytkownika
Spass
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 186
Rejestracja: 19 paź 2006, 01:54
Wersja Ubuntu: 19.04
Środowisko graficzne: Xfce
Kontakt:

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Spass » 11 lip 2019, 11:52

Cześć, skąd instalowałaś te sterowniki? Ze strony NVIDIA czy z repozytorium PPA?
Margolka
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 10 lip 2019, 23:20
Wersja Ubuntu: 18.04

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Margolka » 11 lip 2019, 12:05

z repozytorium PPA
Awatar użytkownika
Spass
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 186
Rejestracja: 19 paź 2006, 01:54
Wersja Ubuntu: 19.04
Środowisko graficzne: Xfce
Kontakt:

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Spass » 11 lip 2019, 12:17

A na sterownikach 418.56 z PPA ( https://launchpad.net/~graphics-drivers ... ubuntu/ppa ) wszystko działa dobrze? Może akurat chwilowo coś nie tak z gałęzią 430 na PPA (konkretnie 430.26) i musisz poczekać na nową wersję. Z tego co widzę do 19.10 ("alpha") wrzucili już do oficjalnego repo wersję 430.34 ( https://packages.ubuntu.com/eoan/nvidia-driver-430 ), więc PPA jest nieco do tyłu.

Sam akurat używam na 19.04 sterowników 418.56 z oficjalnego repozytorium Ubuntu (nie mam dodanego PPA), więc nie pomogę za bardzo z testach, ale może ktoś z forumowiczów siedzi aktualnie na 430 i pomoże coś więcej.
Margolka
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 10 lip 2019, 23:20
Wersja Ubuntu: 18.04

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Margolka » 11 lip 2019, 12:39

Wcześniej próbowałam zainstalować sterownik 418.74 wedle instrukcji Nvidia, lecz się nie udało. Wyskakiwał:
The distribution-provided pre-install script failed!
Are you sure you want to continue?
Na chwilę obecną wyglada to tak:
code: nvidia-smi

Kod: Zaznacz cały

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.26       Driver Version: 430.26       CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1650    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   36C    P8     1W /  N/A |      0MiB /  3911MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 4104
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: jacekalex » 11 lip 2019, 12:41

Konfig Xorga wygenerowałeś?

Kiedy ostatnio widziałem Nvidię, to trzeba było w konfiigu Xorga ją ustawić, bo system automatycznie jej nie wykrywał za Chiny Ludowe.

Polecenie:

Kod: Zaznacz cały

sudo nvidia-xconfig 
wygeneruje xorg.conf do używania nvidii.

Pozdro
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Awatar użytkownika
Spass
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 186
Rejestracja: 19 paź 2006, 01:54
Wersja Ubuntu: 19.04
Środowisko graficzne: Xfce
Kontakt:

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Spass » 11 lip 2019, 12:55

Margolka, a zerknij może co masz w oknie Dodatkowe sterowniki (czyli coś takiego https://xubuntu-pl.neocities.org/assets ... owniki.png ), bo tam na liście powinnaś mieć do wyboru między innymi 418, skoro masz dodane PPA. Z doświadczenia wiem, że wybranie odpowiedniego sterownika z listy, zastosowanie zmian i restart to najprostszy sposób instalacji sterowników NVIDIA w *ubuntu. Nigdy nie musiałem po tym samodzielnie generować plików konfiguracyjnych. Jeśli nie widzisz tam na liście gałęzi 418 (i 430) do wyboru to upewnij się, że PPA jest dodane ( sudo add-apt-repository ppa:graphics-drivers/ppa && sudo apt update )
Margolka
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 10 lip 2019, 23:20
Wersja Ubuntu: 18.04

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Margolka » 11 lip 2019, 13:13

Kod: Zaznacz cały

sudo nvidia-xconfig

WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
New X configuration file written to '/etc/X11/xorg.conf'
po tej komendzie i reboocie wszystko się posypało.... i wyglada to tak: https://photos.app.goo.gl/hgFryQT2XnPX3EHx5
Awatar użytkownika
Spass
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 186
Rejestracja: 19 paź 2006, 01:54
Wersja Ubuntu: 19.04
Środowisko graficzne: Xfce
Kontakt:

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Spass » 11 lip 2019, 13:21

Czyli całkiem się wykrzaczył tryb graficzny? Na tym ekranie co widzisz przejdź na inną konsolę skrótem Ctrl+Alt+F2, zaloguj się na swoje konto i użyj tych komend:

Kod: Zaznacz cały

sudo apt remove nvidia*
sudo apt autoremove
shutdown -r now
Jak wszystko dobrze pójdzie to system powinien wstać i powinnaś zobaczyć pulpit. Czyli system powinien wstać na sterownikach otwartoźródłowych Nouveau. Wtedy spróbuj dodać sterownik 418 z okna ustawień Dodatkowe sterowniki, tak jak pisałem wyżej.

EDIT: Możesz też (jeszcze zanim dodasz sterownik 418) usunąć ten wygenerowany wcześniej plik, czyli:

Kod: Zaznacz cały

sudo rm /etc/X11/xorg.conf
EDIT: Tak w ogóle to jakiś czas temu skrobnąłem krótki poradnik na ten temat:
https://xubuntu-pl.neocities.org/poradn ... vidia.html
Margolka
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 10 lip 2019, 23:20
Wersja Ubuntu: 18.04

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Margolka » 11 lip 2019, 13:42

w liście mam tylko do wyboru:
NVIDIA Corporation: Nieznany
  • używanie NVIDIA driver metapackage z nvidia-driver-430(otwartoźródłowy)
  • używanie Serwer X od X.Org-- Sterownik Nouveau z xserver-xorg-video-nouveau(otwartoźródłowy)
na chwilę obecną wybrana opcja druga

EDIT:
po

Kod: Zaznacz cały

sudo add-apt-repository ppa:graphics-drivers/ppa && sudo apt update
lista wyboru się nie zmieniła
Awatar użytkownika
Spass
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 186
Rejestracja: 19 paź 2006, 01:54
Wersja Ubuntu: 19.04
Środowisko graficzne: Xfce
Kontakt:

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Spass » 11 lip 2019, 14:04

Wygląda na to, że karta GTX1650 działa (powinna działać...) tylko na sterownikach 430 (pewnie dopiero wtedy dodali dla niej wsparcie), a 418 są za stare dla tej karty.

Cóż, możesz spróbować dodać je raz jeszcze i zobaczyć czy wstanie. Zaznacz w tym oknie 430, zastosuj zmiany i zrestartuj system. Jak dalej nie będzie działać, to pewnie trzeba będzie poczekać na nieco nowsze sterowniki z gałęzi 430 w tym PPA ( https://launchpad.net/~graphics-drivers ... ter=bionic ) Obecnie jest to 430.26
Margolka
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 10 lip 2019, 23:20
Wersja Ubuntu: 18.04

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Margolka » 11 lip 2019, 14:13

Nic się nie zmieniło. W ten sposób wróciłam do początku i jestem na wersji 430.26 :(
Awatar użytkownika
Spass
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 186
Rejestracja: 19 paź 2006, 01:54
Wersja Ubuntu: 19.04
Środowisko graficzne: Xfce
Kontakt:

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Spass » 12 lip 2019, 11:10

Margolka, ta wiadomość może cię zainteresować: Ubuntu Now Offers the Latest Nvidia Graphics Drivers to LTS Users

Dzięki temu powinnaś być w stanie zainstalować u siebie sterowniki w wersji 430.34, może te zadziałają prawidłowo. Z tego co piszą konieczne jest włączenie repozytorium "proposed". Wejdź w okno ustawień Oprogramowanie i aktualizacje, w zakładce Opcje programisty włącz repo bionic-proposed i zamknij okno (wczytując ponownie informacje o oprogramowaniu), następnie wejdź w ustawienia Dodatkowe sterowniki i zobacz czy wersja 430.34 jest teraz dostępna na liście. Powodzenia.
Margolka
Piegowaty Guziec
Piegowaty Guziec
Posty: 7
Rejestracja: 10 lip 2019, 23:20
Wersja Ubuntu: 18.04

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Margolka » 12 lip 2019, 20:32

Za radą forum nvidia zaktualizowałam jądro i oto efekt:

Kod: Zaznacz cały

błąd: boot/vmlinuz-5.1.16-050116-lowlatency has inwalid signatur 
bład: najpierw należy wczytać jądro
Jedyna opcja to wyłączyć boot secure i daje się odpalić Ubuntu. I o dziwo widzi też już grafe zintegrowaną... (W tym momencie mogłabym mi ona zupełnie wystarczyć).
Nie chcę na stałe wyłączyć boot secure, więc jak obejść ten problem?
Awatar użytkownika
Spass
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 186
Rejestracja: 19 paź 2006, 01:54
Wersja Ubuntu: 19.04
Środowisko graficzne: Xfce
Kontakt:

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: Spass » 12 lip 2019, 21:02

Cóż, nie takiej odpowiedzi się pewnie spodziewasz i nie wniesie ona zbyt wiele do tematu, ale sama mi się nasuwa - zainstaluj Pop!_OS 19.04 (obraz ISO dla NVIDIA), bo ten system wydaje się lepiej skrojony (out-of-the-box) pod twoją specyfikację. Nowe stery, nowe jądro, wbudowane rozszerzenie do przełączania grafik zintegrowana<->dedykowana.

A co do fachowej porady na problem z sygnaturami jądra, to musi się wypowiedzieć jakiś forumowicz z większą wiedzą.

EDIT: A może nie "zainstaluj," tylko raczej "przetestuj, a potem ewentualnie jak wszystko by śmigało w sesji live, wtedy zainstaluj".

EDIT: Tu jest chyba podobny problem do twojego: https://askubuntu.com/questions/1087279 ... 80/1087288

Próbowałaś instalować te oficjalne sterowniki z "bionic-proposed"? Może one są podpisane i nie powodują konfliktów z Secure Boot.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7678
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Nvidia-drivers-430 - zainstalowany i nie działa

Post autor: mario_7 » 15 lip 2019, 19:11

Zobacz jaki sterownik jest załadowany dla karty graficznej:

Kod: Zaznacz cały

lshw -C display
Czytelnia - poczytaj, Google - poszukaj
ODPOWIEDZ

Wróć do „Multimedia - karty graficzne, dźwiękowe, telewizyjne, drukarki, skanery”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 9 gości