Nowy komputer - karta ethernet bardzo powolna

Instalacja i konfiguracja oprogramowania sieciowego.
portew
Sędziwy Jeż
Sędziwy Jeż
Posty: 42
Rejestracja: 03 kwie 2016, 22:21
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Nowy komputer - karta ethernet bardzo powolna

Post autor: portew » 15 kwie 2019, 12:03

Mam problem w z zintegrowaną kartą sieciową (Gigabit Ethernet) . Wymieniłem komputer na nowy oparty na płycie (h310m pro-m2) i na internecie mam pingi pokroju 1000-2000ms a przepustowość rzędu kilkunastu kilobitów na sekundę. Pisze po internecie ponieważ po sieci lokalnej rozwijam ze spokojem kilkuset mb/s poprzez protokół SMB a pingi mam rzędu 0,001ms. W przypadku internetu lagi są niezależne od protokołu testowałem: ping, http(pobieranie - wget), https(pobieranie wget) i lagi są wszędzie. Testy prowadziłem też w trybie recovery.

System 16.04 LTS + wszystkie najnowsze updaty
Ethtool wskazuje że jest to połączenie 1000mb/s fullduplex.
Lagi są na wszystkich serwerach DNS, pingowałem też same IP.
Sieć udostępniona z telefonu po USB działa prawidłowo.
Awatar użytkownika
kobrawerde
Zakręcona Traszka
Zakręcona Traszka
Posty: 548
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Nowy komputer problem z ethernet

Post autor: kobrawerde » 15 kwie 2019, 17:48

Może to wina modemu / routera ? ewentualnie tak na szybko sprawdził bym jakąś inną wersję Linux-a live z usb czy też będzie tak samo.
Na samym początku to trzeba zidentyfikować kartę sieciową i drivery :

Kod: Zaznacz cały

sudo inxi -nxxxx
Awatar użytkownika
Spass
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 189
Rejestracja: 19 paź 2006, 01:54
Wersja Ubuntu: 18.04
Środowisko graficzne: Xfce
Kontakt:

Re: Nowy komputer problem z ethernet

Post autor: Spass » 15 kwie 2019, 21:05

Koledze kobrawerde wkradła się mała literówka, zapewne chodziło o:

Kod: Zaznacz cały

sudo inxi -nzxxx
(nie ma w inxi poziomu danych z czterema "x", a dodatkowe "z" ukrywa nasz adres MAC przed światem)
Awatar użytkownika
kobrawerde
Zakręcona Traszka
Zakręcona Traszka
Posty: 548
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Nowy komputer problem z ethernet

Post autor: kobrawerde » 15 kwie 2019, 23:27

masz rację ...ale dziwne bo ten mój wadliwy wpis w terminalu podaje prawie to samo... jednak widoczny adres mac to duży błąd ! :oops:
Awatar użytkownika
arecki
Wytworny Kaczor
Wytworny Kaczor
Posty: 283
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Xfce
Architektura: x86_64
Lokalizacja: 44 Bronson Lane Hensonville

Re: Nowy komputer problem z ethernet

Post autor: arecki » 16 kwie 2019, 06:40

Wrzuć logi dmesg.
kobrawerde pisze:
15 kwie 2019, 23:27
masz rację ...ale dziwne bo ten mój wadliwy wpis w terminalu podaje prawie to samo... jednak widoczny adres mac to duży błąd ! :oops:
A dlaczego pokazywanie adresu MAC jest dużym błędem ? :pt36:
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 4113
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Re: Nowy komputer problem z ethernet

Post autor: jacekalex » 16 kwie 2019, 07:47

Podejrzewam po pierwsze, że karta nie potrafi wynegocjować z routerem prędkości 1Gbit, w rezultacie ląduje na 10Mbit duplex half.
Być może taki problem ma router z siecią dostawcy.

W Linuxie sterowniki sieciowe są pisane w zgodzie w dokumentami RFC, i np stery Intela nie pozwalają ustawić trybu 1000Mbit bez autonegocjacji.
Poza tym możliwe błędy to brak firmware do karty ethernet, o ile karta taki potrzebuje:
radzę sprawić:

Kod: Zaznacz cały

sudo dmesg | grep -i firmware

Kod: Zaznacz cały

sudo  dmesg -l err,warn |less
albo znowu jakieś błędy w Network_managerze.

U mnie karta Intela bryka grzecznie:

Kod: Zaznacz cały

root ~>  inxi -nzxxx
Network:   Card: Intel 82566DM-2 Gigabit Network Connection
           driver: e1000e port: 1820 bus-ID: 00:19.0 chip-ID: 8086:10bd
           IF: net state: up speed: 1000 Mbps duplex: full mac: <filter>

Kod: Zaznacz cały

root ~> lshw -c network
  *-network                 
       description: Ethernet interface
       product: 82566DM-2 Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: /dev/net
       version: 02
       serial: ca:dc:98:56:c3:98
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=1.3-0 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s

Pozdro
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
portew
Sędziwy Jeż
Sędziwy Jeż
Posty: 42
Rejestracja: 03 kwie 2016, 22:21
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Nowy komputer problem z ethernet

Post autor: portew » 02 maja 2019, 17:17

Trochę mnie nie było, problem jest rozwiązany, był zupełnie gdzie indziej. Nie mógł być to problem z negocjacją pakietów ze switchem ponieważ po sieci lokalnej osiągałem znacznie większe transfery, a połączenie zestawiałem na Gigabit o czym pisałem ponieważ to jako pierwsze sprawdziłem. Inne komputery w sieci działały, poprzedni komputer działał. System ten sam tylko świeża instalacja co się zmieniło? - sprzęt. Co się razem ze sprzętem zmieniło? - adres MAC! I tu jest odpowiedź - na ruterze jest QoS do którego nowy adres nie był dopisany a co za tym idzie miał najniższy priorytet. Jednak dzięki za pomoc nie spodziewałem się takie odzewu, na was zawsze można liczyć :D
ODPOWIEDZ

Wróć do „Sieci, serwery, Internet”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 19 gości