[SOLVED] Internet spowalnia po odłączeniu zasilania laptopa

Tutaj można zadać pytanie, jeśli Linuksa widzi się pierwszy raz w życiu ;)
Awatar użytkownika
Morf1920
Piegowaty Guziec
Piegowaty Guziec
Posty: 28
Rejestracja: 01 maja 2012, 14:48
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

[SOLVED] Internet spowalnia po odłączeniu zasilania laptopa

Post autor: Morf1920 » 01 gru 2012, 13:44

Witam!
Mam problem z którym nie potrafię sobie poradzić od dłuższego czasu i już miewam nawet myśli by zakończyć moją przygodę z linuxem :pt36: . Moi znajomi, którzy są bardziej kumaci z tego systemu również nie wiedzą jak mi pomóc, dlatego postanowiłem poprosić Was o pomoc. Na wstępie dodam, iż jestem początkującym użytkownikiem linuxa i wszystkiego muszę się uczyć sam więc proszę o wyrozumiałość. Problem polega na tym, że w momencie odłączenia zasilania z mojego laptopa (DELL INSPIRON N5010) internet spowalnia mi do prędkości gorszej niż kilkanaście lat temu, gdy łączyliśmy się za pomocą modemu telefonicznego. W ustawieniach zasilania nie widzę opcji, która wyłączałaby oszczędzanie energii. Znalazłem w googlach dużo postów z podobnymi problemami, jednak te rozwiązania mi nie pomogły. Bardzo proszę o pomoc, ponieważ teraz mam laptopa stacjonarnego bo nie mogę odpiąć go od zasilania. Na koniec dodam, że łączę się przez WIFI. Z góry dziękuję za pomoc!
Ostatnio zmieniony 05 gru 2012, 22:30 przez Morf1920, łącznie zmieniany 1 raz.
Awatar użytkownika
Hwiparam
Zakręcona Traszka
Zakręcona Traszka
Posty: 762
Rejestracja: 14 lip 2009, 19:02
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Openbox
Architektura: x86_64
Lokalizacja: WOLA DZBĄDZKA 13 ZA FIGURO W LEWO

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: Hwiparam » 01 gru 2012, 21:40

Jeśli chodzi o Wifi, to znalazłem takie coś:
http://ubuntuforums.org/showthread.php?t=1678098
Z tego wynika, że za takie sprawy odpowiedzialny jest BIOS i w jego ustawieniach należy poszukać opcji dot. zarządzania energią.
BO MY PISZO JAK SIE MUWI A NIE JAK SIE PISZE

inny OS = Arch Linux
garnus
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 125
Rejestracja: 21 wrz 2007, 15:07
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: garnus » 01 gru 2012, 23:17

Spróbuj tak:
zmień w pliku:
/usr/lib/pm-utils/power.d/wireless

końcówkę z:

Kod: Zaznacz cały

case $1 in
     true) wireless_powersave on ;;
     false) wireless_powersave off ;;
     *) exit $NA ;;
esac
 
exit 0
na

Kod: Zaznacz cały

case $1 in
     true) wireless_powersave off ;;
     false) wireless_powersave off ;;
     *) exit $NA ;;
esac
exit 0
i restart(chodź może być niepotrzebny)
spowoduje to, że podczas pracy na baterii karta wifi nie wejdzie w tryb oszczędzania energii
Awatar użytkownika
Morf1920
Piegowaty Guziec
Piegowaty Guziec
Posty: 28
Rejestracja: 01 maja 2012, 14:48
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: Morf1920 » 02 gru 2012, 13:03

Witam!
Wydaje mi się, że to nie zależy od BIOSu ponieważ na windowsie wszystko jest OK. Znalazłem w googlach dużo postów z tym tematem jednak jak wpiszę komendę IWCONFIG nie mam tam czegoś takiego jak POWER MANAGEMENT. Kolego Garnus zaraz spróbuje i na pewno dam znać!

-- 2 gru 2012, o 15:23 --

Nie wiem czy coś źle robię, ale wyskakuje mi coś takiego:

Kod: Zaznacz cały

/usr/lib/pm-utils/power.d/wireless: 3: .: : not found
garnus
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 125
Rejestracja: 21 wrz 2007, 15:07
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: garnus » 03 gru 2012, 12:57

Kiedy to wyskakuje?
Jak już po zmianie to poka na co zmieniłeś
mcjg
Sędziwy Jeż
Sędziwy Jeż
Posty: 99
Rejestracja: 05 mar 2009, 23:40
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: KDE Plasma
Architektura: x86

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: mcjg » 03 gru 2012, 13:46

Morf1920 pisze:Nie wiem czy coś źle robię, ale wyskakuje mi coś takiego:

Kod: Zaznacz cały

/usr/lib/pm-utils/power.d/wireless: 3: .: : not found
Otwórz ten plik w jakimś edytorze tekstowym, a nie podawaj tylko ścieżki do pliku. U mnie jest KDE więc pełne polecenie wygląda tak:

Kod: Zaznacz cały

sudo kate /usr/lib/pm-utils/power.d/wireless
Jeżeli nie masz kate to zastąp je przez inny program do edycji np gedit
Awatar użytkownika
Morf1920
Piegowaty Guziec
Piegowaty Guziec
Posty: 28
Rejestracja: 01 maja 2012, 14:48
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: Morf1920 » 03 gru 2012, 21:37

Witam!
Zmieniłem to w tym pliku, zapisałem, zresetowałem kompa i teraz nie mam w ogóle internetu. WiFI ma połączenie jednak stronek nie wczytuje. Gdy wszedłem jeszcze raz w ten plik konfiguracyjny za pomocą GEDIT jest całkiem pusty. Co mogłem schrzanić i czy idzie przywrócić jakoś system do wcześniejszego punktu?? P.S. Piszę teraz z windowsa :)
garnus
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 125
Rejestracja: 21 wrz 2007, 15:07
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: garnus » 04 gru 2012, 08:28

https://www.dropbox.com/s/1ewph4d8wvec9s7/wireless

Spróbuj go wrzucić, skopiować, zastąpić jak tam chcesz.
Awatar użytkownika
Morf1920
Piegowaty Guziec
Piegowaty Guziec
Posty: 28
Rejestracja: 01 maja 2012, 14:48
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: Morf1920 » 04 gru 2012, 09:35

Może zadam głupie pytanie, ale gdzie go mam wrzucić??
garnus
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 125
Rejestracja: 21 wrz 2007, 15:07
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: garnus » 04 gru 2012, 09:53

tam gdzie poprzedni:
/usr/lib/pm-utils/power.d/
zakładając że ściągniesz to do katalogu Pobrane:

Kod: Zaznacz cały

sudo cp /home/twoj_user/Pobrane/wireless /usr/lib/pm-utils/power.d/
albo zrób

Kod: Zaznacz cały

sudo gedit /usr/lib/pm-utils/power.d/wireless 
i skopiuj to co podesłałem, swoją drogą, nie wiem dlaczego brak tego pliku lub jego rozwalenie miałoby spowodować brak internetu, skoro jak piszesz wifi jest, ale tym później się zajmiemy.
Awatar użytkownika
Morf1920
Piegowaty Guziec
Piegowaty Guziec
Posty: 28
Rejestracja: 01 maja 2012, 14:48
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Internet spowalnia po odłączeniu zasilania laptopa

Post autor: Morf1920 » 05 gru 2012, 22:30

Witam!
Wczoraj pokopałem jeszcze raz w tym pliku, zmieniłem tak jak napisaliście mi wyżej. Na początku miałem problemy z połączeniem, ale teraz śmiga wszystko tak jak trzeba a co najważniejsze piszę ten post z odłączonym kablem zasilania. Także chciałem Wam podziękować bardzo za pomoc i za to że nadal zostanę przy LINUXie!
ODPOWIEDZ

Wróć do „Przedszkole Linuksa”

Kto jest online

Użytkownicy przeglądający to forum: jaroslaw1245, misiek70 i 29 gości