Strona 1 z 1

Forum Ubuntu - działanie ?

: 28 kwie 2019, 11:46
autor: kobrawerde
Przepraszam jeśli to problem po mojej stronie ..ale mam pytanie czy u was dobrze działa forum Ubuntu. Ostatnio zmieniałem firmware w routerze i dokonywałem różnych zmian DNS-ów itd ... jakoś teraz mam problem z forum często mam błąd : 504 Gateway Time-out
trudności w wyszukiwaniu jakiś tematów itp. Czy u was wszystko OK ? .... ostatnio chyba także forum Ubuntu zmieniło serwer.
pozdro!

Re: Forum Ubuntu - działanie ?

: 28 kwie 2019, 11:47
autor: Flavour
Czasami się napotkałem z tym, że był komunikat o jakichś pracach i że czasowo forum niedostępne, ale poza tym, wszystko OK.

Re: Forum Ubuntu - działanie ?

: 28 kwie 2019, 12:52
autor: Spass
Mogę potwierdzić. Od kilku dni (po ostatniej przerwie technicznej?) forum chodzi raczej kiepsko, dość często trzeba długo czekać na otwarcie jakiegoś wątku. Dwa razy miałem też 504.

Re: Forum Ubuntu - działanie ?

: 28 kwie 2019, 15:48
autor: Tomfoc
Potwierdzam. Forum muli od pewnego czasu (początek tego mulenia nastąpił po dłuższej przerwie technicznej).

Nawet po napisaniu powyższego zdania i naciśnięciu "Wyślij" musiałem czekać około minuty na zapis.

Re: Forum Ubuntu - działanie ?

: 28 kwie 2019, 16:10
autor: mario_7
Tia... Chciałem dobrze, a wyszło jak zwykle. :P

Nauczka na przyszłość - MySQL 8 jeszcze nie nadaje się na serwer produkcyjny...
https://www.phpbb.com/community/viewtopic.php?t=2508376
https://stackoverflow.com/questions/555 ... new-server

Zatem wróciłem dzisiaj do MySQL 5.7 i na razie chyba jest lepiej.

Ogólnie rzecz ujmując nastąpiła zmiana serwera na nowszy i lepszy i z nowszym systemem operacyjnym (wraz ze wszystkimi wnętrznościami).
Wiązała się z tym kupa roboty - przeskok z Ubuntu 14.04 na 18.04 - w wielu przypadkach nie dało się konfiguracji skopiować, trzeba było przenosić inteligentnie.
Przy okazji zmienił się też adres IP, ale raczej już wszędzie się rozpropagowało.

Dajcie znać jakby jeszcze jakieś kwiatki się pojawiały.

Re: Forum Ubuntu - działanie ?

: 28 kwie 2019, 18:29
autor: kobrawerde
Tylko spokojnie :razz: .... u mnie niestety dalej tzw. "padaka" co chwila napisy:
504 Gateway Time-out
nginx/1.14.0 (Ubuntu)
Informacje
Przepraszamy, ale witryna jest chwilowo niedostępna. Proszę spróbować ponownie za kilka minut.
Czasami trudno się "wbić" do innych działów np. Poradniki i przewodniki ...
Ale spokojnie @mario_7 forum Ubuntu i w ogóle Linux-a aż tak dużo użytkowników nie odwiedza :mrgreen:
więc można pomału wszystko naprawić. Grunt że już wiemy iż forum idzie ku lepszemu :razz: np . serwer itd
pozdro!

Re: Forum Ubuntu - działanie ?

: 28 kwie 2019, 19:01
autor: mario_7
A teraz? Trochę lepiej?

edit:
chyba dalej nie działa to tak jak powinno... Z ciekawostek - musiałem przywracać serwer z migawki bo go niechcący zepsułem - zwykli systemowi użytkownicy nie znali sowich nazw użytkownika, a systemd-resolved nie wstawało w ogóle. Nie wiem jak to się stało. Problem był gdzieś w translacji UID na nazwy użytkowników i z powrotem. Z kolei systemd-resolved nie wstawało, bo dbus zgłaszał że zasób zajęty... Coś się zdrowo namieszało... Ale już "działa" i bazy przywróciłem, żeby posty nie zginęły.
Ciekawostka do ciekawostki: w sytuacji powyżej - gdy po zalogowaniu przez ssh prompt pokazywał "I have no name!" zamiast nazwy użytkownika - można było się przez ssh zalogować, ale scp nie pozwalało ściągnąć plików, za to na szczęście rsync dawał radę.

Jeśli ktoś ma pomysł dlaczego takie zapytanie trwa niekiedy nawet 4 minuty, to dajcie znać:

Kod: Zaznacz cały

SELECT ug.user_id, a.forum_id, r.auth_setting, r.auth_option_id, ao.auth_option FROM phpbb_acl_groups a, phpbb_user_group ug, phpbb_groups g, phpbb_acl_roles_data r, phpbb_acl_options ao WHERE a.auth_role_id = r.role_id AND r.auth_option_id = ao.auth_option_id AND a.group_id = ug.group_id AND g.group_id = ug.group_id AND ug.user_pending = 0 AND NOT (ug.group_leader = 1 AND g.group_skip_auth = 1) AND ao.auth_option = 'm_';
to wydaje się być wywołanie jednej z funkcji phpBB - acl_get_list(false,'m_', false) - tylko na mojej okrojonej testowej maszynie wirtualnej trwa to 4 sekundy (co i tak jest dużo), a na serwerze, który ma kilka razy więcej dostępnych zasobów trwa nawet 4 minuty...

Re: Forum Ubuntu - działanie ?

: 29 kwie 2019, 09:32
autor: kobrawerde
Dzisiaj niestety co jakiś czas dalej te same komunikaty tzn. przeważnie:
Przepraszamy, ale witryna jest chwilowo niedostępna. Proszę spróbować ponownie za kilka minut.

Re: Forum Ubuntu - działanie ?

: 29 kwie 2019, 10:44
autor: jacekalex
Nauczka na przyszłość - MySQL 8 jeszcze nie nadaje się na serwer produkcyjny...
https://www.phpbb.com/community/viewtopic.php?t=2508376
https://stackoverflow.com/questions/555 ... new-server

Zatem wróciłem dzisiaj do MySQL 5.7 i na razie chyba jest lepiej.
Ktoś jeszcze używa oryginalnego Mysqla?

Radziłbym zobaczyć na tym:

Kod: Zaznacz cały

mysql  Ver 15.1 Distrib 10.2.22-MariaDB, for Linux (x86_64) using readline 5.1
To aktualnie najbardziej powszechna implementacja Mysqla w we wszystkich znanych mi Linuxach.

Stawiałem niedawno na Mariadb 10 i PHP-7.1 Magento-2.2 i Prestashopa-1.7, problemów z bazą nie było żadnych, Wordpress-5 też się nie skarży na kłopoty.

Pozdro
:craz:

Re: Forum Ubuntu - działanie ?

: 30 kwie 2019, 22:39
autor: mario_7
Wordpress u nas też się nie skarży...
Jest to jedno zapytanie z phpBB, które z jakiegoś powodu zajmuje bardzo dużo czasu, a nie wydaje się nadmiernie skomplikowane.

Ponieważ objawy na MySQL 5.7 były jeszcze gorsze - wróciłem do MySQL 8.0.16.
Zmieniłem silnik bazy danych dla wszystkich tabel na InnoDB.
Zrobiłem analyze dla tabel.
Ograniczyłem (zobaczymy czy skutecznie) w kodzie wywoływanie funkcji, która generuje felerne zapytanie.

Na ten moment nie mam więcej pomysłów.

MySQL mysi wybierać jakiś bardzo niewydajny sposób przeliczania tego zapytania. Blokerem nie jest ani dysk, ani I/O - te w ogóle nie są zajęte podczas wykonywania zapytania. Główny proces mysqld w trakcie zjadania CPU siedzi głównie na futexach...

Jeśli ktoś ma pomysły, to jestem otwarty na propozycje co jeszcze można sprawdzić.

Szczegóły:
Polecenie:

Kod: Zaznacz cały

SELECT ug.user_id, a.forum_id, r.auth_setting, r.auth_option_id, ao.auth_option FROM phpbb_acl_groups a, phpbb_user_group ug, phpbb_groups g, phpbb_acl_roles_data r, phpbb_acl_options ao WHERE a.auth_role_id = r.role_id AND r.auth_option_id = ao.auth_option_id AND a.group_id = ug.group_id AND g.group_id = ug.group_id AND ug.user_pending = 0 AND NOT (ug.group_leader = 1 AND g.group_skip_auth = 1) AND ao.auth_option = 'm_';
(...)
8 rows in set (12.00 sec)
Explain:

Kod: Zaznacz cały

explain SELECT ug.user_id, a.forum_id, r.auth_setting, r.auth_option_id, ao.auth_option FROM phpbb_acl_groups a, phpbb_user_group ug, phpbb_groups g, phpbb_acl_roles_data r, phpbb_acl_options ao WHERE a.auth_role_id = r.role_id AND r.auth_option_id = ao.auth_option_id AND a.group_id = ug.group_id AND g.group_id = ug.group_id AND ug.user_pending = 0 AND NOT (ug.group_leader = 1 AND g.group_skip_auth = 1) AND ao.auth_option = 'm_';
+----+-------------+-------+------------+--------+-----------------------+-------------+---------+----------------------------+------+----------+-------------+
| id | select_type | table | partitions | type   | possible_keys         | key         | key_len | ref                        | rows | filtered | Extra       |
+----+-------------+-------+------------+--------+-----------------------+-------------+---------+----------------------------+------+----------+-------------+
|  1 | SIMPLE      | ao    | NULL       | const  | PRIMARY,auth_option   | auth_option | 152     | const                      |    1 |   100.00 | Using index |
|  1 | SIMPLE      | g     | NULL       | ALL    | PRIMARY               | NULL        | NULL    | NULL                       |   15 |   100.00 | NULL        |
|  1 | SIMPLE      | ug    | NULL       | ref    | group_id,group_leader | group_id    | 3       | forum.g.group_id           | 4739 |    10.00 | Using where |
|  1 | SIMPLE      | a     | NULL       | ref    | group_id,auth_role_id | group_id    | 3       | forum.g.group_id           |   80 |   100.00 | NULL        |
|  1 | SIMPLE      | r     | NULL       | eq_ref | PRIMARY,ath_op_id     | PRIMARY     | 6       | forum.a.auth_role_id,const |    1 |   100.00 | NULL        |
+----+-------------+-------+------------+--------+-----------------------+-------------+---------+----------------------------+------+----------+-------------+
5 rows in set, 1 warning (0.00 sec)
Profiling:

Kod: Zaznacz cały

show profile for query 1;
+--------------------------------+-----------+
| Status                         | Duration  |
+--------------------------------+-----------+
| starting                       |  0.000850 |
| Executing hook on transaction  |  0.000034 |
| starting                       |  0.000032 |
| checking permissions           |  0.000034 |
| checking permissions           |  0.000021 |
| checking permissions           |  0.000012 |
| checking permissions           |  0.000008 |
| checking permissions           |  0.000045 |
| Opening tables                 |  0.000251 |
| init                           |  0.000054 |
| System lock                    |  0.000071 |
| optimizing                     |  0.000121 |
| statistics                     |  0.000392 |
| preparing                      |  0.000076 |
| executing                      |  0.000010 |
| Sending data                   | 11.990784 |
| end                            |  0.000070 |
| query end                      |  0.000025 |
| waiting for handler commit     |  0.000046 |
| closing tables                 |  0.000036 |
| freeing items                  |  0.000081 |
| cleaning up                    |  0.000113 |
+--------------------------------+-----------+

Re: Forum Ubuntu - działanie ?

: 01 maja 2019, 07:37
autor: jacekalex
Może wersja PhpBB ma jakiegoś errora.
Zobacz jakąś nowszą/starszą wersję.

I jeśli piszesz, ze WP chodzi, to chyba nie widziałeś co Magento robi z w bazie danych na swoich ponad 300 tabelach.
PHPbb3 jest w porównaniu z nim dosyć lekkie.

Z drugiej strony może baza jest trochę za ciężka albo serwer za słaby, Mysql zawsze lepiej chodził, jak obrabianą bazę mógł zbuforować w RAM.

Pozdro

Re: Forum Ubuntu - działanie ?

: 03 maja 2019, 16:46
autor: mario_7
phpBB generuje prawidłowe zapytanie (a przynajmniej tak piszą na forum phpBB). Jednak z jakiegoś powodu to zapytanie na tym konkretnym serwerze zajmuje nadspodziewanie dużo czasu i zasobów CPU. Inne zapytania działają sprawnie.

A sam serwer raczej nie jest za słaby - KVM z 8GB RAM, 4 rdzenie CPU Xenon E5, dyski SSD.
Dziwne jest, że to samo zapytanie u mnie na wirtualnej maszynie VirtualBox z 1 rdzeniem CPU, 1GB RAM i dyskiem SSD zajmuje niecałe 5 sekund...

No nic - póki co chyba forum działa lepiej i tylko co jakiś czas będzie się dławiło tym felernym zapytaniem (mniej więcej raz na tydzień).

Re: Forum Ubuntu - działanie ?

: 22 maja 2019, 16:05
autor: cukier_lukier
Dalej jest z tym problem?

Re: Forum Ubuntu - działanie ?

: 22 maja 2019, 18:00
autor: mario_7
Jeśli pytasz czy to zapytanie dalej trwa tak długo - to tak.
Jeśli pytasz czy to dalej sprawia problem - to nie jest już źle, bo wartość jest w cache'u i odświeża się raz na tydzień, więc problem pojawia się też raz na tydzień. ;)