Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Instalacja i konfiguracja oprogramowania sieciowego.
Willow
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 123
Rejestracja: 07 gru 2016, 00:43

Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: Willow » 26 mar 2019, 23:23

Witam tak jak w opisie zainstalowałem najnowszą wersję Opera 58.0.3135.118 i jest problem z kodekiem h.264 dokładnie taki sam jaki był w wersji 51. Dodam że FF i Chrome działają. Problem objawia się tym że np. na Twiterze nie wyświetlają się filmy w okienkach. Problem występuje również na stronach internetowych typu tvp.info czy tvn24.pl ale na YT filmy wyświetlają się poprawnie. Ktoś jest w stanie pomóc?
Awatar użytkownika
yacup
Wytworny Kaczor
Wytworny Kaczor
Posty: 291
Rejestracja: 11 maja 2007, 11:13
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: yacup » 27 mar 2019, 20:09

Problem w linuksach jest czasami taki, że wraz z nową wersją czasami zamiast progresu zdarza się regres. W tej sytuacji problemem może być pakiet kodeków zawarty w paczce: chromium-codecs-ffmpeg-extras.

Spróbuj zrobić w ten sposób:

1. z adresu:
https://github.com/iteufel/nwjs-ffmpeg- ... t/releases ściągnij wersję prebuiltu kodeków. [Uwaga taka! Spróbuj różne wersje ponieważ najnowsza nie zawsze będzie najlepsza. Z pewnym uproszczeniem stwierdzę, że ja w takich sytuacjach wybieram wersję najcięższą np. 0.34.0. Jeżeli nie będzie działało spróbuj różne wersje].

2. Zrób backup pliku libffmpeg.so z lokalizacji /usr/lib/chromium-browser (skopiuj sobie gdzieś tam gdzie chcesz tak na wszelki wypadek)

3. a następnie rozpakuj i skopiuj plik (nadpisz) libffmpeg.so w powyższej lokalizacji

4. zamknij-otwórz Operę i powinno działać

5. jeżeli działa to zablokuj np. w Synapticu aktualizację wersji paczki chromium-codecs-ffmpeg-extras
a ja mam takiego komputera, że jest taki czarno-srebrny; a na dole są takie różne przyciski coś tak jakby z literami a na górze jest taki telewizor i na nim się wyświetlają różne obrazki, i można go tak jak zeszyt złożyć (albo książkę)
Willow
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 123
Rejestracja: 07 gru 2016, 00:43

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: Willow » 30 mar 2019, 00:51

Nie mogę uzyskać dostępu do katalogu /usr/lib/chromium-browser celem skopiowania tego pliku. Jestem zalogowany jako root w konsoli i nadal nie mogę skopiować. Jest na to jakaś rada?
Awatar użytkownika
arecki
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Xfce
Architektura: x86_64
Lokalizacja: 44 Bronson Lane Hensonville

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: arecki » 30 mar 2019, 06:20

Pokaż wynik

Kod: Zaznacz cały

ls -la /usr/lib/chrom*
Willow
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 123
Rejestracja: 07 gru 2016, 00:43

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: Willow » 30 mar 2019, 11:39

arecki pisze:
30 mar 2019, 06:20
Pokaż wynik

Kod: Zaznacz cały

ls -la /usr/lib/chrom*
drwxr-xr-x 8 root root 28672 mar 28 2018 .
drwxr-xr-x 204 root root 32768 mar 26 22:57 ..
-rw-r--r-- 1 root root 813215 mar 22 2018 chrome_100_percent.pak
-rw-r--r-- 1 root root 1083947 mar 22 2018 chrome_200_percent.pak
-r-sr-xr-x 1 root root 14320 mar 22 2018 chrome-sandbox
-rwxr-xr-x 1 root root 144972784 mar 22 2018 chromium-browser
-rw-r--r-- 1 root root 8017847 mar 22 2018 headless_lib.pak
-rw-r--r-- 1 root root 10171248 mar 20 2018 icudtl.dat
-rw-r--r-- 1 root root 1392175 mar 22 2018 keyboard_resources.pak
-rw-r--r-- 1 root root 2899440 mar 22 2018 libffmpeg.so
drwxr-xr-x 2 root root 20480 kwi 27 2017 libs
drwxr-xr-x 2 root root 4096 mar 28 2018 locales
drwxr-xr-x 2 root root 4096 mar 28 2018 MEIPreload
-rw-r--r-- 1 root root 72534 mar 22 2018 mus_app_resources_100.pak
-rw-r--r-- 1 root root 126480 mar 22 2018 mus_app_resources_200.pak
-rw-r--r-- 1 root root 3800 mar 22 2018 mus_app_resources_strings.pak
-rw-r--r-- 1 root root 205638 mar 22 2018 natives_blob.bin
drwxr-xr-x 2 root root 4096 sty 22 2016 plugins
-rw-r--r-- 1 root root 13263513 mar 22 2018 resources.pak
-rw-r--r-- 1 root root 1357632 mar 22 2018 snapshot_blob.bin
drwxr-xr-x 2 root root 4096 mar 28 2018 swiftshader
-rwxr-xr-x 1 root root 1374832 mar 22 2018 transport_security_state_generator
-rw-r--r-- 1 root root 1765852 mar 22 2018 v8_context_snapshot.bin
-rw-r--r-- 1 root root 111274 mar 22 2018 views_mus_resources.pak
drwxr-xr-x 2 root root 4096 mar 28 2018 WidevineCdm
-rwxr-xr-x 1 root root 37394 mar 20 2018 xdg-mime
-rwxr-xr-x 1 root root 33273 mar 20 2018 xdg-settings
Awatar użytkownika
arecki
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Xfce
Architektura: x86_64
Lokalizacja: 44 Bronson Lane Hensonville

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: arecki » 30 mar 2019, 11:51

No i masz ten plik w czym problem?
O nic nie mówiącym "Nie mogę uzyskać dostępu do katalogu" już wiemy.
Może spróbuj po prostu

Kod: Zaznacz cały

cp \sciezka\do\pliku \sciezka\do\kopii
lub użyj np. midnight commander.
Willow
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 123
Rejestracja: 07 gru 2016, 00:43

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: Willow » 31 mar 2019, 17:40

arecki pisze:
30 mar 2019, 11:51
No i masz ten plik w czym problem?
O nic nie mówiącym "Nie mogę uzyskać dostępu do katalogu" już wiemy.
Może spróbuj po prostu

Kod: Zaznacz cały

cp \sciezka\do\pliku \sciezka\do\kopii
lub użyj np. midnight commander.

Loguje się jako root w konsoli ale nadal nie mam prawa dostępu do tego katalogu. Spróbuje mc
Willow
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 123
Rejestracja: 07 gru 2016, 00:43

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: Willow » 31 mar 2019, 19:41

arecki pisze:
30 mar 2019, 11:51
No i masz ten plik w czym problem?
O nic nie mówiącym "Nie mogę uzyskać dostępu do katalogu" już wiemy.
Może spróbuj po prostu

Kod: Zaznacz cały

cp \sciezka\do\pliku \sciezka\do\kopii
lub użyj np. midnight commander.
Dzięki, Twoja porada pomogła a Opera znowu ożyła (w sensie prawidłowego wyświetlania filmów na stronach). Udało się podmienić plik przez Midnight Comander'a

Możesz mi jeszcze podpowiedzieć jak zablokować aktualizacje Opery w Synapticu?
Awatar użytkownika
arecki
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Xfce
Architektura: x86_64
Lokalizacja: 44 Bronson Lane Hensonville

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: arecki » 31 mar 2019, 20:18

To nie jest mądre, ale w tymże synapticu odnajdź swoją operą, zaznacz ją i w menu pakiet wybierz opcję 'zablokuj wersję'
Willow
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 123
Rejestracja: 07 gru 2016, 00:43

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: Willow » 31 mar 2019, 20:44

arecki pisze:
31 mar 2019, 20:18
To nie jest mądre, ale w tymże synapticu odnajdź swoją operą, zaznacz ją i w menu pakiet wybierz opcję 'zablokuj wersję'
Okey, dzięki za wszystkie podpowiedzi

P.S.
Moje ubuntu to 14.04 i może się mylę ale w Synapticu nie mam możliwości zablokowania aktualizacji, przynajmniej na nic takiego nie natrafiłem
Awatar użytkownika
arecki
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Xfce
Architektura: x86_64
Lokalizacja: 44 Bronson Lane Hensonville

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: arecki » 31 mar 2019, 21:25

Czemu w P.S. podajesz informacje związane z wątkiem ? :)
P.S.
Takie rzeczy pisz na wstępie :D
Awatar użytkownika
kobrawerde
Zakręcona Traszka
Zakręcona Traszka
Posty: 507
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: kobrawerde » 31 mar 2019, 21:28

Moje ubuntu to 14.04
To w ogóle jeszcze ktoś taką staroć jeszcze używa :razz:
to też jest ...raczej niemądre :oops:
Awatar użytkownika
arecki
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Xfce
Architektura: x86_64
Lokalizacja: 44 Bronson Lane Hensonville

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: arecki » 31 mar 2019, 21:46

kobrawerde pisze:
31 mar 2019, 21:28
Moje ubuntu to 14.04
To w ogóle jeszcze ktoś taką staroć jeszcze używa :razz:
to też jest ...raczej niemądre :oops:
A wcale nie, wciąż ma wsparcie (aż do kwietnia 2019) :D

Ale wracając do tematu, jak autor poda wersję synaptica to może odkryjemy czy ma blokowanie wersji.
Willow
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 123
Rejestracja: 07 gru 2016, 00:43

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: Willow » 03 kwie 2019, 20:09

arecki pisze:
31 mar 2019, 21:46
kobrawerde pisze:
31 mar 2019, 21:28
Moje ubuntu to 14.04
To w ogóle jeszcze ktoś taką staroć jeszcze używa :razz:
to też jest ...raczej niemądre :oops:
A wcale nie, wciąż ma wsparcie (aż do kwietnia 2019) :D

Ale wracając do tematu, jak autor poda wersję synaptica to może odkryjemy czy ma blokowanie wersji.
Fakt, ubunciak to trochę już staruszek ale znakomicie stabilny i bardzo szybki jak na dość słabym Acer Aspire es-1 x64 4 GB ramu.
Wersja Synaptica to 0.81.1
Swoją drogą zastanawiam się czy ten 3 letni komputer pociągnie 18.04 LTS?
Awatar użytkownika
arecki
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Xfce
Architektura: x86_64
Lokalizacja: 44 Bronson Lane Hensonville

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: arecki » 03 kwie 2019, 20:33

Jakieś lekkie środowisko np. XFCE powinien dać radę.
Możesz też dalej ciągnąć to co masz, tak jak niektórzy do dziś używają niewspierane już wersje i żyją :D
Moja wersja to 0.84.5
Obrazek
Awatar użytkownika
lcoyote
Wytworny Kaczor
Wytworny Kaczor
Posty: 346
Rejestracja: 30 lis 2017, 16:33
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Xfce
Architektura: x86_64

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: lcoyote » 04 kwie 2019, 18:28

Willow pisze:
03 kwie 2019, 20:09
Swoją drogą zastanawiam się czy ten 3 letni komputer pociągnie 18.04 LTS?
=============
Ja używam laptopa z 2013 roku (jak w podpisie) i z Xfce działa OK.
Awatar użytkownika
yacup
Wytworny Kaczor
Wytworny Kaczor
Posty: 291
Rejestracja: 11 maja 2007, 11:13
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: yacup » 04 kwie 2019, 21:22

Willow pisze: Możesz mi jeszcze podpowiedzieć jak zablokować aktualizacje Opery w Synapticu?
A po co blokujesz aktualizację Opery? Ze względu na odtwarzanie filmów?
Jeżeli tak to zablokuj pakiet chromium-codecs-ffmpeg-extras a nie Operę. Zablokowanie Opery nic w takiej sytuacji nie pomoże.

pozdrawiam
yacup
Ostatnio zmieniony 04 kwie 2019, 21:35 przez yacup, łącznie zmieniany 1 raz.
a ja mam takiego komputera, że jest taki czarno-srebrny; a na dole są takie różne przyciski coś tak jakby z literami a na górze jest taki telewizor i na nim się wyświetlają różne obrazki, i można go tak jak zeszyt złożyć (albo książkę)
Awatar użytkownika
arecki
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Xfce
Architektura: x86_64
Lokalizacja: 44 Bronson Lane Hensonville

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: arecki » 04 kwie 2019, 21:31

Pomyliłeś autorów cytatu :D
Awatar użytkownika
yacup
Wytworny Kaczor
Wytworny Kaczor
Posty: 291
Rejestracja: 11 maja 2007, 11:13
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: yacup » 04 kwie 2019, 21:35

Sorki, już poprawiłem
a ja mam takiego komputera, że jest taki czarno-srebrny; a na dole są takie różne przyciski coś tak jakby z literami a na górze jest taki telewizor i na nim się wyświetlają różne obrazki, i można go tak jak zeszyt złożyć (albo książkę)
Willow
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 123
Rejestracja: 07 gru 2016, 00:43

Re: Opera 58.0.3135.118 - kodek h.264 - nie odtwarza filmów na niektórych stronach

Post autor: Willow » 05 kwie 2019, 21:21

arecki pisze:
03 kwie 2019, 20:33
Jakieś lekkie środowisko np. XFCE powinien dać radę.
Możesz też dalej ciągnąć to co masz, tak jak niektórzy do dziś używają niewspierane już wersje i żyją :D
Moja wersja to 0.84.5
Obrazek
Dzięki wielkie w moim synapticu też działa przez opcje "pakiet"
ODPOWIEDZ

Wróć do „Sieci, serwery, Internet”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 22 gości