Gimp uruchamia się tylko z sudo / jako root.

Grafika, film, dźwięk.
dooshpastesh
Piegowaty Guziec
Piegowaty Guziec
Posty: 21
Rejestracja: 25 mar 2010, 15:20
Płeć: Mężczyzna
Wersja Ubuntu: 10.10
Środowisko graficzne: GNOME
Architektura: x86_64

Gimp uruchamia się tylko z sudo / jako root.

Post autor: dooshpastesh » 17 maja 2011, 23:06

Witam, jest problem. Odpalenie gimpa ze skrótu nie uruchamia programu. Trochę go mieli w pasku a po tym znika i nic się nie uruchamia. Z kolei w konsoli: sudo gimp uruchamia program ale w wersji angielskiej to zanczy chyba, że ni mam praw do gimpa?
Awatar użytkownika
kordys
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 226
Rejestracja: 13 mar 2007, 23:12
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Gimp tylko w sudo -Kubuntu

Post autor: kordys » 18 maja 2011, 15:01

Witam!
A uruchomienie gimp'a bez uprawnień root'a w terminalu - co wypluwa?
odolan85
Piegowaty Guziec
Piegowaty Guziec
Posty: 28
Rejestracja: 22 paź 2010, 12:08
Płeć: Mężczyzna
Wersja Ubuntu: 11.04
Środowisko graficzne: KDE Plasma
Architektura: x86

Re: Gimp tylko w sudo -Kubuntu

Post autor: odolan85 » 01 cze 2011, 09:13

Mam ten sam problem, mam Kubuntu 11.04, gimp nie uruchamia się "normalnie", jedynie z konsoli, po wpisaniu sudo gimp prosi o hasło, następnie uruchamia program po angielsku...

(gimp:2538): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
Naruszenie ochrony pamięci
(...)~$ sudo gimp
[sudo] password (...)

(gimp:2543): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
script-fu-ppracer-save-as-pngs: image-type contains unrecognizable parts:'PNG'
script-fu-ppracer-load-level: image-type contains unrecognizable parts:'PNG'
script-fu-ppracer-create-new-level: image-type contains unrecognizable parts:'PNG'






(gimp:3995): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
script-fu-ppracer-save-as-pngs: image-type contains unrecognizable parts:'PNG'
script-fu-ppracer-load-level: image-type contains unrecognizable parts:'PNG'
script-fu-ppracer-create-new-level: image-type contains unrecognizable parts:'PNG'

(gimp:3995): Gtk-CRITICAL **: IA__gtk_icon_info_load_icon: assertion `icon_info != NULL' failed

(gimp:3995): Gtk-CRITICAL **: IA__gtk_icon_info_load_icon: assertion `icon_info != NULL' failed

(gimp:3995): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Utworzenie pliku "/root/.local/share/recently-used.xbel.T2TNWV" się nie powiodło: Nie ma takiego pliku ani katalogu

(gimp:3995): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: Nie ma takiego pliku ani katalogu

(gimp:3995): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Utworzenie pliku "/root/.local/share/recently-used.xbel.O5YFWV" się nie powiodło: Nie ma takiego pliku ani katalogu

(gimp:3995): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: Nie ma takiego pliku ani katalogu
prezes1519
Piegowaty Guziec
Piegowaty Guziec
Posty: 19
Rejestracja: 26 lut 2011, 20:21
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: Unity
Architektura: x86
Kontakt:

Gimp tylko na root

Post autor: prezes1519 » 18 cze 2011, 18:30

Witam.
Dziś zainstalowałem gimpa. Jak go uruchamiałem ładował się na pasku, ale zero reakcji i po chwili już nic.

Próbowałem uruchomić przez terminal/konsolę, wyrzuciło mi coś takiego:
(gimp:10300): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
Naruszenie ochrony pamięci

Z uprawnieniami root działa bez problemu.
Ostatnio zmieniony 20 cze 2011, 07:31 przez prezes1519, łącznie zmieniany 1 raz.
Awatar użytkownika
igotit4free
Przyjaciel
Przyjaciel
Posty: 6453
Rejestracja: 29 paź 2008, 22:51
Płeć: Mężczyzna
Architektura: x86_64
Lokalizacja: KRK

Re: Gimp tylko w sudo -Kubuntu

Post autor: igotit4free » 18 cze 2011, 19:39

Windows 10 @ GA-P67A-D3-B3, i3-2100 3.10GHz, 8GB RAM, Gigabyte HD6850 1GB RAM
Android 7.0 @ Motorola Moto G4+
prezes1519
Piegowaty Guziec
Piegowaty Guziec
Posty: 19
Rejestracja: 26 lut 2011, 20:21
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: Unity
Architektura: x86
Kontakt:

Re: Gimp tylko w sudo -Kubuntu

Post autor: prezes1519 » 20 cze 2011, 07:32

igotit4free pisze:Google.
Najłatwiej człowieka odesłać do google...
Tak się akurat składa że niektórzy ludzie piszą na forum w ostateczności, już po tej czynności.
Też nie każdy zaczynał od linuxa żeby go olać.
Moim zdaniem (każdy może mieć inne) wypowiedzi typu "google" są zbędne, jeśli ktoś piszę na forum to tylko po to aby uzyskać życzliwą odpowiedź, która mogła by rozwiązać dany problem.
Awatar użytkownika
brezniew
Przyjaciel
Przyjaciel
Posty: 2680
Rejestracja: 12 kwie 2011, 16:48
Wersja Ubuntu: inny OS
Środowisko graficzne: Fluxbox
Architektura: x86_64

Re: Gimp uruchamia się tylko z sudo / jako root.

Post autor: brezniew » 20 cze 2011, 09:10

Może to dotyczy tego samego:
viewtopic.php?f=135&t=124101&p=847658#p847620
prezes1519
Piegowaty Guziec
Piegowaty Guziec
Posty: 19
Rejestracja: 26 lut 2011, 20:21
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: Unity
Architektura: x86
Kontakt:

Gimp uruchamia się tylko z sudo / jako root.

Post autor: prezes1519 » 20 cze 2011, 13:28

U mnie gimp na root wyświetla się w języku polskim...
Jak miałem ubuntu 10.04, nie miałem takiego problemu, tak samo z 10.10 ale te 11.04 jest jakieś nie wydażone.
Poszperam trochę, może coś wykombinuje... Jak ktoś wpadnie na pomysł niech pisze.
Najbardziej interesuje mnie ten napis w logu "Naruszenie ochrony pamięci"...
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 4083
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Re: Gimp uruchamia się tylko z sudo / jako root.

Post autor: jacekalex » 20 cze 2011, 14:06

U mnie na Gentoo Gimp tak samo miauczy, ale chodzi:

Kod: Zaznacz cały

gimp

(gimp:8012): GLib-WARNING **: goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
Na Debianie Wheezy jest dokładnie taka sama sytuacja.

Spróbujcie wymusić w Synapticu inną wersję, albo poczekać z tydzień, aż się pojawi poprawiona wersja paczki.

Można też ściagnąć z netu wersję dla Debiana testing (ten sam lub podobny numer wersji),
i zainstalować ręcznie (przez gdebi), powinno ruszyć.
Mam tu Debiana Whezzy i Gimpa - 2.6.11-2 - uruchamia się i działa bez kłopotu.

To by było na tyle
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
prezes1519
Piegowaty Guziec
Piegowaty Guziec
Posty: 19
Rejestracja: 26 lut 2011, 20:21
Płeć: Mężczyzna
Wersja Ubuntu: 12.04
Środowisko graficzne: Unity
Architektura: x86
Kontakt:

Gimp uruchamia się tylko z sudo / jako root.

Post autor: prezes1519 » 24 cze 2011, 16:02

Nie rozumiem dlaczego ten Gimp się nie chce uruchamiać... Ale zmieniłem środowisko na GNOME i mając ten problem na KDE będąc na GNOME gimp działa bez zarzutu.
Awatar użytkownika
brezniew
Przyjaciel
Przyjaciel
Posty: 2680
Rejestracja: 12 kwie 2011, 16:48
Wersja Ubuntu: inny OS
Środowisko graficzne: Fluxbox
Architektura: x86_64

Re: Gimp uruchamia się tylko z sudo / jako root.

Post autor: brezniew » 24 cze 2011, 21:29

Sprawdź czy masz zainstalowany pakiet polkit-kde-1.
ODPOWIEDZ

Wróć do „Muzyka, filmy, zdjęcia, grafika”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 16 gości