KernelUP - Zadbaj o aktualne jądro w systemie.

Miejsce, w którym użytkownicy forum mogą zaprezentować swoje własne projekty programistyczne.
krystian_kk3
Sędziwy Jeż
Sędziwy Jeż
Posty: 36
Rejestracja: 22 paź 2013, 11:08
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: KernelUP - Zadbaj o aktualne jądro w systemie.

Post autor: krystian_kk3 » 07 paź 2014, 11:29

Witam. Po zainstalowaniu pakietu, który podałem w którymś z wcześniejszych wątków aktualizacje do wyższych wersji jądra nie powodowało żadnych problemów z wifi (karta broadcom), natomiast po zainstalowaniu wersji krenela 3.17.0 znów brak wifi. Czy rozwiązał ktoś ten problem, lub autor "kernelup-a" jest w stanie coś doradzić?
DamiaX
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 06 paź 2011, 19:42
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: KernelUP - Zadbaj o aktualne jądro w systemie.

Post autor: DamiaX » 07 paź 2014, 22:32

Witaj, mam pytanie czy jeszcze raz próbowałeś ponownie instalować ten pakiet na jądrze 3.17.0? Całkiem możliwe, że zaszły jakieś zmiany w jądrze, które sprawiają, że sterowniki zawarte w pakiecie który doinstalowałeś są niekompatybilne z jądrem, i producent będzie musiał wydać zaktualizowaną wersję pakietu przystosowaną do 3.17.0 ale to moje spekulacje. Spróbuj zaktualizować jądro do najnowszej wersji, usunąć ten pakiet, wyczyścić system z pozostałości, uruchomić ponownie system, zainstalować ponownie ten pakiet. Więcej do głowy mi nie przychodzi jak na razie. Chociaż możesz podać wynik polecenia

Kod: Zaznacz cały

ifconfig
,
krystian_kk3
Sędziwy Jeż
Sędziwy Jeż
Posty: 36
Rejestracja: 22 paź 2013, 11:08
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: KernelUP - Zadbaj o aktualne jądro w systemie.

Post autor: krystian_kk3 » 07 paź 2014, 23:50

DamiaX pisze:Witaj, mam pytanie czy jeszcze raz próbowałeś ponownie instalować ten pakiet na jądrze 3.17.0? Całkiem możliwe, że zaszły jakieś zmiany w jądrze, które sprawiają, że sterowniki zawarte w pakiecie który doinstalowałeś są niekompatybilne z jądrem, i producent będzie musiał wydać zaktualizowaną wersję pakietu przystosowaną do 3.17.0 ale to moje spekulacje. Spróbuj zaktualizować jądro do najnowszej wersji, usunąć ten pakiet, wyczyścić system z pozostałości, uruchomić ponownie system, zainstalować ponownie ten pakiet. Więcej do głowy mi nie przychodzi jak na razie. Chociaż możesz podać wynik polecenia

Kod: Zaznacz cały

ifconfig
,
Cześć. Po próbowałem otworzyć ten link poprzedni, ale pakiet już nie istnieje pod tym linkiem. Znalazłem niższą wersę tegoż pakietu, ale przy próbie instalacji wyskakuje komunikat, że pakiet wyższej wersji już istnieje (czyli jest). Każdemu kto chce kupić laptop z myślą o instalacji linuxa odradzam wszystko co ma w sobie broadcom, bo to same kłopoty. Wynik komendy ifconfig to u mnie

Kod: Zaznacz cały

eth0      Link encap:Ethernet  HWaddr 3c:97:0e:d2:92:55  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:10136 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10136 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:918444 (918.4 KB)  TX bytes:918444 (918.4 KB)

wlan0     Link encap:Ethernet  HWaddr 80:56:f2:db:7d:57  
          inet addr:192.168.0.133  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::8256:f2ff:fedb:7d57/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:797747 errors:0 dropped:0 overruns:0 frame:1007867
          TX packets:625768 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:966875139 (966.8 MB)  TX bytes:138443445 (138.4 MB)
          Interrupt:17 
Przejrzałem zagraniczne fora i okazuje się, że wina leży po stronie Broadcom. Przespali aktualizacje jądra i trzeba czekać aż się obudzą.
P.S. Najnowszy pakiet sterownika do kart broadcom jest tu https://launchpad.net/ubuntu/utopic/amd ... m-0ubuntu1
DamiaX
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 06 paź 2011, 19:42
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: KernelUP - Zadbaj o aktualne jądro w systemie.

Post autor: DamiaX » 08 paź 2014, 15:38

Okej, w najbliższym czasie KernelUP zyska możliwość automatycznej instalacji takiego pakietu gdy wykryje on posiadaną kartę sieciową w celu uniknięcia takich problemów jakie mogą wyniknąć u Ciebie.
ODPOWIEDZ

Wróć do „Nasza twórczość”