Mint, nie działa "apt-get", niedostępne aplikacje

Dyskusje o dystrybucjach niezwiązanych z Ubuntu
vvvcrack
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 13 kwie 2016, 15:16
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Architektura: x86_64

Mint, nie działa "apt-get", niedostępne aplikacje

Post autor: vvvcrack » 30 kwie 2016, 15:41

Dzien Dobry forowicze

posiadam Linux Mint 17.3 cinnamon 32-bit.

mimo wskazan o zainstalowanym pakiecie "apt-get". (cron-apt) , niemozliwe jest zainstalowanie oprogramowania takiego jak Kadu lub K3b , ktore to
w menaerze ustawien , napisane jest ze wymaga pakietu "apt-get" , jednak jest on zainstalowany.
probowalem odinstalowac i wgrac na nowo , lecz wciaz niemoge korzystac z wielu programikow dostepnych poprzez "software manager".

gdy wchodze w manager to pisze ze cron-apt jest juz na dysku, wiec czemu wykazuje gdy chcem pobrac w/w aplikacje - "please use apt-get to install this package" ?
kiedys w tej samej wersji Linux Mint , niebylo problemu z pobieraniem nowych aplikacji .
bylbym wdzieczny za wskazanie jak skonfigurowac lub jaki program potrzeba ?
"swiezak" jesli chodzi o Linuxa.

Dziekuje.
bear7
Moderator
Moderator
Posty: 6688
Rejestracja: 20 sty 2009, 23:12
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64
Lokalizacja: pwd

Re: problem z pakietem "apt-get" , niedostepne aplikacje

Post autor: bear7 » 30 kwie 2016, 15:50

A próbowałeś zrobić tak, jak wskazuje komunikat i klepnąć w terminalu:

Kod: Zaznacz cały

sudo apt-get install nazwa_pakietu
Czyli:

Kod: Zaznacz cały

sudo apt-get install kadu

Kod: Zaznacz cały

sudo apt-get install k3b
O pomoc pytaj a forum, a nie przez PW.
vvvcrack
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 13 kwie 2016, 15:16
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Architektura: x86_64

Re: problem z pakietem "apt-get" , niedostepne aplikacje

Post autor: vvvcrack » 02 maja 2016, 16:39

Dziekuje, zrobilem jak mowiles z pozycji terminala wpisalem i taki mi sie wyswietla komunikat.

mint@mint ~ $ sudo apt-get install k3b
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
k3b : Depends: kde-runtime but it is not going to be installed
Depends: libk3b6 (= 2.0.2-7ubuntu1) but it is not going to be installed
Depends: libkde3support4 (>= 4:4.4.4) but it is not going to be installed
Depends: libqt4-qt3support (>= 4:4.5.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
mint@mint ~ $


jako "swiezak"nie ogarniam jezyka programistow "Linux-a" , jesli wiesz co mam zle w moim "Mint 17" to odpisz. i raz jeszcze dziekuje Ci.
Awatar użytkownika
enedil
Terminator
Terminator
Posty: 1306
Rejestracja: 08 wrz 2012, 16:54
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: problem z pakietem "apt-get" , niedostepne aplikacje

Post autor: enedil » 02 maja 2016, 18:50

Kod: Zaznacz cały

sudo apt-get install -f
:?
Dobrze jest, psiakrew, a kto powie, że nie, to go w mordę!

~moderatorzy
vvvcrack
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 13 kwie 2016, 15:16
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Architektura: x86_64

Re: problem z pakietem "apt-get" , niedostepne aplikacje

Post autor: vvvcrack » 02 maja 2016, 19:54

Witaj, chyba mam "magiczną wersję minta" , a pc nie magiczny a obsceniczny.

Kod: Zaznacz cały

mint@mint ~ $ sudo apt-get install -f
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 
mint@mint ~ $ 
Ale dziekuję, że w ogóle odpisałeś. Chyba znow na "gejtsa" się przeniosę.
Ostatnio zmieniony 02 maja 2016, 22:25 przez enedil, łącznie zmieniany 1 raz.
Awatar użytkownika
luk1don
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1768
Rejestracja: 07 lis 2008, 16:17
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86

Re: Mint, nie działa "apt-get", niedostępne aplikacje

Post autor: luk1don » 07 maja 2016, 16:42

Napisał ci co masz wykonać:

Kod: Zaznacz cały

sudo dpkg -a --configure
vvvcrack
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 13 kwie 2016, 15:16
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Architektura: x86_64

Re: Mint, nie działa "apt-get", niedostępne aplikacje

Post autor: vvvcrack » 17 maja 2016, 22:18

mint@mint ~ $ sudo dpkg -a --configure
mint@mint ~ $ sudo apt-get install k3b
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
k3b : Depends: kde-runtime but it is not going to be installed
Depends: libk3b6 (= 2.0.2-7ubuntu1) but it is not going to be installed
Depends: libkde3support4 (>= 4:4.4.4) but it is not going to be installed
Depends: libqt4-qt3support (>= 4:4.5.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
mint@mint ~ $


to co za linuxa ja mam , ze u kazdego jest oki a u mnie ciagle bugi ?
Awatar użytkownika
luk1don
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1768
Rejestracja: 07 lis 2008, 16:17
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86

Re: Mint, nie działa "apt-get", niedostępne aplikacje

Post autor: luk1don » 23 maja 2016, 12:17

Kod: Zaznacz cały

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get -f install k3b
vvvcrack
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 13 kwie 2016, 15:16
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Architektura: x86_64

Re: Mint, nie działa "apt-get", niedostępne aplikacje

Post autor: vvvcrack » 13 cze 2016, 01:19

Dziekuje
ODPOWIEDZ

Wróć do „Ogólnie o Linuksie”