Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Tutaj można zadać pytanie, jeśli Linuksa widzi się pierwszy raz w życiu ;)
rafaln1
Sędziwy Jeż
Sędziwy Jeż
Posty: 52
Rejestracja: 20 wrz 2010, 22:50
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: rafaln1 » 20 lis 2017, 07:21

Zwraca takie coś:

Kod: Zaznacz cały

root      1223  0.0  0.0   2376   592 ?        Ss   07:14   0:00 /bin/sh /snap/pulseaudio/10/bin/pulseaudio
root      1523  0.2  0.4 103184  7704 ?        S<l  07:14   0:00 /snap/pulseaudio/10/usr/bin/pulseaudio --exit-idle-time=-1 --disallow-exit=yes --system -F /snap/pulseaudio/10/etc/pulse/default.pa -p /snap/pulseaudio/10/usr/lib/pulse-8.0/modules -n
gdm       1672  0.0  0.5 628160 10156 ?        Ssl  07:14   0:00 /usr/bin/pulseaudio --daemonize=no
root      2770  0.0  0.0   6492   900 pts/0    S+   07:21   0:00 grep --color=auto pulse
A wystarczy dąć to:

Kod: Zaznacz cały

killall pulseaudio; rm -r ~/.config/pulse/* ; rm -r ~/.pulse*
...I dźwięk wraca ale tylko do kolejnego restartu maszynki.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7152
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: mario_7 » 20 lis 2017, 22:39

A co to za pulseaudio ze snapa? Wygląda na to, że masz 2 serwery dźwięku uruchomione i zgaduję, że się gryzą i w efekcie nic nie działa.
Polecenie, które uruchamiasz zabija jeden z serwerów i wtedy ten drugi zaczyna działać.

Instalowałeś pulseaudio z pakietów snap?
Czytelnia - poczytaj, Google - poszukaj
rafaln1
Sędziwy Jeż
Sędziwy Jeż
Posty: 52
Rejestracja: 20 wrz 2010, 22:50
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: rafaln1 » 21 lis 2017, 07:24

Niestety nie mam pojęcia co to instalować ze snap.
Jak pisałem na początku- zrobiłem upgrade do wersji 17.04, uruchomiłem po wszystkim maszynę i od tej pory dźwięku ni hu hu.
Co wobec tego zrobić aby mieć jeden serwer dźwięku i nic się nie gryzło?
Bo przecież nie będę teraz po każdym uruchomieniu zabijał.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7152
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: mario_7 » 21 lis 2017, 10:07

Aktualizacja systemu raczej tego nie zainstalowała...

Sprawdź:

Kod: Zaznacz cały

sudo snap list
jeśli na liście będzie pulseaudio, to usuń:

Kod: Zaznacz cały

sudo snap remove pulseaudio
Po restarcie sprawdź czy jest lepiej.
Czytelnia - poczytaj, Google - poszukaj
rafaln1
Sędziwy Jeż
Sędziwy Jeż
Posty: 52
Rejestracja: 20 wrz 2010, 22:50
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: rafaln1 » 21 lis 2017, 15:12

Kolego Adminie- jesteś wielki.
Usunąłem z listy pulseaudio i wszystko śmiga.
Dzięki obu kolegom, którzy poświęcili swój czas na udzielenie mi pomocy.
rafaln1
Sędziwy Jeż
Sędziwy Jeż
Posty: 52
Rejestracja: 20 wrz 2010, 22:50
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: rafaln1 » 06 mar 2018, 07:40

Witam ponownie.
Dźwięk sobie był aż do niedawna.
Ot tak nagle mam magiczny napis "głuche wyjscie"
Jak to naprawić bo znów laptop milczy?
Awatar użytkownika
kobrawerde
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 156
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: kobrawerde » 06 mar 2018, 10:02

A może takie howto coś pomoże : jak rozwiązać problem z dźwiękiem na ubuntu
rafaln1
Sędziwy Jeż
Sędziwy Jeż
Posty: 52
Rejestracja: 20 wrz 2010, 22:50
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: rafaln1 » 07 mar 2018, 06:28

niestety nic z tego linku nie pomaga.
Zauważyłem, że wpisanie w terminal Alsamixer daje takie coś zamiast suwaków do regulacji:
nie udało się otworzyć miksera: Nie ma takiego pliku ani katalogu
Awatar użytkownika
kobrawerde
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 156
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: kobrawerde » 07 mar 2018, 09:15

Pewnie dla poprawnego działania alsamixer-a wystarczy zainstalować :

Kod: Zaznacz cały

sudo apt-get install alsa
sudo apt-get install alsa-utils
sudo apt-get install alsa-tools
ale czy sama instalacja serweru dźwięku alsa w systemie pomoże w twoim przypadku ?... narzucają się tu słowa po upgradzie ... może więc coś z nowszym kernelem i twoją kartą dźwiękową. Tematów jest sporo : google -sound does not work after upgrade 17.10
https://ubuntuforums.org/showthread.php?t=2363938
Na Kubuntu podobny problem po upgrade....pomaga niby:

Kod: Zaznacz cały

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload
https://bugs.launchpad.net/ubuntu/+sour ... ug/1728587
A może jak wcześniej coś z pakietami snap które same się instalują / aktualizują i błąd podwójnego servera pulseaudio :
/bin/sh /snap/pulseaudio/10/bin/pulseaudio
Nie wiem czy to poprawne i bezpieczne usunięcie snap
https://www.howtoinstall.co/en/ubuntu/x ... ion=remove
rafaln1
Sędziwy Jeż
Sędziwy Jeż
Posty: 52
Rejestracja: 20 wrz 2010, 22:50
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: rafaln1 » 08 mar 2018, 21:48

Nic nie pomaga... ręce opadają na te awarie z kosmosu wzięte.
Działa dobrze a tu nagle awaria.
Cały czas "głuche wyjście" i brak alsamixer w terminalu.
Dobrze, że mam na laptopie Windowsa obok Linuxa.
Awatar użytkownika
kobrawerde
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 156
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: kobrawerde » 09 mar 2018, 09:59

Ja mam Lubuntu ... taką odchudzoną wersję Ubuntu i powiem iż nie narzekam sprawuje się naprawdę dobrze na moim leciwym lapku. Ale może w twoim przypadku ( i konfiguracji sprzętowej ) może lepiej sprawowałoby się inne distro ..np Linux Mint itd . Wbrew pozorom tak na "oko" mało co się między sobą różnią ( oczywiście pomijając grafikę ) ...a jednak :-) .... czasem inne repo / nowsze paczki / konfiguracja systemu itp i wszystko jakoś inaczej pracuje na danym sprzęcie. Warto po sprawdzić np choćby parę distro z Live CD / USB bo jeśli są ciągle tak uciążliwe problemy ( i nikt nie potrafi pomóc ) to szkoda czasu .... jest naprawdę sporo innych wartościowych dystrybucji które mogą spokojnie zastąpić Ubuntu. Zerknij https://distrowatch.com/
Ja testuję teraz parę systemów i powiem że są naprawdę spoko choćby np. : https://voyagerlive.org/
https://mxlinux.org/ ... nie wiem czy można je na 100% spolszczyć, pewnie większość programów tak ale specyficzny interface i oryginalne dodatki ?... w tych wersjach przyciąga mnie ich dopracowanie... zainstalowane już oprogramowanie które często po instalacji jakiegoś distro muszę uzupełniać / oryginalne dodatki które otrzymujemy bez kombinowania np Conky itp
Może warto coś poszukać / zmienić.... lub jeszcze przejrzeć google o podobnych problemach z dźwiękiem po upgrade systemu
google- ubuntu sound does not work after upgrade 17.10 - Pulse can not be installed
https://help.ubuntu.com/community/SoundTroubleshooting
https://www.youtube.com/watch?v=VPyGye0MTjw
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7152
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: mario_7 » 17 mar 2018, 09:28

Większości awarii można uniknąć poprzez rozumne wykonywanie poradników znalezionych w internecie, a nie bezmyślne wklejanie poleceń... To co było problemem na początku nie występuje w standardowej konfiguracji Ubuntu i sam musiałeś kiedyś sobie to "zepsuć".
Jaki problem jest teraz? Pokaż logi, to się dowiemy - pokaż wynik skryptu alsa-info: https://wiki.ubuntu.com/Audio/AlsaInfo
Czytelnia - poczytaj, Google - poszukaj
rafaln1
Sędziwy Jeż
Sędziwy Jeż
Posty: 52
Rejestracja: 20 wrz 2010, 22:50
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: rafaln1 » 20 mar 2018, 07:54

mario_7 pisze:
17 mar 2018, 09:28
... sam musiałeś kiedyś sobie to "zepsuć".
...
Cuda cuda Panie...
Na co dzień korzystam z tabletu czy smartfona.
Włączam sobie laptok po dłuższym czasie nieużytkowania a tu ni ma dźwięku... wcześniej oczywiście był.
Jakieś paskudne krasnoludki cos popsuły i na mnie zrzucają.

Nie kumaty jestem ale takie coś mam po Twojej podpowiedzi:
http://www.alsa-project.org/db/?f=20d3a ... cff6c0ccb7
Awatar użytkownika
kobrawerde
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 156
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: kobrawerde » 20 mar 2018, 16:20

Może ten fix coś wniesie do sprawy ?
https://unix.stackexchange.com/question ... fch-azalia
albo spróbuj jak pisze w tym temacie zrobić downgrade / przywrócić poprzedni kernel kiedy audio działało poprawnie...
https://forums.fedoraforum.org/showthre ... f-a-sudden
Tu podobny problem z taką samą konfiguracją karty dźwiękowej... ostatecznie chyba rozwiązany instalując pavucontrol ....możesz sprawdzić :

Kod: Zaznacz cały

 lspci | grep Audio
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 02)
https://sparkylinux.org/forum/index.php ... 916.0.html
rafaln1
Sędziwy Jeż
Sędziwy Jeż
Posty: 52
Rejestracja: 20 wrz 2010, 22:50
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: Unity
Architektura: x86_64
Kontakt:

Re: Nie działa dźwięk po upgrade 17.10 - nie można zainstalować Pulse

Post autor: rafaln1 » 23 mar 2018, 20:51

Kolego, pisałes coś o Kernelu i o tym zacząłem grzebać w sieci.
Grzebałem... grzebałem i .. wygrzebałem to https://linuxhint.com/how-to-upgrade-th ... ntu-17-10/
Działa.
Dzięki za naprowadzenie na trop!
ODPOWIEDZ

Wróć do „Przedszkole Linuksa”