Brak regulacji jasności

Przenośne komputery i problemy z nimi związane
Mroovkoyad
Piegowaty Guziec
Piegowaty Guziec
Posty: 28
Rejestracja: 22 paź 2016, 16:56
Wersja Ubuntu: 17.04
Środowisko graficzne: Unity
Architektura: x86_64

Brak regulacji jasności

Post autor: Mroovkoyad » 30 sty 2018, 15:29

Na nowym laptopie miałem problem ze sterownikami nouveau rozwiązany poprzez dodanie do gruba "nomodeset".
https://ubuntu.pl/forum/viewtopic.php?f ... 4#p1024344

Aktualny problem polega na tym, że:
a - nie mam możliwości regulacji jasności ekranu;
b - wygaszacz ekranu nie wyłącza go, tylko tak jakby "świeci czernią";
c - nie mogę wstrzymać systemu. Tzn mogę, ale potem nie da się dobudzić komputera (tylko świecąca czerń).

W oprogramowaniu i aktualizacjach przełączyłem z otwartoźródłowego sterownika karty grafiki na własnościowy nVidii. Po restarcie pojawił się problem pętli logowania (jak tu: https://ubuntu.pl/forum/viewtopic.php?f ... e#p1024376). Pomogło

Kod: Zaznacz cały

sudo apt-get purge nvidia*
Co z tym zrobić? Nie obchodzi mnie jakich system używa sterowników, chcę tylko aby ekran działał normalnie.
Awatar użytkownika
e X t 7 3
Przyjaciel
Przyjaciel
Posty: 4939
Rejestracja: 07 maja 2009, 23:34
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: KDE4
Architektura: x86_64
Lokalizacja: Kraków
Kontakt:

Re: Brak regulacji jasności

Post autor: e X t 7 3 » 01 lut 2018, 11:29

Witaj

Zainstaluj nasz NeteXt'73 a tam: kernel [na razie standard], APM, sterowniki Nvidii, ustawienia grub dla intela i daj informację, czy działa poprawnie.

Pozdarwaim
Nie ma rzeczy niemożliwych ... są tylko trudne do zrobienia ;)

Moje kernele oraz skrypty:

NeteXt'73 - instalator kerneli i skryptów oraz optymalizator systemu w jednym > netext73.pl
Mroovkoyad
Piegowaty Guziec
Piegowaty Guziec
Posty: 28
Rejestracja: 22 paź 2016, 16:56
Wersja Ubuntu: 17.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Brak regulacji jasności

Post autor: Mroovkoyad » 07 lut 2018, 21:44

Ale po instalacji mam coś jeszcze zrobić? Bo sama instalacja nic nie pomogła.
Awatar użytkownika
e X t 7 3
Przyjaciel
Przyjaciel
Posty: 4939
Rejestracja: 07 maja 2009, 23:34
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: KDE4
Architektura: x86_64
Lokalizacja: Kraków
Kontakt:

Re: Brak regulacji jasności

Post autor: e X t 7 3 » 07 lut 2018, 22:01

Mroovkoyad pisze:
07 lut 2018, 21:44
Ale po instalacji mam coś jeszcze zrobić? Bo sama instalacja nic nie pomogła.
Jaki kernel wgrany, APM jak ustawione + Grub ?

Pozdrawiam
Nie ma rzeczy niemożliwych ... są tylko trudne do zrobienia ;)

Moje kernele oraz skrypty:

NeteXt'73 - instalator kerneli i skryptów oraz optymalizator systemu w jednym > netext73.pl
Mroovkoyad
Piegowaty Guziec
Piegowaty Guziec
Posty: 28
Rejestracja: 22 paź 2016, 16:56
Wersja Ubuntu: 17.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Brak regulacji jasności

Post autor: Mroovkoyad » 08 lut 2018, 15:52

Przepraszam, ale nie zrozumiałem nic z tego co napisałeś. Można jakoś prostszymi instrukcjami?

Jeżeli chodzi o plik GRUB, to wygląda tak:

Kod: Zaznacz cały

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Awatar użytkownika
e X t 7 3
Przyjaciel
Przyjaciel
Posty: 4939
Rejestracja: 07 maja 2009, 23:34
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: KDE4
Architektura: x86_64
Lokalizacja: Kraków
Kontakt:

Re: Brak regulacji jasności

Post autor: e X t 7 3 » 08 lut 2018, 23:18

Mroovkoyad pisze:
08 lut 2018, 15:52
Przepraszam, ale nie zrozumiałem nic z tego co napisałeś. Można jakoś prostszymi instrukcjami?

Jeżeli chodzi o plik GRUB, to wygląda tak:

Kod: Zaznacz cały

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Ok jutro odpisze - znaczy sie nic tam nie masz [co jest konieczne].

Pozdrawiam
Nie ma rzeczy niemożliwych ... są tylko trudne do zrobienia ;)

Moje kernele oraz skrypty:

NeteXt'73 - instalator kerneli i skryptów oraz optymalizator systemu w jednym > netext73.pl
Graba
Sędziwy Jeż
Sędziwy Jeż
Posty: 66
Rejestracja: 08 maja 2005, 06:26
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: GNOME
Architektura: x86_64
Lokalizacja: UK

Re: Brak regulacji jasności

Post autor: Graba » 10 lut 2018, 10:54

Witam

Jak bootujesz system nacisnij E a nastepnie dodaj to do lini gdzie jest wywolanie kernela
acpi_backlight=vendor
zapisz ustawienia (f10) i boot
jesli bedzie dzialac to dopisz to do pliku konfiguracyjnego Grub
Awatar użytkownika
e X t 7 3
Przyjaciel
Przyjaciel
Posty: 4939
Rejestracja: 07 maja 2009, 23:34
Płeć: Mężczyzna
Wersja Ubuntu: 14.04
Środowisko graficzne: KDE4
Architektura: x86_64
Lokalizacja: Kraków
Kontakt:

Re: Brak regulacji jasności

Post autor: e X t 7 3 » 10 lut 2018, 22:38

OK zatem zrób po kolei - start, a następnie instaluj wskazane komponenty. Konfiguracja APM, GRUB - jak na obrazkach:

Start

APM

GRUB

Pozdrawiam
Nie ma rzeczy niemożliwych ... są tylko trudne do zrobienia ;)

Moje kernele oraz skrypty:

NeteXt'73 - instalator kerneli i skryptów oraz optymalizator systemu w jednym > netext73.pl
ODPOWIEDZ

Wróć do „Laptopy”