Brak dostępu do maszyn w LAN po adresie z sufiksem DNS

Instalacja i konfiguracja oprogramowania sieciowego.
dplociniczak
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 27 mar 2018, 09:08
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Architektura: x86_64

Brak dostępu do maszyn w LAN po adresie z sufiksem DNS

Post autor: dplociniczak » 27 mar 2018, 09:14

Cześć,

Chciałem zacząć korzystać z Ubuntu, ale mam pewien problem natury sieciowej.
Po instalacji czytego systemu mimo, że mam poprawne adresy DNS to nie mam komunikacji z maszynami w LAN podając adres z sufiksem, tj.

PING devel.arch.local - nie działa (host nieznany)
PING devel - działa (są odpowiedzi PING)

Prośba o wsparcie.
Wszystko co udało mi się znaleźć w sieci nie skutkuje...

Pozdrawiam,
Darek
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7358
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Brak dostępu do maszyn w LAN po adresie z sufiksem DNS

Post autor: mario_7 » 27 mar 2018, 09:20

Domeny .local są traktowane w linuksie specjalnie, więc jeśli twoja domena nie jest taka "specjalna", to pewnie wystarczy że usuniesz pakiet libnss-mdns i po przelogowaniu wszystko zacznie działać.
Czytelnia - poczytaj, Google - poszukaj
dplociniczak
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 27 mar 2018, 09:08
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Architektura: x86_64

Re: Brak dostępu do maszyn w LAN po adresie z sufiksem DNS

Post autor: dplociniczak » 27 mar 2018, 09:27

Dziękuje - działa
dplociniczak
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 27 mar 2018, 09:08
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Architektura: x86_64

Re: Brak dostępu do maszyn w LAN po adresie z sufiksem DNS

Post autor: dplociniczak » 06 cze 2018, 15:08

Na Ubuntu 16.04 to działało.
Na wersji 18.04 już nie.
Ma ktoś jakiś pomysł?
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7358
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Brak dostępu do maszyn w LAN po adresie z sufiksem DNS

Post autor: mario_7 » 07 cze 2018, 22:42

No to może zmiana konfiguracji w pliku nsswitch.conf (umieszczenie dns przed wpisem [NOTFOUND=return]): https://serverfault.com/questions/93462 ... cal-domain
Czytelnia - poczytaj, Google - poszukaj
ODPOWIEDZ

Wróć do „Sieci, serwery, Internet”