Instalowanie adobeair w ubuntu 18.04

Wyłącznie system! Wątpliwości dotyczące aplikacji proszę umieszczać niżej, w odpowiednich forach.
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 28 kwie 2018, 12:05

W ubuntu 18.04 nie instaluje się adobe air w starszej wersji. W poprzednich systemach 64-bitowych np. ubuntu 16.04, po zainstalowaniu dodatkowych bibliotek taka instalacja była możliwa. W nowym systemie to nie działa. Poza tym nie instalują się programy z niektórych repozytoriów np repozytorium ppa:tomtomtom, mimo że programy te tam się znajdują, ukazuje się komunikat o ich braku. Nie wiem z czego to wynika. Czy to jest już takie uwarunkowanie, którego nie da się wyeliminować?
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7223
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mario_7 » 28 kwie 2018, 19:49

Jeśli chodzi o adobeair - co rozumiesz przez nie działa?
Jeśli chodzi o inne repozytoria - czy znajdują się tam pakiety w wersjach dla Ubuntu 18.04?
Czytelnia - poczytaj, Google - poszukaj
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 28 kwie 2018, 20:44

Przez nie działa mówię, że nie instaluje się, mimo zainstalowania tych samych bibliotek do systemu 32 bit co w ubuntu 16.04, wychodzi komunikat, że brak bibliotek a tak nie jest. Jeśli chodzi o repozytoria to nie wiadomo mi czy to jest wersja dla systemu ubuntu 18.04, ale z innych repozytoriów jak np. ppa://ubuntuhandbook1/dvdstyler nastąpiła instalacja programu.

Mdt
Awatar użytkownika
Spass
Sędziwy Jeż
Sędziwy Jeż
Posty: 34
Rejestracja: 19 paź 2006, 01:54
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: XFCE
Architektura: x86_64

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: Spass » 28 kwie 2018, 23:15

Z tego co widzę, to nie wszystkie repozytoria ppa:tomtomtom mają pakiety przygotowane pod Bionic (a łatwo to sprawdzić na stronie Launchpada), więc to pewnie jest przyczyną. Jak ci zależy na jakimś pakiecie to tymczasowo możesz modyfikować dany wpis w "Oprogramowanie i aktualizacje > Inne oprogramowanie" i zmienić na "artful" albo "xenial". Albo po prostu ściągnij DEB z Launchpada.
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 29 kwie 2018, 12:37

Dziękuję za informacje. Jeśli chodzi o pakiet k9copy to mogę się bez niego obejść. sprawdzałem repozytorium tomtomtom. Nie jest dostosowane do bionic, stąd niemożliwość zainstalowania . Próbowałem zmodyfikować i to też nic nie dało bo brakuje innych komponentów. To samo jest przy pakietach .deb, też nie da się ich zainstalować.
Ważniejsza jest dla mnie instalacja adobeair w takiej wersji jaka jest możliwa. Zainstalowałem wszystkie biblioteki na i386 z wyjątkiem jednej której nie udało się zainstalować tj.

Kod: Zaznacz cały

 libnss3-1d:i386
. Czy to ma wpływ na instalację programu?

Mtd
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 29 kwie 2018, 18:01

Udało mi się znaleźć tę bibliotekę i po zainstalowaniu jej adobeair zaczął się instalować, lecz pojawił się komunikat o innym błędzie następującej treści:

Kod: Zaznacz cały

W systemie nie można znaleźć narzędzi systemu Debian do tworzenia pakietów deb (np. dpkg-deb lub ar)
.
O ile mi wiadomo jest w systemie narzędzie dpkg-deb. Jak uaktywnić to narzędzie żeby instalator go widział? W poprzednich systemach tego nie było.

Mdt
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7223
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mario_7 » 01 maja 2018, 21:03

Może trzeba wersję 32-bitową zainstalować?
Czytelnia - poczytaj, Google - poszukaj
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 02 maja 2018, 09:07

W poprzednich dystrybucjach ubuntu 64 bitowych, po zainstalowaniu odpowiednich bibliotek 32 bitowych instalacja przebiegała prawidłowo.Problem dotyczy dystrybucji 18.04. Choćbym chciał to nie mogę zainstalować wersji 32 bitowej, bo jej nie ma. Ubuntu 18.04 jest tylko w architekturze 64 bitowej.

Mdt
Awatar użytkownika
Spass
Sędziwy Jeż
Sędziwy Jeż
Posty: 34
Rejestracja: 19 paź 2006, 01:54
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: XFCE
Architektura: x86_64

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: Spass » 02 maja 2018, 10:35

mdt pisze:
02 maja 2018, 09:07
Ubuntu 18.04 jest tylko w architekturze 64 bitowej.
Są repozytoria dla 32-bit, po prostu już nie tworzą obrazów ISO w tej architekturze.

Jeśli podejrzewasz, że sprawcą może być brak pakietu libnss3-1d to nie widzę go już w repozytoriach bionic. Jeśli chcesz, to możesz ściągnąć ten pakiet ręcznie stąd: https://packages.ubuntu.com/xenial/libnss3-1d (amd64 i i386). Ale może jest jakiś powód, dla którego tego pakietu już w bionic nie ma, tego nie wiem.

EDIT: Sorry, nie doczytałem, że znalazłeś tę bibliotekę.
Ostatnio zmieniony 02 maja 2018, 17:44 przez Spass, łącznie zmieniany 1 raz.
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 02 maja 2018, 16:16

Tego pakietu nie da się zainstalować w ubuntu 18.04. (nie spełnione zależności), Natomiast wcześniej pobrałem i zainstalowałem pakiet libnss3, a nie libnss3-1d w wersji 32 bitowej i instalator adobe air nie zgłasza błędu tego co poprzednio, lecz przerywa instalację i zgłasza błąd o braku w systemie narzędzi do tworzenia pakietów deb o treści którą podałem poprzednio. O ile mi wiadomo to narzędzia takie powinny być w systemie, dlaczego zatem jest zgłaszany błąd?
Mdt
Awatar użytkownika
ffatman
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 167
Rejestracja: 20 sie 2007, 07:24
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: XFCE
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: ffatman » 08 maja 2018, 03:43

Od lat nie ma wersji Adobe Air na linuksa, ściąganie starej wersji linuksowej skądeś tam nie ma sensu, bo i tak nic na niej nie pójdzie. Problem obchodziłem instalując aktualną wersję windowsowa przez Wine. Nie daję gwarancji na obejście, bo... przestało jakiś czas temu mi działać. Przestało się instalować. Nie wiem czemu, nie szukam, w dobie Electronu straciłem zainteresowanie.
Awatar użytkownika
Spass
Sędziwy Jeż
Sędziwy Jeż
Posty: 34
Rejestracja: 19 paź 2006, 01:54
Płeć: Mężczyzna
Wersja Ubuntu: 17.10
Środowisko graficzne: XFCE
Architektura: x86_64

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: Spass » 08 maja 2018, 12:39

Ja kilka dni temu trochę z tym walczyłem (zgadza się - to jakieś prehistoryczne wersje), bo chciałem sprawdzić czy dam radę odpalić program do podatków e-Deklaracje na moim Linuksie. Walka była dość ciężka, ale udało mi się nawet doprowadzić do stanu, w którym widzę ładne okno instalacyjne Adobe AIR 2.6, klikam OK, okno znika i dalej nie wiedziałem jak odpalić pliki .air, poddałem się. Pewnie za jakiś czas spróbuję odpalić e-Deklaracje w nowym Wine, bo to chyba jedyny program jakiego mi brakuje z Windowsa.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7223
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mario_7 » 09 maja 2018, 10:11

W tym PPA jest paczka dla Ubuntu 18.04 - może zadziała?
https://launchpad.net/~andykimpe/+archi ... ter=bionic
Czytelnia - poczytaj, Google - poszukaj
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 10 maja 2018, 07:59

Niestety, nie da się zainstalować adobeair z tego repozytorium . Wskazany jest brak zależności. Dziękuję, będę musiał w ostateczności skorzystać z wersji windows poprzez wine.

Mdt
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7223
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mario_7 » 10 maja 2018, 23:18

Byłoby łatwiej, gdybyś napisał jak dodałeś to repozytorium i jaki błąd jest zgłaszany...
Czytelnia - poczytaj, Google - poszukaj
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 11 maja 2018, 15:38

Repozytorium to dodałem w następujący sposób

Kod: Zaznacz cały

sudo add-apt-repository -y ppa:andykimpe/adobeair
sudo apt-get update
sudo apt-get -y install adobeair
nic z tego nie wyszło więc odinstalowałem repozytorium i dodałem go poraz drugi :

Kod: Zaznacz cały

sudo add-apt-repository ppa:andykimpe/adobeair
sudo apt-get update
i próbowałem zainstalować adobeair. w każdym przypadku otrzymałem taki komunikat :

Kod: Zaznacz cały

sudo apt-get install adobeair
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 adobeair : Wymaga: ia32-libs ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7223
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mario_7 » 13 maja 2018, 13:29

Pokaż wynik polecenia

Kod: Zaznacz cały

apt-cache policy adobeair
Czytelnia - poczytaj, Google - poszukaj
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 13 maja 2018, 16:14

Wynik polecenia jest następujący:

Kod: Zaznacz cały

 apt-cache policy adobeair
adobeair:
  Zainstalowana: (brak)
  Kandydująca:   1:2.6.0.20002-xenial
  Tabela wersji:
     1:2.6.0.20002-xenial 500
        500 http://ppa.launchpad.net/andykimpe/adobeair/ubuntu bionic/main amd64 Packages
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7223
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mario_7 » 13 maja 2018, 22:04

A dlaczego pakiet ia32-libs nie instaluje się? On też jest dostarczany przez to repozytorium PPA.
Czytelnia - poczytaj, Google - poszukaj
mdt
Sędziwy Jeż
Sędziwy Jeż
Posty: 30
Rejestracja: 02 mar 2017, 16:48
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: Instalowanie adobeair w ubuntu 18.04

Post autor: mdt » 14 maja 2018, 09:23

Już w kilku poprzednich wersjach począwszy od 14.04 (64 bit) nie można zainstalować pakietu ia32-libs, w miejsce tego pakietu instalowałem biblioteki 32 bitowe takie jak:

Kod: Zaznacz cały

 sudo apt-get install libxt6:i386 libnspr4-0d:i386 libgtk2.0-0:i386 libstdc++6:i386
libnss3-1d:i386 libnss-mdns:i386 libxml2:i386 libxslt1.1:i386 libcanberra-gtk-
module:i386 gtk2-engines-murrine:i386 libqt4-qt3support:i386 libgnome-keyring0:i386
libxaw7
i adobe air było instalowane, jak również inne programy działające w adobeair. W ubuntu 18.04 też zainstalowałem te same biblioteki, ale instalacja nie idzie,

Mdt
ODPOWIEDZ

Wróć do „Instalacja, aktualizacja i konfiguracja Ubuntu”