16.04 - nie wszystko się zainstalowało - Błąd

Wyłącznie system! Wątpliwości dotyczące aplikacji proszę umieszczać niżej, w odpowiednich forach.
Awatar użytkownika
Rocky2
Sędziwy Jeż
Sędziwy Jeż
Posty: 53
Rejestracja: 14 gru 2006, 12:07
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

16.04 - nie wszystko się zainstalowało - Błąd

Post autor: Rocky2 » 06 maja 2018, 12:36

Kilka dni temu była aktualizacja i było zdaje się aktualizacja do jądra. Coś musiało pójść źle, bo pojawił się tu jakiś błąd. Ubuntu działa tylko, że teraz po każdej aktualizacji potrzebuje 2x restart aby nie było informacji o tym, ze potrzebny jest restart. Teraz czasami ma jakieś "zwiechy" a lubię jak wszystko działa gładko, bo to przecież LTS i o to chodzi. Coś tam jest źle :(
Przestał się otwierać program "Proste Skanowanie" do skanera , a wolałbym aby to działało bo to potrzebuję. :(

Po komendzie autoremove podana jest info, ze po prostu wcześniej nie wszystko się zainstalowało (załącznik).
Czy da się to jakoś naprawić czy muszę wszystko przeinstalować ?
Załączniki
Błąd po Aktualizacji .png
(173.73 KiB) Nie pobierany
 Gnome³
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7223
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: 16.04 - nie wszystko się zainstalowało - Błąd

Post autor: mario_7 » 09 maja 2018, 10:51

Masz wolne miejsce na dysku?
Spróbuj uruchomić polecenia:

Kod: Zaznacz cały

sudo dpkg --configure -a
sudo apt-get install -f
Pokaż tekst jaki pojawił się w terminalu (skopiuj i wklej tekst, nie zdjęcie).
Czytelnia - poczytaj, Google - poszukaj
Awatar użytkownika
Rocky2
Sędziwy Jeż
Sędziwy Jeż
Posty: 53
Rejestracja: 14 gru 2006, 12:07
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: 16.04 - nie wszystko się zainstalowało - Błąd

Post autor: Rocky2 » 09 maja 2018, 11:55

Dzisiaj rano była jakaś aktualizacja zdaje się kernela. Więc miałem nadzieję, ze może ona to naprawi. Zainstalowała się ale niestety odziedziczyła błąd :(
Po tej aktualizacji Jeszcze raz próbowałem samodzielnie to naprawić posiłkując się info z sieci. Nie udało się.
Zdaje się coś do tego Kernela się nie zainstalowało czy nie skonfigurowało. Albo instalacja poprzedniej wersji się nie zakończyła poprawnie, a następna aktualizacja dziedziczy ten błąd i samodzielnie nie potrafi wyjść z tej sytuacji bo jest zaprogramowana na aktualizację do wersji z wyższym numerem czy coś podobnego. :( Jestem zielony jesli chodzi o tego kernela i pisze tylko to co mi się wydaje.

Te komendy co podałeś próbowałem ale one nie pomagają :???: Poniżej zamieszczam tekst z Terminala:

Kod: Zaznacz cały


        `:+ssssssssssssssssss+:`           -------------- 
      -+ssssssssssssssssssyyssss+-         OS: Ubuntu 16.04.4 LTS x86_64 
    .ossssssssssssssssssdMMMNysssso.       Host: Inspiron 5758 01 
   /ssssssssssshdmmNNmmyNMMMMhssssss/      Kernel: 4.13.0-38-generic 
  +ssssssssshmydMMMMMMMNddddyssssssss+     Uptime: 38 mins 
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/    Packages: 1966 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Shell: bash 4.3.48 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Resolution: 1600x900 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   DE: GNOME 3.18.5 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM: GNOME Shell 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   WM Theme: Adwaita 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Theme: Adwaita [GTK2/3] 
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/    Icons: Gnome [GTK2/3] 
  +sssssssssdmydMMMMMMMMddddyssssssss+     Terminal: gnome-terminal 
   /ssssssssssshdmNNNNmyNMMMMhssssss/      CPU: Intel i5-5200U (4) @ 2.700GHz 
    .ossssssssssssssssssdMMMNysssso.       GPU: NVIDIA GeForce 920M 
      -+sssssssssssssssssyyyssss+-         GPU: Intel Broadwell-U Integrated Gr 
        `:+ssssssssssssssssss+:`           Memory: 2549MiB / 7887MiB 
            .-/+oossssoo+/-. 
                                                                   


lipton@lip5758:~$ sudo apt-get install -f
[sudo] hasło użytkownika lipton: 
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
5 nie w pełni zainstalowanych lub usuniętych.
Po tej operacji zostanie dodatkowo użyte 0 B miejsca na dysku.
Konfigurowanie pakietu initramfs-tools (0.122ubuntu8.11) ...
update-initramfs: deferring update (trigger activated)
Konfigurowanie pakietu linux-image-4.13.0-39-generic (4.13.0-39.44~16.04.1) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-4.13.0-41-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.13.0-39-generic /boot/vmlinuz-4.13.0-39-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.13.0-39-generic /boot/vmlinuz-4.13.0-39-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.13.0-39-generic /boot/vmlinuz-4.13.0-39-generic
update-initramfs: Generating /boot/initrd.img-4.13.0-39-generic
cp: nie można wykonać stat na '/usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf': Nie ma takiego pliku ani katalogu
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-4.13.0-39-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.13.0-39-generic.postinst line 1052.
dpkg: błąd przetwarzania pakietu linux-image-4.13.0-39-generic (--configure):
 podproces zainstalowany skrypt post-installation zwrócił kod błędu 2
Konfigurowanie pakietu linux-image-4.13.0-41-generic (4.13.0-41.46~16.04.1) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-4.13.0-39-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.13.0-41-generic /boot/vmlinuz-4.13.0-41-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.13.0-41-generic /boot/vmlinuz-4.13.0-41-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.13.0-41-generic /boot/vmlinuz-4.13.0-41-generic
update-initramfs: Generating /boot/initrd.img-4.13.0-41-generic
cp: nie można wykonać stat na '/usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf': Nie ma takiego pliku ani katalogu
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-4.13.0-41-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.13.0-41-generic.postinst line 1052.
dpkg: błąd przetwarzania pakietu linux-image-4.13.0-41-generic (--configure):
 podproces zainstalowany skrypt post-installation zwrócił kod błędu 2
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu linux-image-extra-4.13.0-39-generic:
 linux-image-extra-4.13.0-39-generic zależy od linux-image-4.13.0-39-generic; jednakże:
  Pakiet linux-image-4.13.0-39-generic nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu linux-image-extra-4.13.0-39-generic (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Brak raportu programu apport, ponieważ komunikat błędu wskazuje, że przyczyna niepowodzenia leży w poprzednim błędzie.
                                      dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu linux-image-extra-4.13.0-41-generic:
 linux-image-extra-4.13.0-41-generic zależy od linux-image-4.13.0-41-generic; jednakże:
  Pakiet linux-image-4.13.0-41-generic nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu linux-image-extra-4.13.0-41-generic (--configure):
Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
                                                                   problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu initramfs-tools (0.122ubuntu8.11)...
update-initramfs: Generating /boot/initrd.img-4.13.0-38-generic
cp: nie można wykonać stat na '/usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf': Nie ma takiego pliku ani katalogu
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-4.13.0-38-generic with 1.
dpkg: błąd przetwarzania pakietu initramfs-tools (--configure):
 podproces zainstalowany skrypt post-installation zwrócił kod błędu 1
Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
                                                                  Wystąpiły błędy podczas przetwarzania:
 linux-image-4.13.0-39-generic
 linux-image-4.13.0-41-generic
 linux-image-extra-4.13.0-39-generic
 linux-image-extra-4.13.0-41-generic
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
lipton@lip5758:~$
---------------------------------------------------------------------

Z tego co tu widzę to Używam aktualnie wersję z końcówką 38, a problem jest z 39 i 41. Może należałoby jakoś wyrzucić te dwa linux-image 39 i 41 i spróbować zaktualizować jeszcze raz :confused:
 Gnome³
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7223
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: 16.04 - nie wszystko się zainstalowało - Błąd

Post autor: mario_7 » 10 maja 2018, 23:15

Jest jakiś problem ze złymi zależnościami... https://bugs.launchpad.net/ubuntu/+sour ... ug/1751184

masz plik DejaVuSerif.ttf gdzieś na dysku? Możesz to sprawdzić poleceniem

Kod: Zaznacz cały

locate DejaVuSerif.ttf
Jeśli tak, to spróbuj zrobić tak (w poleceniu cp podmień ścieżkę /usr/share/fonts/truetype/dejavu/DejaVuSerif.ttf na właściwą w twoim przypadku):

Kod: Zaznacz cały

sudo mkdir -p /usr/share/fonts/truetype/ttf-dejavu/
sudo cp /usr/share/fonts/truetype/dejavu/DejaVuSerif.ttf /usr/share/fonts/truetype/ttf-dejavu/
sudo apt-get install -f
Czytelnia - poczytaj, Google - poszukaj
Awatar użytkownika
Rocky2
Sędziwy Jeż
Sędziwy Jeż
Posty: 53
Rejestracja: 14 gru 2006, 12:07
Wersja Ubuntu: 16.04
Środowisko graficzne: GNOME
Architektura: x86_64
Kontakt:

Re: 16.04 - nie wszystko się zainstalowało - Błąd

Post autor: Rocky2 » 11 maja 2018, 07:32

Dziękuję za pomoc. Prawdopodobnie masz rację. Nie sadziłem, że czcionki mogą mieć znaczenia. Myślałem, :rolleyes: że ktoś odpowie tego samego dnia. Nie mogłem :-| dłużej czekać. Kombinowałem :ligt: tu samodzielnie aż zepsułem jeszcze więcej :???: . No ale tak się człowiek uczy. Kto nie próbuje ten się niczego nie nauczy :)
Przeinstalowałem na nowo i teraz mam czysty. Lubię jak wszystko działa jak należy.
;-)
 Gnome³
ODPOWIEDZ

Wróć do „Instalacja, aktualizacja i konfiguracja Ubuntu”