Zepsułam phpMyAdmin

Instalacja i konfiguracja oprogramowania sieciowego.
JoShiMa
Sędziwy Jeż
Sędziwy Jeż
Posty: 72
Rejestracja: 03 lis 2016, 10:11
Płeć: Kobieta
Wersja Ubuntu: 16.04

Zepsułam phpMyAdmin

Post autor: JoShiMa » 02 lip 2018, 20:52

Zaczłą mi się pojawiać błąd wg którego po zalogowaniu do phpMA nie miałam niektórych uprawnień. Podejrzewam że w akcie pomroczności jasnej podmieniłam sobie tabelę phpmyadmin kopjując tabele ze starego komputera.

Pomyślałam, że nie ma problemu usunę phpMA i zainstaluję od nowa. No i tak zrobiłam ale nadal mam problem, który się nazywa brak tabeli phpmyadmin i komunikat:
Przechowywania konfiguracji phpMyAdmin nie jest w pełni skonfigurowane, niektóre rozszerzone funkcje zostały wyłączone. Dowiedz się dlaczego.
Możesz też przejść do karty 'Operacje' dowolnej bazy danych, by skonfigurować tą opcję tylko dla tej bazy.
Po kliknięciu 'Dowiedz się dlaczego' i stworzeniu za pomocą kuszącego linka tabeli phpmyadmin mam z powrotem ten sam błąd wynikający z nieprawidłowej autoryzacji
Warning in ./libraries/sql.lib.php#613
count(): Parameter must be an array or an object that implements Countable

Backtrace

./libraries/sql.lib.php#2128: PMA_isRememberSortingOrder(array)
./libraries/sql.lib.php#2079: PMA_executeQueryAndGetQueryResponse(
array,
boolean true,
string 'phpmyadmin',
string 'pma__users',
NULL,
NULL,
NULL,
NULL,
NULL,
NULL,
string '',
string './themes/pmahomme/img/',
NULL,
NULL,
NULL,
string 'SELECT * FROM `pma__users`',
NULL,
NULL,
)
i tak dalej. To co ja jeszcze powinnam zrobić?
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7473
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: Zepsułam phpMyAdmin

Post autor: mario_7 » 09 lip 2018, 01:14

Spróbuj

Kod: Zaznacz cały

sudo dpkg-reconfigure phpmyadmin
i wybierz aby zainstalować bazę PMA na nowo.
Czytelnia - poczytaj, Google - poszukaj
ODPOWIEDZ

Wróć do „Sieci, serwery, Internet”