UBUNTU16.04 - nie ładuje compiz

Tematy specyficzne dla poszczególnych window managerów: KDE, GNOME, XFCE, Fluxbox, Blackbox, IceWM, WindowMaker, itd. - wszystko tutaj.
zenek
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 06 mar 2018, 12:34
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

UBUNTU16.04 - nie ładuje compiz

Post autor: zenek » 11 lip 2018, 19:17

Witam.
Pomimo, że nie przeprowadzałem żadnych aktualizacji ani nie grzebałem w plikach konfiguracyjnych od dzisiaj mam kłopot z prawidłowym uruchomieniem Unity (Ubuntu 16.04) tzn. po zalogowaniu widzę pulpit i ikony na nim ale brakuje całej reszty czyli bocznego paska oraz menu. Monitor systemu nie pokazuje compiz. Dodam, że na koncie gościa wszystko działa poprawnie.
Próbowałem już następujących metod:

Kod: Zaznacz cały

export DISPLAY=:0
sudo dconf reset -f /org/compiz/
setsid unity
usunięcia pliku koniguracyjnego

Kod: Zaznacz cały

rm -rf ~/.cache/compizconfig-1
Nie mogę skorzystać z reinstalacji bo nie mam dostępu do sieci (nie wiem jak odpalić połączenie modemowe z konsoli) ale mam nadzieję, że problem da się rozwiązać bez tego.

Załączam logi systemowe po zalogowaniu
https://wklejaj.pl/bkwWKozEaQXX

kluczowe chyba

Kod: Zaznacz cały

traps: -config-p[3685] general protection ip:7fe043f70d6f sp:7fffb1f22710 error:0 in libcompizconfig.so.0.0.0[7fe043f48000+52000]
Z góry dzięki za wszelkie sugestie.
Awatar użytkownika
Tomfoc
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1709
Rejestracja: 30 lis 2011, 21:14
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: UBUNTU16.04 - nie ładuje compiz

Post autor: Tomfoc » 11 lip 2018, 19:49

Laptop: Lenovo Ideapad 300, CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz × 4, GPU: Intel® HD Graphics 520 (Skylake GT2), RAM: 8 GB, HDD: 500 GB
zenek
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 06 mar 2018, 12:34
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: UBUNTU16.04 - nie ładuje compiz

Post autor: zenek » 12 lip 2018, 12:11

Po pierwsze utworzyłem nowe konto z przynależnością do grup tak jak podstawowe konto. Z tego konta zainstalowałem unity-tweak-tool a następnie przy jego pomocy przywróciłem wszystkie ustawienia do domyślnych (nie pomogło). Następnie korzystając ze wskazówek https://askubuntu.com/questions/992571/ ... -segfaults ustaliłem w pliku ~/.config/compiz-1/compizconfig/config wartość profile=unity. Sytuacja uległa zmianie tzn. uruchomił się compiz co sprawiło, że okna ponownie mogę przeciągać, zamykać... (nie napisałem tego wcześniej ale brakowało górnej belki). Niemniej w dalszym ciągu brak górnego menu i bocznego paska. Czyszczenie cache jakie również proponowano nic nie zmieniło.
Jakieś propozycje?
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7473
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: UBUNTU16.04 - nie ładuje compiz

Post autor: mario_7 » 12 lip 2018, 22:53

Problemem zdecydowanie jest jakaś konfiguracja compiza (lub compizconfig) ukryta w katalogu domowym użytkownika.
Może spróbuj zmienić nazwę katalogu .config/compiz na .config/compiz-bak
Czytelnia - poczytaj, Google - poszukaj
zenek
Piegowaty Guziec
Piegowaty Guziec
Posty: 5
Rejestracja: 06 mar 2018, 12:34
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Unity
Architektura: x86_64

Re: UBUNTU16.04 - nie ładuje compiz

Post autor: zenek » 13 lip 2018, 18:27

Wielkie dzięki @mario_7- proste rozwiązanie i skuteczne.
Co prawda widzę, że zaczyna grzać się karta graficzna. Widać z tego że to ja jakoś wcześniej (to dosyć stara instalacja) musiałem ustawić tryb pracy na low graphics i to w jakiś okolicznościach doprowadziło do awarii.
Jeszcze raz wielkie dzięki.
ODPOWIEDZ

Wróć do „Środowiska graficzne”