Konfigurowanie Samby, nie można się logować

Instalacja i konfiguracja oprogramowania sieciowego.
Gdobyl
Piegowaty Guziec
Piegowaty Guziec
Posty: 18
Rejestracja: 04 cze 2018, 00:45
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: Brak
Architektura: x86_64

Konfigurowanie Samby, nie można się logować

Post autor: Gdobyl » 08 sie 2018, 16:27

Mam Linuxa Ubuntu Server 16.04 i na nim postawiona Samba. Dodałem 15 użytkowników i porobiłem zasoby do których mają dostęp, okazuje się, że 14 może się logować a jedna osoba nie. Usuwałem konto, zakładałem na nowo efekt jest ten sam. Tak jakby coś blokowało tego użytkownika, może gdzieś zostaje wpis. Jak chce uruchomić zasób tego użytkownika i prosi mnie o nazwę i hasło po podaniu nie wpuszcza mnie dalej pisząc o złym haśle lub użytkowniku. Przy logowaniu do serwera przez ssh wszystko jest ok. Podglądałem plik Group (bo chyba tylko ten zawiera info o kontach i grupach)i jest tam wpis użytkownika i przynależność do grupy. Nie wiem co może blokować tego jednego użytkownika.
Ponadto mam utworzonego jednego użytkownika, który nie jest dopisany do grupy np. Biuro. Nie chciałem, żeby ta osoba miała dostęp do dokumentów grupy. Mimo, że w konfiguracji wpisałem @biuro to również osoba nie należąca do tej grupy ma dostęp. Gdzie robię błąd.
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7504
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Konfigurowanie Samby, nie można się logować

Post autor: mario_7 » 29 sie 2018, 00:07

Czytelnia - poczytaj, Google - poszukaj
Gdobyl
Piegowaty Guziec
Piegowaty Guziec
Posty: 18
Rejestracja: 04 cze 2018, 00:45
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: Brak
Architektura: x86_64

Re: Konfigurowanie Samby, nie można się logować

Post autor: Gdobyl » 14 wrz 2018, 15:48

w logu /var/log/samba mam:
[2018/09/14 15:43:13.115039, 0] ../source3/param/loadparm.c:3259(process_usershare_file)
process_usershare_file: stat of /var/lib/samba/usershares/wspolny failed. Permission denied
[2018/09/14 15:43:13.116792, 0] ../source3/param/loadparm.c:3259(process_usershare_file)
process_usershare_file: stat of /var/lib/samba/usershares/wspolny failed. No such file or directory


Co najdziwniejsze to katalog wspolny już dawno nie istnieje. Gdzieś są zapisane jeszcze te stare odnośniki, tyle że gdzie ? Nadal nie mogę się zalogować do samby
Ostatnio zmieniony 15 wrz 2018, 05:38 przez Gdobyl, łącznie zmieniany 1 raz.
Gdobyl
Piegowaty Guziec
Piegowaty Guziec
Posty: 18
Rejestracja: 04 cze 2018, 00:45
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: Brak
Architektura: x86_64

Re: Konfigurowanie Samby, nie można się logować

Post autor: Gdobyl » 14 wrz 2018, 15:58

Tak myślę, że może w pliku konfiguracyjnym mam coś nie hallo, dla tego użytkownika zmieniałem hasło kilka razy i może nie pamięta. Zerknijcie na konfiguracje
####### Authentication #######


server role = standalone server

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.
passdb backend = tdbsam

obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
map to guest = bad user
Ostatnio zmieniony 15 wrz 2018, 05:41 przez Gdobyl, łącznie zmieniany 1 raz.
Gdobyl
Piegowaty Guziec
Piegowaty Guziec
Posty: 18
Rejestracja: 04 cze 2018, 00:45
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: Brak
Architektura: x86_64

Re: Konfigurowanie Samby, nie można się logować

Post autor: Gdobyl » 14 wrz 2018, 16:46

Po dodaniu log level 1 mam coś takiego

[2018/09/14 16:41:46.066466, 5] ../source3/auth/auth.c:252(auth_check_ntlm_password)
check_ntlm_password: sam authentication for user [beata] FAILED with error NT_STATUS_WRONG_PASSWORD
[2018/09/14 16:41:46.066563, 2] ../source3/auth/auth.c:315(auth_check_ntlm_password)
check_ntlm_password: Authentication for user [beata] -> [beata] FAILED with error NT_STATUS_WRONG_PASSWORD

czy samba pamięta inne hasło niż te zapisane w systemie. Może ustawiłem hasło dla tego użytkownika poprzez smbpasswd i teraz jest ignorowanie te z passwd.
Dla użytkownika, który moze się zalogować mam poprawny wpis

check_ntlm_password: authentication for user [ewelina] -> [ewelina] -> [ewelina] succeeded
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7504
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Konfigurowanie Samby, nie można się logować

Post autor: mario_7 » 18 wrz 2018, 00:09

Tak, hasła utworzone przez smbpasswd są wyłącznie dla samby i nie są synchronizowane z hasłami systemowymi.
Czytelnia - poczytaj, Google - poszukaj
Gdobyl
Piegowaty Guziec
Piegowaty Guziec
Posty: 18
Rejestracja: 04 cze 2018, 00:45
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: Brak
Architektura: x86_64

Re: Konfigurowanie Samby, nie można się logować

Post autor: Gdobyl » 18 wrz 2018, 07:13

Ustawię identyczne hasło jak to systemowe i będzie ok. Próbowałem usunąć hasło smbpasswd z opcją -x ale po tym wchodzę do zasobu bez podania nazwy użytkownika i hasła. Zasób zrobił się taki jak public. Czy można zrobić tak, żeby samba korzystała z hasła systemowego?
Gdobyl
Piegowaty Guziec
Piegowaty Guziec
Posty: 18
Rejestracja: 04 cze 2018, 00:45
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: Brak
Architektura: x86_64

Re: Konfigurowanie Samby, nie można się logować

Post autor: Gdobyl » 18 wrz 2018, 22:29

Naszła mnie nowa myśl i proszę o podpowiedź czy jest to możliwe. Otóż, zamiast zakładania kont użytkowników systemowych chciałbym ich tylko utworzyć w sambie. Zawsze bezpieczniej bo po co mają mi się logować do systemu. Pytanie tylko tego typu jak zrobić grupy w sambie. Mam jednego użytkownika ( z zewnątrz) ,który nie może mieć dostępu do dokumentów przeznaczonych dla wszystkich użytkowników. Mam taki zasób wspólny dla wszystkich użytkowników. W systemie zrobiłem to tak, że wszystkich przypisałem do jednej grupy oprócz jednej osoby a później ten wspólny zasób zrobiłem jako valid users = @grupa. Czy można zrobić taki myk tylko w oparciu o tworzenie użytkowników poprzez smbpassword?
Awatar użytkownika
mario_7
Administrator
Administrator
Posty: 7504
Rejestracja: 30 sie 2006, 13:11
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Konfigurowanie Samby, nie można się logować

Post autor: mario_7 » 21 wrz 2018, 09:30

Grupę musisz utworzyć na poziomie systemu, a nie samby, zatem musisz mieć użytkowników systemowych, dodanych do właściwych grup i dopiero wtedy samba zacznie to rozpoznawać.

Jeśli nie chcesz, żeby użytkownicy mogli się logować do systemu, to ustaw im powłokę na nologin i zablokuj konta. Wtedy będą widnieli w systemie, ale nie będą się mogli logować do niego. Prawdopodobnie na sambę (bo tam inne hasło jest) będą mogli się wciąż logować.
Czytelnia - poczytaj, Google - poszukaj
ODPOWIEDZ

Wróć do „Sieci, serwery, Internet”