"Nieudane pobranie informacji z repozytoriów." podczas aktualizacji [solved]

Tutaj można zadać pytanie, jeśli Linuksa widzi się pierwszy raz w życiu ;)
kasparov
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 188
Rejestracja: 21 paź 2012, 18:58
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Xfce

"Nieudane pobranie informacji z repozytoriów." podczas aktualizacji [solved]

Post autor: kasparov » 08 wrz 2018, 16:47

Chcąc zaktualizować oprogramowanie klikam program "Aktualizacje oprogramowania". Połączenie mam, powiedzmy że stabilne Wi-fi, i ono działa. Od kilku tygodni po jakiejś aktualizacji lub sprzątaniu "Ubuntu Tweakiem" pojawiają się dziwne komunikaty przy updacie. Zrzuty w załączeniu.

Na początku uruchamiam "Aktualizacje".
Po chwili kręci się kółko i pojawia się okno z komunikatem "Nieudane pobranie informacji z repozytoriów. Proszę sprawdzić połączenie internetowe".
Klikając OK pojawia się kolejne okno z "Nie udało się zebrać informacji o aktualizacjach części oprogramowania i że inne aktualizacje mogą zostać pobrane"
Wybieram "Zainstaluj" i następuje instalacja.

Co zrobić, by naprawić repozytoria, aby się poprawnie aktualizowały?
Jestem bardzo przeciętnym użytkownikiem Linuksa w wersji 16.04 i proszę o proste wskazówki.
Dzięki.
Załączniki
Zrzut2z2.png
(272.18 KiB) Nie pobierany
Ostatnio zmieniony 08 wrz 2018, 21:05 przez kasparov, łącznie zmieniany 1 raz.
Awatar użytkownika
kobrawerde
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Problem z repozytoriami podczas aktualizacji

Post autor: kobrawerde » 08 wrz 2018, 16:57

kasparov
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 188
Rejestracja: 21 paź 2012, 18:58
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Xfce

Re: Problem z repozytoriami podczas aktualizacji

Post autor: kasparov » 08 wrz 2018, 17:02

Kod: Zaznacz cały

adam@myubuntu:~$ sudo apt-get update
[sudo] hasło użytkownika adam: 
Błąd:1 http://archive.getdeb.net/ubuntu xenial-getdeb InRelease
  Nie udało się połączyć z archive.getdeb.net:80 (144.76.200.19). - connect (111: Połączenie odrzucone)
Stary:2 http://pl.archive.ubuntu.com/ubuntu xenial InRelease
Stary:3 http://pl.archive.ubuntu.com/ubuntu xenial-updates InRelease
Stary:4 http://pl.archive.ubuntu.com/ubuntu xenial-backports InRelease
Stary:5 http://security.ubuntu.com/ubuntu xenial-security InRelease
Stary:6 https://repo.skype.com/deb stable InRelease
Stary:7 https://deb.opera.com/opera-stable stable InRelease
Czytanie list pakietów... Gotowe
W: Nie udało się pobrać http://archive.getdeb.net/ubuntu/dists/xenial-getdeb/InRelease  Nie udało się połączyć z archive.getdeb.net:80 (144.76.200.19). - connect (111: Połączenie odrzucone)
W: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub użyto ich starszej wersji.
I co teraz?

P.S. Od pewnego czasu wolę zapytać się Was niż próbować wszystkiego z netu. Kilka lat temu tak porobiłem ustawiając sobie 12.04, że zakrzaczyłem system, ponieważ niektóre porady pomogły, a inne nie.
Awatar użytkownika
kobrawerde
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Problem z repozytoriami podczas aktualizacji

Post autor: kobrawerde » 08 wrz 2018, 17:37

Podstawa .....to chyba nie trzeba przypominać BACKUP SYSTEMU ! ...a ponieważ już raz to przeżywałeś to trochę się dziwię ...
Nikt Ci nie poda 100% -towego rozwiązania zawsze może w systemie linux coś pójść nie tak każdy ma inną konfigurację / zależności programów / własne repozytoria itd. Zainteresuj się najpierw np. takim programem jak CloneZilla.
Wracając do tematu chyba trzeba przepatrzyć właśnie listę repozytoriów w : /etc/apt/sources.list
nie zaszkodzi:

Kod: Zaznacz cały

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
Czy aby na pewno jest to poprawne repo : http://archive.getdeb.net/ubuntu xenial-getdeb InRelease ???
ja bym je odnalazł i usunął ....
mój sources.list ( Xubuntu 18.04.1 LTS ) :
Załączniki
sources.list.txt
(3 KiB) Pobrany 5 razy
Ostatnio zmieniony 08 wrz 2018, 17:52 przez kobrawerde, łącznie zmieniany 1 raz.
kasparov
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 188
Rejestracja: 21 paź 2012, 18:58
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Xfce

Re: Problem z repozytoriami podczas aktualizacji

Post autor: kasparov » 08 wrz 2018, 17:50

Kod: Zaznacz cały

adam@myubuntu:~$ sudo apt-get clean
[sudo] hasło użytkownika adam: 

Kod: Zaznacz cały

adam@myubuntu:~$ sudo apt-get update
Stary:1 http://pl.archive.ubuntu.com/ubuntu xenial InRelease
Błąd:2 http://archive.getdeb.net/ubuntu xenial-getdeb InRelease                
  Nie udało się połączyć z archive.getdeb.net:80 (144.76.200.19). - connect (111: Połączenie odrzucone)
Stary:3 http://pl.archive.ubuntu.com/ubuntu xenial-updates InRelease           
Stary:4 http://pl.archive.ubuntu.com/ubuntu xenial-backports InRelease         
Pobieranie:5 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Stary:6 https://repo.skype.com/deb stable InRelease        
Stary:7 https://deb.opera.com/opera-stable stable InRelease  
Pobrano 107 kB w 1s (105 kB/s)                               
Czytanie list pakietów... Gotowe
W: Nie udało się pobrać http://archive.getdeb.net/ubuntu/dists/xenial-getdeb/InRelease  Nie udało się połączyć z archive.getdeb.net:80 (144.76.200.19). - connect (111: Połączenie odrzucone)
W: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub użyto ich starszej wersji.

Kod: Zaznacz cały

adam@myubuntu:~$ sudo apt-get upgrade
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Obliczanie aktualizacji... Gotowe
Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
  linux-image-unsigned-4.15.0-29-generic
  linux-image-unsigned-4.15.0-32-generic linux-modules-4.15.0-24-generic
  linux-modules-4.15.0-29-generic linux-modules-4.15.0-30-generic
Aby je usunąć należy użyć "sudo apt autoremove".
Następujące pakiety zostaną zaktualizowane:
  gnome-software gnome-software-common libpam-systemd libsystemd0
  libsystemd0:i386 libudev1 libudev1:i386 libunity-control-center1
  python3-update-manager systemd systemd-sysv ubuntu-software udev
  unity-control-center unity-control-center-faces update-manager
  update-manager-core
17 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 9733 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 46,1 kB miejsca na dysku.
Kontynuować? [T/n] T
Pobieranie:1 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libpam-systemd amd64 229-4ubuntu21.4 [115 kB]
Pobieranie:2 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libudev1 amd64 229-4ubuntu21.4 [54,1 kB]
Pobieranie:3 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main i386 libudev1 i386 229-4ubuntu21.4 [57,3 kB]
Pobieranie:4 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 udev amd64 229-4ubuntu21.4 [993 kB]
Pobieranie:5 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main i386 libsystemd0 i386 229-4ubuntu21.4 [222 kB]
Pobieranie:6 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libsystemd0 amd64 229-4ubuntu21.4 [204 kB]
Pobieranie:7 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 systemd amd64 229-4ubuntu21.4 [3615 kB]
Pobieranie:8 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 systemd-sysv amd64 229-4ubuntu21.4 [11,6 kB]
Pobieranie:9 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 python3-update-manager all 1:16.04.13 [32,6 kB]
Pobieranie:10 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 update-manager-core all 1:16.04.13 [5496 B]
Pobieranie:11 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 update-manager all 1:16.04.13 [543 kB]
Pobieranie:12 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 ubuntu-software amd64 3.20.5-0ubuntu0.16.04.11 [11,6 kB]
Pobieranie:13 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 gnome-software amd64 3.20.5-0ubuntu0.16.04.11 [251 kB]
Pobieranie:14 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 gnome-software-common all 3.20.5-0ubuntu0.16.04.11 [2521 kB]
Pobieranie:15 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libunity-control-center1 amd64 15.04.0+16.04.20171130-0ubuntu1 [81,1 kB]
Pobieranie:16 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 unity-control-center amd64 15.04.0+16.04.20171130-0ubuntu1 [835 kB]
Pobieranie:17 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 unity-control-center-faces all 15.04.0+16.04.20171130-0ubuntu1 [180 kB]
Pobrano 9733 kB w 5s (1923 kB/s)                    
(Odczytywanie bazy danych ... 220121 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../libpam-systemd_229-4ubuntu21.4_amd64.deb ...
Rozpakowywanie pakietu libpam-systemd:amd64 (229-4ubuntu21.4) nad (229-4ubuntu21.2) ...
Przygotowywanie do rozpakowania pakietu .../libudev1_229-4ubuntu21.4_i386.deb ...
Dekonfigurowanie pakietu libudev1:amd64 (229-4ubuntu21.2) ...
Rozpakowywanie pakietu libudev1:i386 (229-4ubuntu21.4) nad (229-4ubuntu21.2) ...
Przygotowywanie do rozpakowania pakietu .../libudev1_229-4ubuntu21.4_amd64.deb ...
Rozpakowywanie pakietu libudev1:amd64 (229-4ubuntu21.4) nad (229-4ubuntu21.2) ...
Przetwarzanie wyzwalaczy pakietu man-db (2.7.5-1)...
Przetwarzanie wyzwalaczy pakietu libc-bin (2.23-0ubuntu10)...
Konfigurowanie pakietu libudev1:amd64 (229-4ubuntu21.4) ...
Konfigurowanie pakietu libudev1:i386 (229-4ubuntu21.4) ...
Przetwarzanie wyzwalaczy pakietu libc-bin (2.23-0ubuntu10)...
(Odczytywanie bazy danych ... 220121 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../udev_229-4ubuntu21.4_amd64.deb ...
Rozpakowywanie pakietu udev (229-4ubuntu21.4) nad (229-4ubuntu21.2) ...
Przygotowywanie do rozpakowania pakietu .../libsystemd0_229-4ubuntu21.4_amd64.deb ...
Dekonfigurowanie pakietu libsystemd0:i386 (229-4ubuntu21.2) ...
Rozpakowywanie pakietu libsystemd0:amd64 (229-4ubuntu21.4) nad (229-4ubuntu21.2) ...
Przygotowywanie do rozpakowania pakietu .../libsystemd0_229-4ubuntu21.4_i386.deb ...
Rozpakowywanie pakietu libsystemd0:i386 (229-4ubuntu21.4) nad (229-4ubuntu21.2) ...
Przygotowywanie do rozpakowania pakietu .../systemd_229-4ubuntu21.4_amd64.deb ...
Rozpakowywanie pakietu systemd (229-4ubuntu21.4) nad (229-4ubuntu21.2) ...
Przetwarzanie wyzwalaczy pakietu man-db (2.7.5-1)...
Przetwarzanie wyzwalaczy pakietu ureadahead (0.100.0-19)...
ureadahead will be reprofiled on next reboot
Przetwarzanie wyzwalaczy pakietu libc-bin (2.23-0ubuntu10)...
Konfigurowanie pakietu libsystemd0:amd64 (229-4ubuntu21.4) ...
Konfigurowanie pakietu libsystemd0:i386 (229-4ubuntu21.4) ...
Konfigurowanie pakietu systemd (229-4ubuntu21.4) ...
addgroup: Grupa "systemd-journal" już istnieje jako grupa systemowa. Kończenie.
Przetwarzanie wyzwalaczy pakietu dbus (1.10.6-1ubuntu3.3)...
Przetwarzanie wyzwalaczy pakietu libc-bin (2.23-0ubuntu10)...
(Odczytywanie bazy danych ... 220121 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../systemd-sysv_229-4ubuntu21.4_amd64.deb ...
Rozpakowywanie pakietu systemd-sysv (229-4ubuntu21.4) nad (229-4ubuntu21.2) ...
Przetwarzanie wyzwalaczy pakietu man-db (2.7.5-1)...
Konfigurowanie pakietu systemd-sysv (229-4ubuntu21.4) ...
(Odczytywanie bazy danych ... 220121 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../python3-update-manager_1%3a16.04.13_all.deb ...
Rozpakowywanie pakietu python3-update-manager (1:16.04.13) nad (1:16.04.12) ...
Przygotowywanie do rozpakowania pakietu .../update-manager-core_1%3a16.04.13_all.deb ...
Rozpakowywanie pakietu update-manager-core (1:16.04.13) nad (1:16.04.12) ...
Przygotowywanie do rozpakowania pakietu .../update-manager_1%3a16.04.13_all.deb ...
Rozpakowywanie pakietu update-manager (1:16.04.13) nad (1:16.04.12) ...
Przygotowywanie do rozpakowania pakietu .../ubuntu-software_3.20.5-0ubuntu0.16.04.11_amd64.deb ...
Rozpakowywanie pakietu ubuntu-software (3.20.5-0ubuntu0.16.04.11) nad (3.20.5-0ubuntu0.16.04.10) ...
Przygotowywanie do rozpakowania pakietu .../gnome-software_3.20.5-0ubuntu0.16.04.11_amd64.deb ...
Rozpakowywanie pakietu gnome-software (3.20.5-0ubuntu0.16.04.11) nad (3.20.5-0ubuntu0.16.04.10) ...
Przygotowywanie do rozpakowania pakietu .../gnome-software-common_3.20.5-0ubuntu0.16.04.11_all.deb ...
Rozpakowywanie pakietu gnome-software-common (3.20.5-0ubuntu0.16.04.11) nad (3.20.5-0ubuntu0.16.04.10) ...
Przygotowywanie do rozpakowania pakietu .../libunity-control-center1_15.04.0+16.04.20171130-0ubuntu1_amd64.deb ...
Rozpakowywanie pakietu libunity-control-center1 (15.04.0+16.04.20171130-0ubuntu1) nad (15.04.0+16.04.20170214-0ubuntu2) ...
Przygotowywanie do rozpakowania pakietu .../unity-control-center_15.04.0+16.04.20171130-0ubuntu1_amd64.deb ...
Rozpakowywanie pakietu unity-control-center (15.04.0+16.04.20171130-0ubuntu1) nad (15.04.0+16.04.20170214-0ubuntu2) ...
Przygotowywanie do rozpakowania pakietu .../unity-control-center-faces_15.04.0+16.04.20171130-0ubuntu1_all.deb ...
Rozpakowywanie pakietu unity-control-center-faces (15.04.0+16.04.20171130-0ubuntu1) nad (15.04.0+16.04.20170214-0ubuntu2) ...
Przetwarzanie wyzwalaczy pakietu libglib2.0-0:amd64 (2.48.2-0ubuntu4)...
Przetwarzanie wyzwalaczy pakietu libglib2.0-0:i386 (2.48.2-0ubuntu4)...
Przetwarzanie wyzwalaczy pakietu desktop-file-utils (0.22-1ubuntu5.2)...
Przetwarzanie wyzwalaczy pakietu bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1)...
Rebuilding /usr/share/applications/bamf-2.index...
Przetwarzanie wyzwalaczy pakietu gnome-menus (3.13.3-6ubuntu3.1)...
Przetwarzanie wyzwalaczy pakietu mime-support (3.59ubuntu1)...
Przetwarzanie wyzwalaczy pakietu man-db (2.7.5-1)...
Przetwarzanie wyzwalaczy pakietu gconf2 (3.2.6-3ubuntu6)...
Przetwarzanie wyzwalaczy pakietu hicolor-icon-theme (0.15-0ubuntu1.1)...
Przetwarzanie wyzwalaczy pakietu libc-bin (2.23-0ubuntu10)...
Konfigurowanie pakietu libpam-systemd:amd64 (229-4ubuntu21.4) ...
Konfigurowanie pakietu udev (229-4ubuntu21.4) ...
addgroup: Grupa "input" już istnieje jako grupa systemowa. Kończenie.
update-initramfs: deferring update (trigger activated)
Konfigurowanie pakietu python3-update-manager (1:16.04.13) ...
Konfigurowanie pakietu update-manager-core (1:16.04.13) ...
Konfigurowanie pakietu update-manager (1:16.04.13) ...
Konfigurowanie pakietu gnome-software-common (3.20.5-0ubuntu0.16.04.11) ...
Konfigurowanie pakietu gnome-software (3.20.5-0ubuntu0.16.04.11) ...
Konfigurowanie pakietu ubuntu-software (3.20.5-0ubuntu0.16.04.11) ...
Konfigurowanie pakietu libunity-control-center1 (15.04.0+16.04.20171130-0ubuntu1) ...
Konfigurowanie pakietu unity-control-center (15.04.0+16.04.20171130-0ubuntu1) ...
Konfigurowanie pakietu unity-control-center-faces (15.04.0+16.04.20171130-0ubuntu1) ...
Przetwarzanie wyzwalaczy pakietu initramfs-tools (0.122ubuntu8.11)...
update-initramfs: Generating /boot/initrd.img-4.15.0-33-generic
W: Possible missing firmware /lib/firmware/i915/kbl_guc_ver9_14.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_ver8_7.bin for module i915
Przetwarzanie wyzwalaczy pakietu libc-bin (2.23-0ubuntu10)...
i nic się nie zmieniło. Tak samo pojawiają się dziwaczne komunikaty.

Odhaczyłem "http://archive.getdeb.net/ubuntu"z zakładki "Inne oprogramowanie" programu "Aktualizacje... " i chyba jest już w porządku. Przynajmniej nic dziwnego i niepokojącego się nie pojawia. Czy bez tego "http://archive.getdeb.net/ubuntu" można spokojnie pracować na Linuksie czy było/jest to coś ważnego?
Awatar użytkownika
kobrawerde
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Problem z repozytoriami podczas aktualizacji

Post autor: kobrawerde » 08 wrz 2018, 17:54

Wspomniałem wyżej że ja go nie mam w repo .... możesz przejrzeć moje wpisy w pliku : sources.list.txt
kasparov
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 188
Rejestracja: 21 paź 2012, 18:58
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: Xfce

Re: Problem z repozytoriami podczas aktualizacji

Post autor: kasparov » 08 wrz 2018, 17:59

Na razie odhaczyłem. Usunąć?
Nie wiem skąd się tam wzięło.
Awatar użytkownika
kobrawerde
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 209
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Problem z repozytoriami podczas aktualizacji

Post autor: kobrawerde » 08 wrz 2018, 18:02

Nie musisz jeśli odhaczyłeś :-) ...bo nie działa ! trzeba poszperać co to za repo ...
Ale przypominam na przyszłość kopia partycji z systemem lub dysku i ...śpisz spokojnie :-)
CloneZilla zapisuje kopię tylko "używanych / zapisanych " danych więc nie będzie to cała partycja u mnie np. z 65GB przeważnie wychodzi ok 9 - 10GB i jakieś 10 ..15 min i system przywrócony .
Wynika iż pewnie repozytorium na razie nie działa ...może awaria ? ..... ponoć ma serwery lustrzane które można dodać w zamian poczytaj:
https://askubuntu.com/questions/51692/w ... ry-is-down
Awatar użytkownika
lcoyote
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 177
Rejestracja: 30 lis 2017, 16:33
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: Xfce
Architektura: x86_64
Lokalizacja: Vichy, Auvergne-Rhone Alpes, Francja

Re: Problem z repozytoriami podczas aktualizacji

Post autor: lcoyote » 08 wrz 2018, 18:59

Ja bym radził odchaczyć "automatyczne aktualizacje" i dodatkowo w konsoli wpisać
Polecenie naprawiania zależności i dodawania do instalacji niezainstalowanych pakietów

# sudo apt-get install -f
============================
CloneZilla jest OK, ale jak człowiek kilkanaście razy zacznie instalować system (tutaj Linux) - to nabywa DOŚWIADCZENIA. Według mnie rozsądniejsze jest stosowanie poleceń z konsoli do aktualizacji systemu, czyli najpierw;
sudo apt-get update
a potem
sudo apt-get upgrade
----------------------------------------------------------------------------
« Jesteśmy pyłkiem i wielkością »
Użytkownik Xubuntu 18.04.1 LTS na Packard Dell "IXTREME-MC-9625" i Lenovo G585 w języku francuskim i polskim.
ODPOWIEDZ

Wróć do „Przedszkole Linuksa”