18.04.1 LTS czarny ekran po uśpieniu

Wyłącznie system! Wątpliwości dotyczące aplikacji proszę umieszczać niżej, w odpowiednich forach.
btanreb
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 14 paź 2016, 15:30

18.04.1 LTS czarny ekran po uśpieniu

Post autor: btanreb » 14 wrz 2018, 21:27

Kiedy chcę wzbudzić komputer po uśpieniu, mam czarny ekran (monitor nie włącza się). Ktoś z Was miał podobny problem?
Wyczytałem, że może to być problem ze sterownikami karty graficznej.

System: Ubuntu 18.04.1 LTS
Kernel: 4.15.0-34-generic
Grafika: GeForce GTX 1060
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 306
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: kobrawerde » 14 wrz 2018, 23:03

Nie wiem czy to czasem nie jest wina kernela ... bo przeważnie takie "klocki" z opcją suspend są po upgrade do nowszej wersji jądra
btanreb
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 14 paź 2016, 15:30

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: btanreb » 19 wrz 2018, 13:41

Niestety to nie wina kernela. Mam taki sam na innym komputerze (laptopie) i tam uśpienie działa prawidłowo.

Ktoś ma jakiś inny pomysł?
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 306
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: kobrawerde » 19 wrz 2018, 17:38

Wybacz ale ten sam kernel na obu różnych PC / laptopach nie świadczy o tym że jest z nim wszystko OK :-) ... może oznaczać tylko tyle że z jednym zestawem działa prawidłowo a z innym już niekoniecznie ....
Za mało danych podajesz jaki to model PC / płyta główna / procek ... a najlepiej info z komendy:

Kod: Zaznacz cały

inxi -Fxz
btanreb
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 14 paź 2016, 15:30

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: btanreb » 22 wrz 2018, 11:15

Proszę, info z tej komendy:

Kod: Zaznacz cały

System:    Host: btanreb Kernel: 4.15.0-29-generic x86_64 bits: 64 gcc: 7.3.0
           Console: tty 0 Distro: Ubuntu 18.04.1 LTS
Machine:   Device: desktop Mobo: ASRock model: Z170 Gaming K4 serial: <filter>
           UEFI [Legacy]: American Megatrends v: P3.20 date: 07/06/2016
CPU:       Quad core Intel Core i5-6600K (-MCP-) 
           arch: Skylake-S rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28032
           clock speeds: max: 3900 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz
           4: 800 MHz
Graphics:  Card: NVIDIA GP106 [GeForce GTX 1060 6GB] bus-ID: 06:00.0
           Display Server: X.Org 1.19.6 driver: nouveau
           Resolution: 1280x1024@60.02hz
           OpenGL: renderer: NV136 version: 4.3 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 NVIDIA GP106 High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 06:00.1
           Card-2 Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network:   Card: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller
           driver: alx port: e000 bus-ID: 05:00.0
           IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1240.3GB (1.2% used)
           ID-1: /dev/sda model: GOODRAM size: 240.1GB temp: 30C
           ID-2: /dev/sdb model: WDC_WD1003FZEX size: 1000.2GB temp: 28C
Partition: ID-1: / size: 28G used: 4.4G (17%) fs: ext4 dev: /dev/sda5
           ID-2: /boot size: 941M used: 76M (9%) fs: ext4 dev: /dev/sda6
           ID-3: /home size: 15G used: 85M (1%) fs: ext4 dev: /dev/sda7
           ID-4: swap-1 size: 10.00GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda8
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 37.5C mobo: N/A gpu: 37.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 287 Uptime: 2 min Memory: 1589.2/15987.1MB
           Init: systemd runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3959
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: jacekalex » 22 wrz 2018, 12:46

Problem może być w Kernelu, Xorgu, w Systemd, w sterowniku karty graficznej lub w środowisku graficznym.

Na początek:

Kod: Zaznacz cały

Graphics:  Card: NVIDIA GP106 [GeForce GTX 1060 6GB] bus-ID: 06:00.0
           Display Server: X.Org 1.19.6 driver: nouveau
Czy na binarnym sterowniku Nvidia (masz takowy w repo non-free) są podobne objawy.

Bo u mnie system usypiany poleceniem

Kod: Zaznacz cały

sudo pm-suspend
budzi się grzecznie:

Kod: Zaznacz cały

Graphics:  Card: NVIDIA GM107 [GeForce GTX 750] bus-ID: 01:00.0
           Display Server: X.org 1.20.0 driver: nvidia
Oprócz tego sensory mobo masz nieskonfigurowane:
Dowód rzeczowy:

Kod: Zaznacz cały

Sensors:   System Temperatures: cpu: 37.5C mobo: N/A gpu: 37.0
           Fan Speeds (in rpm): cpu: N/A
U mnie:

Kod: Zaznacz cały

Sensors:   System Temperatures: cpu: 40.0C mobo: 44.0C gpu: 0.0:38C
           Fan Speeds (in rpm): cpu: 1080 mobo: 1200
Coś mi się zdaje, że polecenie:

Kod: Zaznacz cały

sudo sensors-detect
i dopisanie podanych w jego wyniku modułów do /etc/modules Cię nie minie.
Oczywiście najpierw trzeba zainstalować paczkę lm-sensors:

Kod: Zaznacz cały

sudo apt install -y   lm-sensors
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
btanreb
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 14 paź 2016, 15:30

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: btanreb » 22 wrz 2018, 13:38

Zmieniłem na sterownik Nvidia, wykonałem polecenie sensors-detect z dopisaniem do /etc/modules.

Niestety nic, to nie pomogło. Dodatkowo po w/w czynnościach straciłem połączenie sieciowe. :shock:
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3959
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: jacekalex » 22 wrz 2018, 14:13

Jakim cudem straciłeś połączenie sieciowe?

Ani sterownik Nvidii ani sensors-detetect nie mają literalnie nic wspólnego z siecią.

Na 99% Network-manager świruje, to dosyć częsta przypadłość w tym programie.
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
btanreb
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 14 paź 2016, 15:30

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: btanreb » 22 wrz 2018, 15:52

Nie wiem właśnie jakim cudem :D

Jakieś inne wskazówki co do problemu wzbudzenia systemu?
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3959
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: jacekalex » 22 wrz 2018, 16:12

Ja bym brał Stabilnego Debiana, a nie Ubuntu.

Ubuntu bazuje na Debianie Sid, taka migawka z Sida jest poprawiana przez 6 miesięcy i wydawana jako stabilne wydanie Ubuntu.
Potem ma cale tony błędów, jak każdy "łatwy system".

Dla porównania Debian testing staje się stabilny dopiero, jak załatają w nim wszystkie ważne błędy
(co trwa zazwyczaj około 18-24 miesiące).
Migawka Sida staje się testingiem dopiero, jak testing staje się nowym stabilnym wydaniem.

Do tego przy Debianie pracuje około tysiąca Developerów, a Ubuntu robi 150 osób, w tym sprzątaczki, kucharki i sekretarki. xD
https://wiki.debian.org/DebianReleases# ... statistics

Pozdro
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
btanreb
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 14 paź 2016, 15:30

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: btanreb » 22 wrz 2018, 18:10

Postawiłem debiana 9, ale występuje ten sam problem. :-x
Dodatkowo popsułem coś przy instalacji sterowników nvidia, bo nie mogę teraz włączyć systemu (czarny ekran) :clap:

Nie mam pojęcia w czym jest problem...
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3959
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: jacekalex » 22 wrz 2018, 19:01

Kod: Zaznacz cały

Zobacz w takim razie /var/log/kern.log
I poszukaj w takim razie w biosie, czy tam coś dziwnego nie jest ustawione.
Jeśli system siębudzi, ale nie ma Xorga, tylko czarny ekran, to powinienieś móc wyjść na konsolę przyciskami Alt+Ctrl+{numer konsoli} gdzie numer konsoli to 1 do 6.

Przy okazji, w Debianie u Ciebie Xorg wstaje jako root czy jako użytkownik?

Kod: Zaznacz cały

ps aux | grep -v grep | grep X
Tak to ustalisz.

Bo przy sterze Nvidii, często bywają kłopoty jak Xorg chodzi na koncie użytkownika, nie roota - bez bitu SUID.

PS.
Problem dosyć znany:
https://www.google.pl/search?source=hp& ... end+nvidia

Może to jakoś poprawią, podejrzewam też, że może Xorg-1.19 świruje, też miałem z nim jakieś cyrki, nie pamiętam teraz, o co chodziło, także zmieniłem na Xorga-1.20.
Inna sprawa, że w moim Linuxie (Gentoo) mam zawsze wybór kilku wersji.

Pozdro
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 306
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: kobrawerde » 22 wrz 2018, 20:19

Trochę poszperałem w necie i ta płyta główna ma problemy z BIOS-em ...może sprawdzić pod tym kątem ?
btanreb
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 14 paź 2016, 15:30

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: btanreb » 22 wrz 2018, 20:50

Popatrzę w biose czy nie ma tam czegoś ciekawego.

Tylko, że jest taka sprawa, że jak odsypiam, to do monitora nie dochodzi w ogóle sygnał. Monitor jest w stanie uśpienia, więc do konsoli nie mam szansy wejść po wzbudzeniu systemu.
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 306
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: kobrawerde » 22 wrz 2018, 20:57

A w ogóle jest to najnowszy BIOS do tej płyty głównej ...może są jakieś poprawki ?
btanreb
Piegowaty Guziec
Piegowaty Guziec
Posty: 11
Rejestracja: 14 paź 2016, 15:30

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: btanreb » 22 wrz 2018, 22:08

Faktycznie BIOS miał aktualizację. Przeprowadziłem ją, ale nadal bez zmian.

Dodatkowo postawiłem całkowicie inna dystrybucją, Fedora. Myślałem, że może coś debianowe dystrybucje się gryzą, ale niestety na Fedorze również nie mogę wzbudzić systemu po uśpieniu. :pt36:
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3959
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Re: 18.04.1 LTS czarny ekran po uśpieniu

Post autor: jacekalex » 22 wrz 2018, 22:23

btanreb pisze:
22 wrz 2018, 22:08
Faktycznie BIOS miał aktualizację. Przeprowadziłem ją, ale nadal bez zmian.

Dodatkowo postawiłem całkowicie inna dystrybucją, Fedora. Myślałem, że może coś debianowe dystrybucje się gryzą, ale niestety na Fedorze również nie mogę wzbudzić systemu po uśpieniu. :pt36:

Kod: Zaznacz cały

Mobo: ASRock model: Z170 Gaming K
Nie chcę Ciebie straszyć, ale Mobo Asrocka bym nie brał nawet za darmo, poniżej Gigabyte czy Asusa lepiej nie schodzić niezależnie, czy planujesz Windowsa, Linuxa, BSD czy Androida, czy nawet sam od zera tworzysz system operacyjny. ;-)
Ja akurat te Mobo poznałem wiele lat temu na Windowsie.

Możesz się jeszcze pobawić ustawieniami ACPI przez CMDLINE Gruba.
Rzuć okiem na to:
http://iam.tj/prototype/enhancements/Wi ... i_osi.html

Pozdro
:craz:
Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Komputer jest jak klimatyzacja - gdy otworzysz okna, robi się bezużyteczny...
Linux User #499936
Inny OS: Gentoo Linux :)
ODPOWIEDZ

Wróć do „Instalacja, aktualizacja i konfiguracja Ubuntu”