Aktualizacja do 18.04 LTS - Samba nie akceptuje niektórych użytkowników

Wyłącznie system! Wątpliwości dotyczące aplikacji proszę umieszczać niżej, w odpowiednich forach.
Dariusz
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 17 paź 2018, 18:01
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86

Aktualizacja do 18.04 LTS - Samba nie akceptuje niektórych użytkowników

Post autor: Dariusz » 17 paź 2018, 18:30

Po aktualizacji systemu z 16.04 do 18.04 ("do-release-upgrade") wszystko wydaje się działać poprawnie. Pliki konfiguracyjne zachowałem w wersji lokalnej, gdy byłem pytany. Plik smb.conf jest identyczny jak wcześniej. Ale niektóre starsze urządzenia, które dotąd logowały się (Użytkownik / hasło) jak użytkownicy Windows (od XP do 10) dostają odmowę (typu 'błędny użytkownik / hasło'). Musi mieć to związek ze zmianą sposobu logowania do zasobów. Ale nie wiem, czy to problem Samby, czy systemu jako takiego? Szczerze mówiąc znalazłem podobne zapytania na forum ogólnym anglojęzycznym, ale ZERO odpowiedzi. A rzecz jest poważna. Po reinstalacji 16.04 wszystko działa jak powinno. Przeprowadziłem jeszcze raz aktualizację i czystą instalację w wirtualnej maszynie z takim samym skutkiem - do udostępnionego zasobu pod 18.04 niektóre urządzenia nie są w stanie się zalogować, choć do wersji 16.04 mogły.

Jakieś pomysły na obejście problemu po aktualizacji?
Awatar użytkownika
yahoob3
Wytworny Kaczor
Wytworny Kaczor
Posty: 396
Rejestracja: 01 lip 2013, 20:28
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Cinnamon
Architektura: x86_64
Lokalizacja: Lublin
Kontakt:

Re: Aktualizacja do 18.04 LTS - Samba nie akceptuje niektórych użytkowników

Post autor: yahoob3 » 19 paź 2018, 11:11

Zobacz ten wątek. Może coś rozjaśni :)
viewtopic.php?f=145&t=183440
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M;
LU#586742
Dariusz
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 17 paź 2018, 18:01
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86

Re: Aktualizacja do 18.04 LTS - Samba nie akceptuje niektórych użytkowników

Post autor: Dariusz » 27 paź 2018, 22:08

Niestety niewiele.
Rzecz w tym, że wszystko działa. Do zasobów Samby po aktualizacji można bez problemu logować się jak wcześniej z każdego Windowsa łącznie z XP.
Ale nie można nagle z urządzenia strumieniującego. Dane logowania są odrzucane.
Musiało coś się zmienić w sposobie autoryzacji. Szyfrowaniu? Kodzie znaków? Nastąpiła zmiana powodująca nierozumienie danych, które to urządzenie wysyła.

Można oczywiście uruchomić obok Samby serwer DLNA i jest ok, ale chciałbym się dowiedzieć, jaka nastąpiła zmiana, że nie daje się zalogować. Nie mogę tego znaleźć.
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 290
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Aktualizacja do 18.04 LTS - Samba nie akceptuje niektórych użytkowników

Post autor: kobrawerde » 27 paź 2018, 23:21

Niestety ale Samba od czasu do czasu przy aktualizacji funduje nam takie kwiatki ( ze dwa razy już to przeszedłem) :-) .... czasem obawiam się więc aktualizować w/w bo mając sporo dobrze działających urządzeń w sieci ... robi się nagle BIG PROBLEM :-(
trzeba szukać rozwiązania :
Nie można połączyć się z Windows do samby-4.6.7
https://askubuntu.com/questions/1031101 ... blem-18-04
https://superuser.com/questions/1125438 ... amba-share
https://www.linuxquestions.org/question ... 175626176/
Dariusz
Piegowaty Guziec
Piegowaty Guziec
Posty: 3
Rejestracja: 17 paź 2018, 18:01
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86

Re: Aktualizacja do 18.04 LTS - Samba nie akceptuje niektórych użytkowników

Post autor: Dariusz » 07 lis 2018, 11:02

Problem rozwiązany!
Dziękuję kobrawerde za pomoc.

Plik smb.conf potrzebuje teraz w moim przypadku dodatkowej linii
[global]
ntlm auth = yes

Najwyraźniej po aktualizacji samba nie zezwala na autoryzację NTLM-1, czyli starą metodą windowsową. (O problemach bezpieczeństwa można zobaczyć tu: https://blogs.technet.microsoft.com/mir ... nd-ntlmv1/)

Decyzja jest prosta: mogę po aktualizacji tę funkcjonalność przywrócić, ale trzeba się zastanowić, czy powinienem.

Jeszcze raz dzięki za pomoc!
ODPOWIEDZ

Wróć do „Instalacja, aktualizacja i konfiguracja Ubuntu”