Grafika AMD i kernel 4.19+

Karty graficzne, dźwiękowe, tv, monitory etc.
Awatar użytkownika
Arkosake
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 171
Rejestracja: 07 lut 2009, 16:38
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64
Lokalizacja: Gdańsk

Grafika AMD i kernel 4.19+

Post autor: Arkosake » 08 lis 2018, 16:05

Dzień dobry. Mam pytanie czy ktoś orientuje się co Pan Greg Kroah-Hartman wpuścił do jądra 4.19, że mi karta graficzna szaleje. Mam kartę RX460, sterowniki Mesa RVDA 18.2.4, LLVM 7.0.0, oraz wszystko co potrzeba do działania DXVK. Niestety przy kernelu 4.19 za żadne skarby nie działa akceleracja sprzętowa w programach takich jak VLC i SMPlayer. Testowałem gry: Tibia - działa tak jak powinna, no ale tą grę można odpalić na ziemniaku więc przerzuciłem się na World of Warcraft, Heros of the storm i te z wykorzystaniem DXVK również działają jak powinny. Ale za żadne skarby nie da się odtworzyć filmu niezależnie od rozdzielczości. Jedyny program jaki działa to MVP ale on po prostu zarzyna procesor, nie korzysta z mocy karty graficznej. Dodatkowo komputer uruchamia się zdecydowanie dłużej (zamiast 5-6 sekund od gruba, jest kilka minut), a w logach powodem tej wydłużającej się agonii jest:

Kod: Zaznacz cały

4.682484] amdgpu: [powerplay] 
 failed to send message 148 ret is 0
błędów takich jest oczywiście cała masa, treść podobna zmienia się tylko pierwsza liczba zamiast 148 może być 155, 261, 260, 281 itd.
Dodatkowo już wychodząc z tej abstrakcji, nie da się normalnie wyłączyć komputera, gaśnie ekran, wyłączają się dyski, ale cały czas coś pracuje nie zamyka się do końca, wymagana ręczna stymulacja przycisku power. Czy ktoś wie o co może chodzić i czy można to jakoś naprawić, zależy mi aby trzymać się gałęzi LTS z kernelami, a 4.14 już trochę leciwy jest :-).
Dodatkowo jak widziana jest karta przy 4.19:

Kod: Zaznacz cały

*-display                 
       description: VGA compatible controller
       product: Baffin [Radeon RX 460/560D / Pro 450/455/460/560]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: cf
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: irq:26 memory:e0000000-efffffff memory:dfe00000-dfffffff ioport:c000(size=256) memory:fe980000-fe9bffff memory:c0000-dffff
To mój pierwszy problem z kartami od AMD na Linuxach, jestem przyzwyczajony, że w przypadku Nvidii bez melisy nie wolno aktualizować systemu, ale tutaj to totalna nowość :-).
Manjaro KDE na : Asus P5G41T-M LX, Intel Core 2 Quad Q9450 2,66 GHz podbity do 3.2 GHz, Radeon RX460 2GB, 6 GB ram DDR3 1333 MHz, 256GB SSD Crucial MX100 + 8TB HDD WD & Hitachi.
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 291
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Grafika AMD i kernel 4.19+

Post autor: kobrawerde » 08 lis 2018, 18:25

To mój pierwszy problem z kartami od AMD na Linuxach, jestem przyzwyczajony, że w przypadku Nvidii bez melisy nie wolno aktualizować systemu, ale tutaj to totalna nowość
No to witamy w klubie :razz: ..... ja od kernela 4.14 nie mam internetu po wybudzeniu z opcji suspend ( błąd dotyczy drivera sky2 ) ...już jest jajko 4.19.1 ... i lipa :razz: o problemach z kartami nvidia już wspomniałeś więc nie jest wesoło. :mrgreen:
Awatar użytkownika
Arkosake
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 171
Rejestracja: 07 lut 2009, 16:38
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64
Lokalizacja: Gdańsk

Re: Grafika AMD i kernel 4.19+

Post autor: Arkosake » 08 lis 2018, 20:09

kobrawerde pisze:
08 lis 2018, 18:25
No to witamy w klubie :razz: ..... ja od kernela 4.14 nie mam internetu po wybudzeniu z opcji suspend ( błąd dotyczy drivera sky2 ) ...już jest jajko 4.19.1 ... i lipa :razz: o problemach z kartami nvidia już wspomniałeś więc nie jest wesoło. :mrgreen:
klub użytkowników, którym coś nie działa jest mało satysfakcjonującym miejscem :razz:. Nie mniej ściągnąłem sobie na szybko Manjaro 18.0 z kernelem 4.19 w podstawie i wnioski mam takie, że problem dotyczy tylko układów Polaris, na legendarnej X1600 oraz HD6970 problemów nie ma. Gdzieś czytałem, że w 4.19 jakiś bust zegarów dla polarisów był ale nikt nie pisał o niedziałaniu, po za tym owa łatka miała być już w 4.18.10, a ten działa bez problemów zresztą cała linia 4.18 działa (no z wyjątkami 4.18.7 gdzie po 2h komputer nie reagował na żadne polecenie :-)).
Manjaro KDE na : Asus P5G41T-M LX, Intel Core 2 Quad Q9450 2,66 GHz podbity do 3.2 GHz, Radeon RX460 2GB, 6 GB ram DDR3 1333 MHz, 256GB SSD Crucial MX100 + 8TB HDD WD & Hitachi.
ODPOWIEDZ

Wróć do „Multimedia - karty graficzne, dźwiękowe, telewizyjne, drukarki, skanery”