Mysz nie działa [solved]

Wyłącznie system! Wątpliwości dotyczące aplikacji proszę umieszczać niżej, w odpowiednich forach.
mlody969
Sędziwy Jeż
Sędziwy Jeż
Posty: 66
Rejestracja: 16 maja 2010, 11:14
Płeć: Mężczyzna
Wersja Ubuntu: 10.04
Środowisko graficzne: GNOME
Architektura: x86_64

Mysz nie działa [solved]

Post autor: mlody969 » 09 gru 2018, 22:34

Witam

Po paru latach bez linuxa postanowiłem na nowo spróbować. Zainstalowałem ubuntu 18.04 LTS.
I niestety już na etapie live cd nie działała mi myszka (w zasadzie to dwie - logitech i modecom). Myślałem, że jak się zainstaluje w pełni, pościąga wszystkie sterowniki to ruszy, ale tak się nie stało. Dziwne to ponieważ g-parted sprzed paru lat z tymi myszkami nie miał żadnego problemu.

Robiłem to co na tym filmie ale nie zadziałało:
https://www.youtube.com/watch?v=IuxhEbzPMVk

Jakieś porady?
Ostatnio zmieniony 11 gru 2018, 12:26 przez mlody969, łącznie zmieniany 1 raz.
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 407
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Mysz nie działa

Post autor: kobrawerde » 09 gru 2018, 23:16

Pewnie wszystkim by się przydało info jakie to myszki model / przewodowa /usb
info z podpiętych do portu usb:

Kod: Zaznacz cały

lsusb
Czy sprawdzałeś na wszystkich portach usb w kompie usb2 / usb3
mlody969
Sędziwy Jeż
Sędziwy Jeż
Posty: 66
Rejestracja: 16 maja 2010, 11:14
Płeć: Mężczyzna
Wersja Ubuntu: 10.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Mysz nie działa

Post autor: mlody969 » 09 gru 2018, 23:35

Myszki oczywiście bezprzewodowe,, optyczne, odbiornik w USB. Modelu logitecha już nie odgadnę bo się wytarł, modecom to MC-WM101. Ale dziwne, bo dzisiaj partycję pod ubuntu robiłem w G-parted chyba sprzed 5-ciu lat i nie było z myszką żadnego problemu.
Testowałem w innym porcie i na przednim panelu - nic nie rusza. Kursor na pulpicie jest tylko że martwy. W jednej z myszy zauważyłem, że po kilku sekundach wyłącza się dioda, tak jakby w ogóle nie działał odbiornik. Teraz piszę z windowsa i z myszami nie ma żadnego problemu. Może coś nie tak ze sterownikami pod płytę główną? Mam Gigabyte 970A-D3

EDIT:
Właśnie sprawdziłem tą komendę na ubuntu. Przy wszystkich pozycjach opócz jednej wyskoczyło Linux Foundation: hub root czy jakoś tak (nie mogę stamtąd tego skopiować). Ta jedna pozycja to moja zewnętrzna karta dźwiękowa Line 6, która jest podpięta do USB. I ona działa. Natomiast inne urządzenia jak np pendrive nie działają. Najwyraźniej coś ze sterownikami do płyty głównej.

Chciałem przekopiować screena, ale widzę że do pozostałych dysków też nie mam dostępu. Cóż, Windows 10 i Ubuntu na jednej maszynie to chyba kiepskie małżeństwo...

A to się dzieje jak próbuję uruchomić wersję live z pendrive
https://images91.fotosik.pl/88/002a10da7b2091b3.jpg
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 407
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Mysz nie działa

Post autor: kobrawerde » 10 gru 2018, 18:57

Tu coś jest dla tej płyty i portów USB2 ....
https://linhaiting.wordpress.com/2015/0 ... el-ubuntu/
Jeszcze można spróbować czy tej opcji nie ma w BIOS ...( IOMMU - na disabled ? )
https://ubuntuforums.org/showthread.php?t=2111223
mlody969
Sędziwy Jeż
Sędziwy Jeż
Posty: 66
Rejestracja: 16 maja 2010, 11:14
Płeć: Mężczyzna
Wersja Ubuntu: 10.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Mysz nie działa

Post autor: mlody969 » 10 gru 2018, 20:12

Dzięki. Na razie robię eksperyment. Zaorałem tamto ubuntu i zainstalowałem (z pendrive) polską wersję 14.04 - tutaj mysz działała bez zarzutu już od trybu live. Na zainstalowanym systemie też działa. Teraz aktualizuję i zobaczymy co się stanie na nowej wersji.
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 407
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Mysz nie działa

Post autor: kobrawerde » 10 gru 2018, 21:18

To jak sobie zainstalowałes tą wersję 14.04 to zerknij na jakim jajku leci / jaki kernel :-)

Kod: Zaznacz cały

uname -a
Może na wersji 18.04 wystarczy downgrade kernela i będzie git :razz: a najlepiej wypróbuj Debiana live ... stabilna wersja to chyba 9.6 stretch
mlody969
Sędziwy Jeż
Sędziwy Jeż
Posty: 66
Rejestracja: 16 maja 2010, 11:14
Płeć: Mężczyzna
Wersja Ubuntu: 10.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Mysz nie działa

Post autor: mlody969 » 10 gru 2018, 21:25

Już chyba wiem gdzie problem leży i dowiedziałem się o tym przez pomyłkę, ale jeszcze wykonam jeden test.

Ok, już chyba wiem. Otóż przed instalacją tego 14.04 pomyliłem się i ściągnąłem wersję 32 bitową. Zorientowałem się dopiero po czasie i wszystko działało. Pobrałem więc wersję 64 bitową, też 14.04 i ta już z pena ruszyć nie chciała.
A jest to o tyle ciekawe, że pena widzi, zaczyna się z niego uruchamiać, jest już nawet logo ubuntu i te kropki, aż nagle wywala komunikat, że nie widzi nośnika z systemem plików do wczytania:
https://images90.fotosik.pl/88/00c83b5063fdb3c1gen.jpg

Więc wygląda to tak, że wersja 64 bit po prostu gubi moje usb

Edit:
Na debianie to samo. Odpalam z pena, uruchamia się instalator i mysz już nie reaguje. Przechodzę z klawiatury dalej instalację a ten mi krzyczy że nie widzi cd romu - pewnie dlatego że już zgubił usb z pendrive. W sumie niby człowiek wiedział, że ubuntu stoi na debianie, a jednak się łudził...
mlody969
Sędziwy Jeż
Sędziwy Jeż
Posty: 66
Rejestracja: 16 maja 2010, 11:14
Płeć: Mężczyzna
Wersja Ubuntu: 10.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Mysz nie działa

Post autor: mlody969 » 11 gru 2018, 01:17

Sukces. Gra i trąbi zespół Kombi. Znalazłem tą opcję w biosie o której pisałeś IOMMU tyle że ona domyślnie jest wyłączona i trzeba właśnie ją włączyć. Od tego czasu usb działa.

Tylko jest jeden feler. Na jednym dysku fizycznym jest windows, na drugim linux (w sumie mam 4 dyski, ale chodzi o te dwa). Instalując linuxa zaznaczyłem ten drugi dysk dla gruba (specjalnie) aby domyslnie włączał się windows który jest moim podstawowym systemem. Tak robiłem wcześniej i to działało, a gdy chciałem wejść na linuxa po prostu wchodziłem w bootmenu i bootowałem z tego drugiego dysku. Tyle, że teraz z automatu włącza się grub a nie bootloader windowsa. Nie byłoby w tym nic strasznego, tyle że sam grub włącza się ze 2 minuty
Awatar użytkownika
kszyhus
Zakręcona Traszka
Zakręcona Traszka
Posty: 641
Rejestracja: 19 lis 2010, 08:34
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64
Lokalizacja: okolice Ostrowa Wielkopolskiego

Re: Mysz nie działa

Post autor: kszyhus » 11 gru 2018, 04:15

Sprawdź jaki ustawienia czasowe (czekanie na wybór systemu) masz w Grub-ie:

Kod: Zaznacz cały

Sudo gedit /etc/defualt/grub
pozycja:
GRUB_TIMEOUT=3
gdzie 3 to sekundy do wyboru systemu
Nie trzeba mówić tsza, lecz tsza mówić trzeba.
PC: Gigabyte H270-HD3 * intel i5 7600 * 16GB RAM * SSD M.2 Nvme 250 GB * SSD 1TB * HDD 2 TB
Awatar użytkownika
D35CART35
Piegowaty Guziec
Piegowaty Guziec
Posty: 24
Rejestracja: 01 mar 2018, 13:30
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne

Re: Mysz nie działa

Post autor: D35CART35 » 11 gru 2018, 09:48

Na czas instalacji Ubuntu odłącz dysk z Windows, i pamiętaj w bios ustawić go jako pierwszy.
Grub podczas instalacji wyszukuje innych systemów.
mlody969
Sędziwy Jeż
Sędziwy Jeż
Posty: 66
Rejestracja: 16 maja 2010, 11:14
Płeć: Mężczyzna
Wersja Ubuntu: 10.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Mysz nie działa

Post autor: mlody969 » 11 gru 2018, 11:23

Chodziło mi o to, że sam grub się długo włącza. Logo gigabyte a potem przez 2 min (no dobra, może nie aż 2, ale ponad minutę) czarny ekran, dopiero potem pojawiał się wybór systemu. Ale dzisiaj rano już włączył się normalnie, być może wczoraj jeszcze się konfigurował, ściągnąłem aktualizacje, może w nich był też grub.

No ale już działa. Zaskoczony jestem bo bez problemu działa nawet mój interfejs audio, a wcześniej na ubuntu był z nim problemy. Pobawię się tak jak jest, a potem będę chciał sprawdzić aktualne kubuntu, bo kiedyś miałem, ale bardzo się zawiodłem. A potem może wezmę na próbę linux mint, bo nigdy nie używałem.

No a docelowo będę chciał postawić oba systemy a jednym dysku, bo teraz windows chodzi na SSD, a linux na starym magnetycznym WD green (najwolniejszy), co jest chyba trochę nieuczciwe. No ale do tego celu będę chyba musiał kupić nowy, większy SSD

Tak czy inaczej wiem już o co chodzi, dzięki za pomoc.
D35CART35 pisze:
11 gru 2018, 09:48
Na czas instalacji Ubuntu odłącz dysk z Windows, i pamiętaj w bios ustawić go jako pierwszy.
Grub podczas instalacji wyszukuje innych systemów.
Wiem, że wyszukuje, tyle że ja nie zaznaczałem instalacji obok innego systemu tylko "inne rozwiązanie" i ręcznie wskazywałem inne urządzenie
ODPOWIEDZ

Wróć do „Instalacja, aktualizacja i konfiguracja Ubuntu”