Blokada instalacji Ubuntu w momencie instalowania grub2

Wyłącznie system! Wątpliwości dotyczące aplikacji proszę umieszczać niżej, w odpowiednich forach.
mikcie
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sty 2019, 08:38
Płeć: Mężczyzna
Wersja Ubuntu: 18.04

Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: mikcie » 11 sty 2019, 08:51

Witam,

Tematu nie znalazłem na forum tym, a także żadnym innym.

Laptop HP, Intel Celeron CPU N3550 @ 1.10GHz, 4GB RAM, BIOS InsydeH20

Laptop w zasadzie nowy, był na nim preinstalowany Win10. Próbuję na nim zainstalować Linuxa (Ubuntu rzecz jasna, Minta próbowałem dla sprawdzenia czy da się zainstalować - efekt ten sam), lecz instalacja zatrzymuje się na instalacji grub2. Dalej ani drgnie. Spędziłem nad tym już dużo godzin, wypróbowałem całą masę porad z internetu, które zresztą się dokładnie do tego problemu nie odnoszą i nic. Pendrive na pewno dobrze wypalony bo na drugim komputerze ładnie się zainstalowało. Dodam jeszcze, że moim celem jest instalacja samego Ubuntu, bez Windowsa w jednym domku. Jeśli chodzi o secure boot, legacy support to już przerobiłem wszystkie opcje jakie mam dostępne w biosie.

Co robić?
Awatar użytkownika
Tomfoc
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1892
Rejestracja: 30 lis 2011, 21:14
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: Tomfoc » 11 sty 2019, 18:10

Napisz czy instalacja zatrzymuje się i jest wyświetlany jakiś komunikat, czy takowego brak. Masz na dysku partycję efi? Czy podczas instalowania wskazałeś ją jako partycję EFI i nadałeś punkt montowania jako /boot/efi?
Laptop: Lenovo Ideapad 300, CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz × 4, GPU: Intel® HD Graphics 520 (Skylake GT2), RAM: 8 GB, HDD: 500 GB
mikcie
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sty 2019, 08:38
Płeć: Mężczyzna
Wersja Ubuntu: 18.04

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: mikcie » 11 sty 2019, 21:47

Tomfoc pisze:
11 sty 2019, 18:10
Napisz czy instalacja zatrzymuje się i jest wyświetlany jakiś komunikat, czy takowego brak. Masz na dysku partycję efi? Czy podczas instalowania wskazałeś ją jako partycję EFI i nadałeś punkt montowania jako /boot/efi?
Jako komunikat w takim sensie, że nad paskiem stanu czy tam pod paskiem stanu instalacji są komunikaty co aktualnie jest instalowane. I zatrzymuje się na punkcie "instalowanie grub2".

Tego drugiego pewnie nie, trzeciego na pewno nie - podczas wyboru sposobu instalacji wybrałem wykasowanie wszystkich danych i zainstalowanie linuxa.
Awatar użytkownika
Tomfoc
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1892
Rejestracja: 30 lis 2011, 21:14
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: Tomfoc » 12 sty 2019, 00:11

Kilka dni temu instalowałem Ubuntu w laptopie, którego dysk nie posiadał żadnej partycji, wcześniej był tam Windows 10. W BIOS wyłączyłem opcję Secure Boot i Fast Boot. Na dysku utworzyłem programem gparted (jest dostępny po odpaleniu kompa z nośnika instalacyjnego) partycję o rozmiarze 250 MB, założyłem na niej system plikowy Fat32 i nadałem jej dwie flagi tj. boot oraz esp. Następnie utworzyłem partycję swap o rozmiarze nieco ponad 4 GB (RAM-u laptop ma 4 GB). Kolejna to partycja o rozmiarze 15 GB z systemem plikowym ext4 i ostatnia na pozostałej powierzchni dysku i również ext4. Podczas instalacji systemu nie korzystałem z automatycznego podziału dysku, bo inaczej nie miało by sensu to, co zrobiłem ręcznie. Tę małą partycję wskazałem do montowania w punkcie /boot/efi, tę swap jako swap, tę o rozmiarze 15 GB jako / i tę dużą ostatnią jako /home. Instalacja przebiegła bez problemu. Zakładam, że na dysku nie masz jeszcze żadnych danych, więc możesz spróbować.
Laptop: Lenovo Ideapad 300, CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz × 4, GPU: Intel® HD Graphics 520 (Skylake GT2), RAM: 8 GB, HDD: 500 GB
mikcie
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sty 2019, 08:38
Płeć: Mężczyzna
Wersja Ubuntu: 18.04

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: mikcie » 13 sty 2019, 12:10

Tomfoc pisze:
12 sty 2019, 00:11
Kilka dni temu instalowałem Ubuntu w laptopie, którego dysk nie posiadał żadnej partycji, wcześniej był tam Windows 10. W BIOS wyłączyłem opcję Secure Boot i Fast Boot. Na dysku utworzyłem programem gparted (jest dostępny po odpaleniu kompa z nośnika instalacyjnego) partycję o rozmiarze 250 MB, założyłem na niej system plikowy Fat32 i nadałem jej dwie flagi tj. boot oraz esp. Następnie utworzyłem partycję swap o rozmiarze nieco ponad 4 GB (RAM-u laptop ma 4 GB). Kolejna to partycja o rozmiarze 15 GB z systemem plikowym ext4 i ostatnia na pozostałej powierzchni dysku i również ext4. Podczas instalacji systemu nie korzystałem z automatycznego podziału dysku, bo inaczej nie miało by sensu to, co zrobiłem ręcznie. Tę małą partycję wskazałem do montowania w punkcie /boot/efi, tę swap jako swap, tę o rozmiarze 15 GB jako / i tę dużą ostatnią jako /home. Instalacja przebiegła bez problemu. Zakładam, że na dysku nie masz jeszcze żadnych danych, więc możesz spróbować.
Zrobiłem tak jak zaproponowałeś - podzieliłem, ponazywałem itd i ku mojemu wielkiemu smutkowi instalacja znów zawiesiła się na komunikacie "Instalowanie pakietu 'grub2'...".

Czy ktoś ma jeszcze jakiś pomysł?
rrico
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 147
Rejestracja: 22 kwie 2017, 11:32
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: MATE
Architektura: x86_64
Lokalizacja: óć-pl

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: rrico » 13 sty 2019, 13:03

Zobacz sumy kontrolne pliku, może pobierz jeszcze raz - nie wiem czy pomoże ale może to to.
----------------------------------------------------
Ubuntu MATE 16.04.2 LTS x64 (tymczasowo offline) | Składak
Limux Mint 18.2 Mate/Cinnamon x64 (bieżący) | Toshiba Satellite A350
Awatar użytkownika
kobrawerde
Zakręcona Traszka
Zakręcona Traszka
Posty: 504
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: kobrawerde » 13 sty 2019, 13:51

mikcie
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sty 2019, 08:38
Płeć: Mężczyzna
Wersja Ubuntu: 18.04

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: mikcie » 17 sty 2019, 17:40

kobrawerde pisze:
13 sty 2019, 13:51
Może te tematy będą pomocne ...warto poczytać i spróbować :
https://ubuntuforums.org/showthread.php?t=2380155
https://askubuntu.com/questions/392254/ ... age/392273
To jest boot info z poleconych linków.

http://paste.ubuntu.com/p/HvfvVzMkz6/

Czy teraz ktoś może podpowiedzieć?
smogs
Piegowaty Guziec
Piegowaty Guziec
Posty: 9
Rejestracja: 11 lis 2018, 03:43
Płeć: Mężczyzna
Wersja Ubuntu: 16.04

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: smogs » 19 sty 2019, 08:40

text z boot info
"The settings chosen by the user will not act on the boot." nie zadziwiała ci bo namieszałes "grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your device.map."
najprościej to przywróć BIOS do ustawień fabrycznych, wyłącz opcję Secure Boot i Fast Boot i zainstaluj system automatycznie w tym wypadku wymaże ci caly dysk
ps. na dysku najlepiej ustawić 3partycjie podstawowe i 1 rozszerzoną
mikcie
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sty 2019, 08:38
Płeć: Mężczyzna
Wersja Ubuntu: 18.04

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: mikcie » 23 sty 2019, 09:29

smogs pisze:
19 sty 2019, 08:40
text z boot info
"The settings chosen by the user will not act on the boot." nie zadziwiała ci bo namieszałes "grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your device.map."
najprościej to przywróć BIOS do ustawień fabrycznych, wyłącz opcję Secure Boot i Fast Boot i zainstaluj system automatycznie w tym wypadku wymaże ci caly dysk
ps. na dysku najlepiej ustawić 3partycjie podstawowe i 1 rozszerzoną
Ten sam efekt.
Awatar użytkownika
kobrawerde
Zakręcona Traszka
Zakręcona Traszka
Posty: 504
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: kobrawerde » 23 sty 2019, 17:22

Jaki to dokładnie model laptopa HP ? ... swoją drogą już gdzieś ktoś miał podobny problem ( niestety nierozwiązany ) i też chyba był to model HP :cry:
plus info :

Kod: Zaznacz cały

inxi -Fxz
mikcie
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sty 2019, 08:38
Płeć: Mężczyzna
Wersja Ubuntu: 18.04

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: mikcie » 24 sty 2019, 07:59

kobrawerde pisze:
23 sty 2019, 17:22
Jaki to dokładnie model laptopa HP ? ... swoją drogą już gdzieś ktoś miał podobny problem ( niestety nierozwiązany ) i też chyba był to model HP :cry:
plus info :

Kod: Zaznacz cały

inxi -Fxz
HP 250 G6

a z tym kodem to co?
Awatar użytkownika
Tomfoc
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1892
Rejestracja: 30 lis 2011, 21:14
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: Tomfoc » 24 sty 2019, 10:00

Ten "kod" wpisz w terminalu i daj na forum wynik. Będą to szczegółowe dane o sprzęcie i systemie.
Laptop: Lenovo Ideapad 300, CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz × 4, GPU: Intel® HD Graphics 520 (Skylake GT2), RAM: 8 GB, HDD: 500 GB
Awatar użytkownika
kobrawerde
Zakręcona Traszka
Zakręcona Traszka
Posty: 504
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: kobrawerde » 24 sty 2019, 16:03

sory za ten kod ...w końcu nie możesz zainstalować na nim systemu więc z informacji lipa :-)
Znalazłem jakiś temat dotyczący twojego lapka HP G6 250 który potwierdza iż to przypadłość firmy HP.
cytat:
HP often requires a work around as it violated UEFI standard and uses description as part of boot. And only valid description is "Windows Boot Manager". tłumaczenie google-translator :
HP często wymaga obejścia, ponieważ narusza standard UEFI i wykorzystuje opis jako część rozruchu. I tylko prawidłowy opis to "Windows Boot Manager".
https://ubuntuforums.org/showthread.php ... st13750069
https://ubuntuforums.org/showthread.php?t=2385726
Ciekawe czemu opisują opcje wyłączenia Secure Boot w laptopach HP .... może coś jest nie tak ?
http://linuxbsdos.com/2016/11/05/disabl ... g5-laptop/
HP to jakiś koszmar ...może to ktoś "rozkmini" z dobrą znajomością angielskiego :razz:
https://h30434.www3.hp.com/t5/Desktop-W ... -p/5949710
mikcie
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sty 2019, 08:38
Płeć: Mężczyzna
Wersja Ubuntu: 18.04

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: mikcie » 27 sty 2019, 09:35

Czy są jeszcze jakieś pomysły?
smogs
Piegowaty Guziec
Piegowaty Guziec
Posty: 9
Rejestracja: 11 lis 2018, 03:43
Płeć: Mężczyzna
Wersja Ubuntu: 16.04

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: smogs » 27 sty 2019, 11:31

jeszcze raz próbuj z biosem secure boot off (wyłącz) i legecy boot on (włącz)
nie wiem czy to moze mieć coś wspólnego ale moze Windows zablokował partycje bo go nie wyłączyłeś tylko zahibernowałeś, zeruj dysk za pomocą liveUSB Gparted/utwórz tablice partycji/ nowe partycje albo podmień na inny dysk i powinien ruszyć
mikcie
Piegowaty Guziec
Piegowaty Guziec
Posty: 8
Rejestracja: 11 sty 2019, 08:38
Płeć: Mężczyzna
Wersja Ubuntu: 18.04

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: mikcie » 27 sty 2019, 17:34

smogs pisze:
27 sty 2019, 11:31
jeszcze raz próbuj z biosem secure boot off (wyłącz) i legecy boot on (włącz)
nie wiem czy to moze mieć coś wspólnego ale moze Windows zablokował partycje bo go nie wyłączyłeś tylko zahibernowałeś, zeruj dysk za pomocą liveUSB Gparted/utwórz tablice partycji/ nowe partycje albo podmień na inny dysk i powinien ruszyć
Wyzerowałem dysk, utworzyłem ładne partycje, dodałem flagi itp itd z uśmiechem, że to na pewno pomoże. I co? Zacięło się w tym samym miejscu. Mam dość.

Czy tam jest jakaś blokada od strony HP czy o co tu chodzi?
Awatar użytkownika
kobrawerde
Zakręcona Traszka
Zakręcona Traszka
Posty: 504
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: kobrawerde » 27 sty 2019, 19:39

Czy tam jest jakaś blokada od strony HP czy o co tu chodzi?
Blokada ...albo jakiś trick właśnie przy instalacji UEFI ze strony firmy HP. Może coś w BIOS-e ( aktualizacja ? ) bo jakoś nikt nie ma aż takich problemów przy instalacji Linux-a jak użytkownicy HP. Może spytać na oficjalnym (EN) forum ubuntu ?
Tu ktoś sprzedaje ten model z możliwością instalacji Linux-a :-) ........więc jest to możliwe
https://www.linuxnow.com.au/nshp2FG10PA.html

Tu potwierdzenie
https://ubuntuforums.org/showthread.php ... st13742853
W skrócie wynika iż firma HP nie jest przyjazna dla instalacji innych systemów jak Windows a nawet podwójnego instalowania systemów. Pisze iż jest to chyba możliwe przy ręcznej modyfikacji / podmiany pewnych plików ...osobiście nigdy się z tym nie spotkałem więc nie pomogę. Może bardziej doświadczeni coś podpowiedzą :razz:
Copy shimx64.efi to /EFI/Boot/bootx64.efi
copied /EFI/ubuntu/grubx64.efi to /EFI/Boot/bootx64.efi
https://ubuntuforums.org/showthread.php?t=2131886
knott
Piegowaty Guziec
Piegowaty Guziec
Posty: 1
Rejestracja: 24 sty 2019, 12:06
Wersja Ubuntu: 18.10
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: knott » 01 lut 2019, 20:39

Kilka miesięcy temu instalowałem 18.10 na HP EB 840G1,
też od razu nie było kolorowo,
ale nie pamiętam dokładnie co pomogło.
Na pewno majstrowałem w biosie * secure boot/legacy boot
format HD z live USB Gparted.
Jestem laik więc partycje z automatu podczas instalacji.
Kilka godzin na to straciłem ale efekt

knott@knott-HP-EliteBook-840-G1:~$ screenfetch
./+o+- knott@knott-HP-EliteBook-840-G1
yyyyy- -yyyyyy+ OS: Ubuntu 18.10 cosmic
://+//////-yyyyyyo Kernel: x86_64 Linux 4.18.0-14-generic
.++ .:/++++++/-.+sss/` Uptime: 4h 34m
.:++o: /++++++++/:--:/- Packages: 1709
o:+o+:++.`..```.-/oo+++++/ Shell: bash
.:+o:+o/. `+sssoo+/ Resolution: 3286x1080
.++/+:+oo+o:` /sssooo. DE: GNOME
/+++//+:`oo+o /::--:. WM: GNOME Shell
\+/+o+++`o++o ++////. WM Theme: Adwaita
.++.o+++oo+:` /dddhhh. GTK Theme: Yaru-dark [GTK2/3]
.+.o+oo:. `oddhhhh+ Icon Theme: Yaru
\+.++o+o``-````.:ohdhhhhh+ Font: Ubuntu 11
`:o+++ `ohhhhhhhhyo++os: CPU: Intel Core i5-4300U @ 4x 2.9GHz [43.0°C]
.o:`.syhhhhhhh/.oo++o` GPU: intel
/osyyyyyyo++ooo+++/ RAM: 1369MiB / 7873MiB
````` +oo+++o\:
`oo++.
knott@knott-HP-EliteBook-840-G1:~$

Wiem, że post mało przydatny ale optymistyczny.
Powodzenia
HP EB 840 G1
Awatar użytkownika
kobrawerde
Zakręcona Traszka
Zakręcona Traszka
Posty: 504
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: MATE
Architektura: x86_64

Re: Blokada instalacji Ubuntu w momencie instalowania grub2

Post autor: kobrawerde » 03 mar 2019, 11:14

No tak przyszło mi zmierzyć się z podobnym problemem czyli laptop HP 250 G5 ( wymiana dysku HDD na SSD + dodatkowa pamięć 4GB) to chyba młodszy brat HP 250 G6 :razz:
Powiem iż lapek HP to prawdziwy koszmar a zwłaszcza ichni BIOS który ma jakieś dziwne zabezpieczenia i ma wiele wad np. dotyczących ACPI .Jednak ponieważ to nie mój laptop tylko kolegi obawiałem się dokonywać upgradu BIOS-u a i tak można wyczytać w necie iż w zasadzie nic to nie daje bo firma HP "olewa" linux-a :mrgreen:
Podam dane tego lapka : inxi -FxZ

Kod: Zaznacz cały

System:
  Host: dom-HP-255-G5-Notebook-PC Kernel: 4.15.0-45-generic x86_64 bits: 64 
  compiler: gcc v: 7.3.0 Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: HP product: HP 255 G5 Notebook PC 
  v: Type1ProductConfigId serial: <root required> 
  Mobo: HP model: 82F6 v: 40.38 serial: <root required> UEFI: Insyde v: F.21 
  date: 10/27/2016 
Battery:
  ID-1: BAT1 charge: 27.7 Wh condition: 27.7/31.1 Wh (89%) 
  model: Hewlett-Packard PABAS0241231 status: Full 
CPU:
  Topology: Quad Core model: AMD A6-7310 APU with AMD Radeon R4 Graphics 
  bits: 64 type: MCP arch: Puma rev: 1 L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 15969 
  Speed: 1154 MHz min/max: 1000/2000 MHz Core speeds (MHz): 1: 1196 2: 1191 
  3: 1159 4: 1191 
Graphics:
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Hewlett-Packard 
  driver: radeon v: kernel bus ID: 00:01.0 
  Display: x11 server: X.Org 1.19.6 driver: ati,radeon 
  unloaded: amdgpu,fbdev,modesetting,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD MULLINS (DRM 2.50.0 4.15.0-45-generic LLVM 7.0.0) 
  v: 4.5 Mesa 18.2.2 direct render: Yes 
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:01.1 
  Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 
  Sound Server: ALSA v: k4.15.0-45-generic 
Network:
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: 3100 
  bus ID: 02:00.0 
  IF: wlo1 state: down mac: 98:54:1b:bf:f2:e3 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: 2000 
  bus ID: 03:00.0 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 40:b0:34:9b:1b:ce 
Drives:
  Local Storage: total: 223.57 GiB used: 9.80 GiB (4.4%) 
  ID-1: /dev/sda model: IR-SSDPR-S25A-240 size: 223.57 GiB 
Partition:
  ID-1: / size: 105.23 GiB used: 9.77 GiB (9.3%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 52.6 C mobo: 20.0 C gpu: radeon temp: 53 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 195 Uptime: 17m Memory: 3.33 GiB used: 955.3 MiB (28.0%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 
W skrócie udało mi się zainstalować Linuxa (Mint-Mate) obok Windy 10 Home ( bo chyba firma HP ma nawet serial do tego systemu zaszyty w BIOS-ie ) koszmar :-)
Moje kolejne kroki :
1.Wymiana dysku na SSD nie partycjonowałem w/w
2. Wejście do BIOS F10 wyłączenie secure boot / TPD itp. oraz włączenie opcji legacy żeby mieć możność boot-owania systemu z USB
3. Instalacja Windy 10 Home z USB wybierając opcję boot-owania F9 ( choć jeśli jest jeden system to już sam boot-uje z USB bez F9 ) winda sama dzieli dysk itd w tym przypadku GPT. W zainstalowanym systemie w opcjach administracyjnych wydzielenie pomniejszenie partycji o drugą na naszego Linux-a u mnie E / sda5
4.Wyłączenie w BIOS opcji legacy ! i instalacja Linux-a np Mint-mate 19.1 w trybie uefi ( oczywiście efekt końcowy brak grub-a i wyboru Linuxa )
5.Włączenie w BIOS-e opcji legacy i z boo-towanie z USB ( F9) jakiejś dystrybucji linuxa live np. naszego Minta i dokonanie pewnych zmian w istniejącym systemie Linux na dysku sda5 (ext4)
Jak wyczytałem w necie trzeba podmienić skopiować pewne pliki jako administrator/root
https://askubuntu.com/questions/244261/ ... w-efi-file
czyli plik:

Kod: Zaznacz cały

/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
przenieść do innego folderu np

Kod: Zaznacz cały

/boot/efi/EFI/Microsoft/bootmgfw.efi
a plik grubx64.efi :

Kod: Zaznacz cały

/boot/efi/EFI/ubuntu/grubx64.efi
skopiować do ścieżki:

Kod: Zaznacz cały

/boot/efi/EFI/Microsoft/Boot
restart / reboot systemu
Po tym triku mam w końcu ekran GRUB-a z wyborem Linux-a i Windy :-) ...ale niestety wpis dotyczący Linux-a działa ale Winda NIE ! wchodząc w Grub z opcją "e" do wpisu Windy zrozumiałem że wpis uruchamia starą ścieżkę czyli : /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi .... wykasowałem Boot czyli : /boot/efi/EFI/Microsoft/bootmgfw.efi i uruchomiłem : Ctrl + x system Windows wystartował OK. Dokonałem więc zmiany w pliku grub.cfg / opcja Windows na :
chainloader /EFI/Microsoft/bootmgfw.efi teraz wszystko działało OK w menu GRUB. Ale niestety po aktualizacji systemu linux i update kernela co wiąże się z update-grub znowu Winda się nie uruchamia bo ma dawny wpis : /EFI/Microsoft/Boot/ :razz:
Skopiowałem więc ponownie plik : bootmgfw.efi do starej ścieżki :

Kod: Zaznacz cały

/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
i o dziwo wszystko działa OK czyli chyba nie trzeba tego przenosić ?
Co więcej można spokojnie dokonać opcji w terminalu : update-grub i system Windows jest wykrywany :-)
Pozostała jeszcze duża liczba błędów/ error podczas startu systemu Linux np . ACPI i w moim przypadku zintegrowane karty grafiki AMD Mullins [Radeon R4/R5 Graphics] vendor: Hewlett-Packard po licznych "bojach" zmianach w parametrach kernela / grub podczas uruchamiana systemu które skutkowały nawet zawieszeniami z opcją error -16 w końcu udało mi się wybrać poprawną konfigurację dotyczącą tego lapka HP 255 g5 "prawie" nie zawierającego błędów w dmesg :pt36:
https://pastebin.com/t249USju
to mój wybór:

Kod: Zaznacz cały

GRUB_CMDLINE_LINUX_DEFAULT="irqpool nouveau.blacklist=1 apm=power_off libata.noacpi=1 acpi_osi=Linux acpi_backlight=vendor"
Co nie zmienia faktu że mimo wszystko laptop moim zdaniem mając dysk SSD uruchamia się nieznacznie szybciej od HDD ale to może być wina BIOS-u HP :cry: ...jeszcze pozostaje dodać dodkowe 4GB pamięci do 8GB i to by było na tyle bo do BIOS-u się nie dotykam mając niemiłe doświadczenia a w końcu to nie mój laptop ...szkoda go uwalić :-)
Najważniejsze że karta radeon została w linux-e w końcu poprawnie zdiagnozowana xrandr

Kod: Zaznacz cały

xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
eDP connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768      60.00*+  40.00  
   1280x720      59.97  
   1152x768      59.95  
   1024x768      59.95  
   800x600       59.96  
   848x480       59.94  
   720x480       59.94  
   640x480       59.94  
HDMI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
oczywiście dodałem dla radeona pewne foldery / wpisy niwelując filickering / thearing + wł akceleracji:
/etc/X11/xorg.conf.d/20-amdgpu.conf

Kod: Zaznacz cały

Section "Device"
Identifier "AMD"
Driver "amdgpu"
Option "Accel" "on"
Option "TearFree" "on"
Option "AccelMethod"  "glamor" 
Option "DRI" "3"
EndSection
nie wiem czy opcja : HDMI-0 disconnected oznacza iż HDMI nie działa ? ale na razie mam dosyć :lol:
Mam nadzieję że komuś pomogę tymi podpowiedziami :mrgreen:

Ps. niestety pewne opcje kernela podczas startu systemu powodują poważne błędy np. brak WiFi .Ostatecznie usunąłem :
apm=power_off libata.noacpi=1 a opcję : acpi_osi=Linux zastąpiłem acpi_osi=Windows. Błąd ACPI pozostał ale nie wpływa na funkcjonalność systemu.
pozdro!
ODPOWIEDZ

Wróć do „Instalacja, aktualizacja i konfiguracja Ubuntu”

Kto jest online

Użytkownicy przeglądający to forum: Google [Bot] i 19 gości