Nie można załadować biblioteki Qt5

Wyłącznie system! Wątpliwości dotyczące aplikacji proszę umieszczać niżej, w odpowiednich forach.
miodo07
Sędziwy Jeż
Sędziwy Jeż
Posty: 39
Rejestracja: 19 gru 2007, 23:16
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: LXDE
Architektura: x86

Nie można załadować biblioteki Qt5

Post autor: miodo07 » 11 lut 2019, 17:54

Dzień dobry,

Nie działają mi aplikacje wymagające użycia bibliotek Qt, mimo iż te są w systemie zainstalowane. Poniżej logi, proszę o pomoc.

Kod: Zaznacz cały

kacper@kacper-komputer:~$ smplayer
smplayer: error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory
kacper@kacper-komputer:~$ sudo apt-get install libqt5widgets5
[sudo] password for kacper: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqt5widgets5 is already the newest version (5.9.5+dfsg-0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 269 not upgraded.
kacper@kacper-komputer:~$ sudo apt-get install libqt5core5a
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqt5core5a is already the newest version (5.9.5+dfsg-0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 269 not upgraded.
Awatar użytkownika
Tomfoc
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1819
Rejestracja: 30 lis 2011, 21:14
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Nie można załadować biblioteki Qt5

Post autor: Tomfoc » 11 lut 2019, 21:57

"0 upgraded, 0 newly installed, 0 to remove and 269 not upgraded."
Zaktualizuj pakiety.
Laptop: Lenovo Ideapad 300, CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz × 4, GPU: Intel® HD Graphics 520 (Skylake GT2), RAM: 8 GB, HDD: 500 GB
miodo07
Sędziwy Jeż
Sędziwy Jeż
Posty: 39
Rejestracja: 19 gru 2007, 23:16
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: LXDE
Architektura: x86

Re: Nie można załadować biblioteki Qt5

Post autor: miodo07 » 12 lut 2019, 19:06

Zaktualizowane.

Kod: Zaznacz cały

kacper@kacper-komputer:~$ smplayer
smplayer: error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory
kacper@kacper-komputer:~$ sudo apt-get install libqt5widgets5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqt5widgets5 is already the newest version (5.9.5+dfsg-0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
:)
miodo07
Sędziwy Jeż
Sędziwy Jeż
Posty: 39
Rejestracja: 19 gru 2007, 23:16
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: LXDE
Architektura: x86

Re: Nie można załadować biblioteki Qt5

Post autor: miodo07 » 16 lut 2019, 06:53

Jak widać w powyższym logu, błąd nadal występuje.
Awatar użytkownika
kobrawerde
Wytworny Kaczor
Wytworny Kaczor
Posty: 376
Rejestracja: 10 wrz 2006, 16:00
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: LXDE
Architektura: x86_64

Re: Nie można załadować biblioteki Qt5

Post autor: kobrawerde » 16 lut 2019, 09:04

a spróbuj doinstalować :

Kod: Zaznacz cały

sudo apt-get install qt5-default
a może wina tkwi w wersji smplayer-a najlepiej sprawdzić czy jest najnowsza wersja ( np z repozytorium ppa ):
https://www.smplayer.info/pl/downloads
lub: 1 / 2
arecki
Sędziwy Jeż
Sędziwy Jeż
Posty: 70
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna

Re: Nie można załadować biblioteki Qt5

Post autor: arecki » 16 lut 2019, 09:45

Wrzuć wynik:

Kod: Zaznacz cały

ldd /usr/bin/smplayer
miodo07
Sędziwy Jeż
Sędziwy Jeż
Posty: 39
Rejestracja: 19 gru 2007, 23:16
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: LXDE
Architektura: x86

Re: Nie można załadować biblioteki Qt5

Post autor: miodo07 » 16 lut 2019, 11:45

Kod: Zaznacz cały

kacper@kacper-komputer:~$ sudo apt-get install qt5-default
[sudo] password for kacper: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libdrm-dev libegl1-mesa-dev libgl1-mesa-dev libgles1 libgles2-mesa-dev
  libglu1-mesa-dev libglvnd-core-dev libglvnd-dev libopengl0
  libpthread-stubs0-dev libqt5concurrent5 libqt5opengl5 libqt5opengl5-dev
  libqt5test5 libwayland-bin libwayland-dev libx11-dev libx11-doc
  libx11-xcb-dev libxau-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
  libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
  libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev libxdamage-dev libxdmcp-dev
  libxext-dev libxfixes-dev libxshmfence-dev libxxf86vm-dev mesa-common-dev
  qt5-qmake qt5-qmake-bin qtbase5-dev qtbase5-dev-tools x11proto-core-dev
  x11proto-damage-dev x11proto-dev x11proto-fixes-dev x11proto-xext-dev
  x11proto-xf86vidmode-dev xorg-sgml-doctools xtrans-dev
Suggested packages:
  libwayland-doc libxcb-doc libxext-doc default-libmysqlclient-dev
  firebird-dev libpq-dev libsqlite3-dev unixodbc-dev
The following NEW packages will be installed:
  libdrm-dev libegl1-mesa-dev libgl1-mesa-dev libgles1 libgles2-mesa-dev
  libglu1-mesa-dev libglvnd-core-dev libglvnd-dev libopengl0
  libpthread-stubs0-dev libqt5concurrent5 libqt5opengl5 libqt5opengl5-dev
  libqt5test5 libwayland-bin libwayland-dev libx11-dev libx11-doc
  libx11-xcb-dev libxau-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
  libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
  libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev libxdamage-dev libxdmcp-dev
  libxext-dev libxfixes-dev libxshmfence-dev libxxf86vm-dev mesa-common-dev
  qt5-default qt5-qmake qt5-qmake-bin qtbase5-dev qtbase5-dev-tools
  x11proto-core-dev x11proto-damage-dev x11proto-dev x11proto-fixes-dev
  x11proto-xext-dev x11proto-xf86vidmode-dev xorg-sgml-doctools xtrans-dev
0 upgraded, 50 newly installed, 0 to remove and 0 not upgraded.
Need to get 7 604 kB of archives.
After this operation, 47,9 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libdrm-dev amd64 2.4.95-1~18.04.1 [121 kB]
Get:2 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libglvnd-core-dev amd64 1.0.0-2ubuntu2.2 [12,9 kB]
Get:3 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgles1 amd64 1.0.0-2ubuntu2.2 [11,2 kB]
Get:4 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libopengl0 amd64 1.0.0-2ubuntu2.2 [31,3 kB]
Get:5 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libglvnd-dev amd64 1.0.0-2ubuntu2.2 [3 408 B]
Get:6 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 xorg-sgml-doctools all 1:1.11-1 [12,9 kB]
Get:7 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 x11proto-dev all 2018.4-4 [251 kB]
Get:8 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 x11proto-core-dev all 2018.4-4 [2 620 B]
Get:9 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxau-dev amd64 1:1.0.8-1 [11,1 kB]
Get:10 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxdmcp-dev amd64 1:1.1.2-3 [25,1 kB]
Get:11 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 xtrans-dev all 1.3.5-1 [70,5 kB]
Get:12 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libpthread-stubs0-dev amd64 0.3-4 [4 068 B]
Get:13 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb1-dev amd64 1.13-1 [80,0 kB]
Get:14 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libx11-dev amd64 2:1.6.4-3ubuntu0.1 [641 kB]
Get:15 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 x11proto-xext-dev all 2018.4-4 [2 620 B]
Get:16 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxext-dev amd64 2:1.3.3-1 [82,1 kB]
Get:17 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 x11proto-xf86vidmode-dev all 2018.4-4 [2 632 B]
Get:18 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxxf86vm-dev amd64 1:1.1.4-1 [13,3 kB]
Get:19 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 x11proto-fixes-dev all 1:2018.4-4 [2 620 B]
Get:20 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxfixes-dev amd64 1:5.0.3-1 [11,0 kB]
Get:21 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 x11proto-damage-dev all 1:2018.4-4 [2 620 B]
Get:22 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxdamage-dev amd64 1:1.1.4-3 [5 028 B]
Get:23 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb-glx0-dev amd64 1.13-1 [27,9 kB]
Get:24 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb-dri2-0-dev amd64 1.13-1 [8 476 B]
Get:25 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb-dri3-dev amd64 1.13-1 [7 368 B]
Get:26 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb-render0-dev amd64 1.13-1 [18,4 kB]
Get:27 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb-randr0-dev amd64 1.13-1 [20,4 kB]
Get:28 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb-shape0-dev amd64 1.13-1 [7 144 B]
Get:29 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb-xfixes0-dev amd64 1.13-1 [11,7 kB]
Get:30 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb-sync-dev amd64 1.13-1 [10,6 kB]
Get:31 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxcb-present-dev amd64 1.13-1 [6 968 B]
Get:32 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libxshmfence-dev amd64 1.3-1 [3 692 B]
Get:33 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libx11-xcb-dev amd64 2:1.6.4-3ubuntu0.1 [9 764 B]
Get:34 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libwayland-bin amd64 1.16.0-1ubuntu1.1~18.04.1 [20,0 kB]
Get:35 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libwayland-dev amd64 1.16.0-1ubuntu1.1~18.04.1 [62,8 kB]
Get:36 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libegl1-mesa-dev amd64 18.2.2-0ubuntu1~18.04.2 [20,8 kB]
Get:37 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgles2-mesa-dev amd64 18.2.2-0ubuntu1~18.04.2 [40,6 kB]
Get:38 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 mesa-common-dev amd64 18.2.2-0ubuntu1~18.04.2 [551 kB]
Get:39 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgl1-mesa-dev amd64 18.2.2-0ubuntu1~18.04.2 [4 428 B]
Get:40 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libglu1-mesa-dev amd64 9.0.0-2.1build1 [206 kB]
Get:41 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libqt5concurrent5 amd64 5.9.5+dfsg-0ubuntu1 [29,8 kB]
Get:42 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libqt5opengl5 amd64 5.9.5+dfsg-0ubuntu1 [132 kB]
Get:43 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libqt5test5 amd64 5.9.5+dfsg-0ubuntu1 [98,1 kB]
Get:44 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 qt5-qmake-bin amd64 5.9.5+dfsg-0ubuntu1 [938 kB]
Get:45 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 qt5-qmake amd64 5.9.5+dfsg-0ubuntu1 [180 kB]
Get:46 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 qtbase5-dev-tools amd64 5.9.5+dfsg-0ubuntu1 [723 kB]
Get:47 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 qtbase5-dev amd64 5.9.5+dfsg-0ubuntu1 [943 kB]
Get:48 http://pl.archive.ubuntu.com/ubuntu bionic/main amd64 libqt5opengl5-dev amd64 5.9.5+dfsg-0ubuntu1 [36,1 kB]
Get:49 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libx11-doc all 2:1.6.4-3ubuntu0.1 [2 065 kB]
Get:50 http://pl.archive.ubuntu.com/ubuntu bionic/universe amd64 qt5-default amd64 5.9.5+dfsg-0ubuntu1 [20,9 kB]
Fetched 7 604 kB in 17s (436 kB/s)                                             
Extracting templates from packages: 100%
Selecting previously unselected package libdrm-dev:amd64.
(Reading database ... 232516 files and directories currently installed.)
Preparing to unpack .../00-libdrm-dev_2.4.95-1~18.04.1_amd64.deb ...
Unpacking libdrm-dev:amd64 (2.4.95-1~18.04.1) ...
Selecting previously unselected package libglvnd-core-dev:amd64.
Preparing to unpack .../01-libglvnd-core-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-core-dev:amd64 (1.0.0-2ubuntu2.2) ...
Selecting previously unselected package libgles1:amd64.
Preparing to unpack .../02-libgles1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgles1:amd64 (1.0.0-2ubuntu2.2) ...
Selecting previously unselected package libopengl0:amd64.
Preparing to unpack .../03-libopengl0_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libopengl0:amd64 (1.0.0-2ubuntu2.2) ...
Selecting previously unselected package libglvnd-dev:amd64.
Preparing to unpack .../04-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) ...
Selecting previously unselected package xorg-sgml-doctools.
Preparing to unpack .../05-xorg-sgml-doctools_1%3a1.11-1_all.deb ...
Unpacking xorg-sgml-doctools (1:1.11-1) ...
Selecting previously unselected package x11proto-dev.
Preparing to unpack .../06-x11proto-dev_2018.4-4_all.deb ...
Unpacking x11proto-dev (2018.4-4) ...
Selecting previously unselected package x11proto-core-dev.
Preparing to unpack .../07-x11proto-core-dev_2018.4-4_all.deb ...
Unpacking x11proto-core-dev (2018.4-4) ...
Selecting previously unselected package libxau-dev:amd64.
Preparing to unpack .../08-libxau-dev_1%3a1.0.8-1_amd64.deb ...
Unpacking libxau-dev:amd64 (1:1.0.8-1) ...
Selecting previously unselected package libxdmcp-dev:amd64.
Preparing to unpack .../09-libxdmcp-dev_1%3a1.1.2-3_amd64.deb ...
Unpacking libxdmcp-dev:amd64 (1:1.1.2-3) ...
Selecting previously unselected package xtrans-dev.
Preparing to unpack .../10-xtrans-dev_1.3.5-1_all.deb ...
Unpacking xtrans-dev (1.3.5-1) ...
Selecting previously unselected package libpthread-stubs0-dev:amd64.
Preparing to unpack .../11-libpthread-stubs0-dev_0.3-4_amd64.deb ...
Unpacking libpthread-stubs0-dev:amd64 (0.3-4) ...
Selecting previously unselected package libxcb1-dev:amd64.
Preparing to unpack .../12-libxcb1-dev_1.13-1_amd64.deb ...
Unpacking libxcb1-dev:amd64 (1.13-1) ...
Selecting previously unselected package libx11-dev:amd64.
Preparing to unpack .../13-libx11-dev_2%3a1.6.4-3ubuntu0.1_amd64.deb ...
Unpacking libx11-dev:amd64 (2:1.6.4-3ubuntu0.1) ...
Selecting previously unselected package x11proto-xext-dev.
Preparing to unpack .../14-x11proto-xext-dev_2018.4-4_all.deb ...
Unpacking x11proto-xext-dev (2018.4-4) ...
Selecting previously unselected package libxext-dev:amd64.
Preparing to unpack .../15-libxext-dev_2%3a1.3.3-1_amd64.deb ...
Unpacking libxext-dev:amd64 (2:1.3.3-1) ...
Selecting previously unselected package x11proto-xf86vidmode-dev.
Preparing to unpack .../16-x11proto-xf86vidmode-dev_2018.4-4_all.deb ...
Unpacking x11proto-xf86vidmode-dev (2018.4-4) ...
Selecting previously unselected package libxxf86vm-dev:amd64.
Preparing to unpack .../17-libxxf86vm-dev_1%3a1.1.4-1_amd64.deb ...
Unpacking libxxf86vm-dev:amd64 (1:1.1.4-1) ...
Selecting previously unselected package x11proto-fixes-dev.
Preparing to unpack .../18-x11proto-fixes-dev_1%3a2018.4-4_all.deb ...
Unpacking x11proto-fixes-dev (1:2018.4-4) ...
Selecting previously unselected package libxfixes-dev:amd64.
Preparing to unpack .../19-libxfixes-dev_1%3a5.0.3-1_amd64.deb ...
Unpacking libxfixes-dev:amd64 (1:5.0.3-1) ...
Selecting previously unselected package x11proto-damage-dev.
Preparing to unpack .../20-x11proto-damage-dev_1%3a2018.4-4_all.deb ...
Unpacking x11proto-damage-dev (1:2018.4-4) ...
Selecting previously unselected package libxdamage-dev:amd64.
Preparing to unpack .../21-libxdamage-dev_1%3a1.1.4-3_amd64.deb ...
Unpacking libxdamage-dev:amd64 (1:1.1.4-3) ...
Selecting previously unselected package libxcb-glx0-dev:amd64.
Preparing to unpack .../22-libxcb-glx0-dev_1.13-1_amd64.deb ...
Unpacking libxcb-glx0-dev:amd64 (1.13-1) ...
Selecting previously unselected package libxcb-dri2-0-dev:amd64.
Preparing to unpack .../23-libxcb-dri2-0-dev_1.13-1_amd64.deb ...
Unpacking libxcb-dri2-0-dev:amd64 (1.13-1) ...
Selecting previously unselected package libxcb-dri3-dev:amd64.
Preparing to unpack .../24-libxcb-dri3-dev_1.13-1_amd64.deb ...
Unpacking libxcb-dri3-dev:amd64 (1.13-1) ...
Selecting previously unselected package libxcb-render0-dev:amd64.
Preparing to unpack .../25-libxcb-render0-dev_1.13-1_amd64.deb ...
Unpacking libxcb-render0-dev:amd64 (1.13-1) ...
Selecting previously unselected package libxcb-randr0-dev:amd64.
Preparing to unpack .../26-libxcb-randr0-dev_1.13-1_amd64.deb ...
Unpacking libxcb-randr0-dev:amd64 (1.13-1) ...
Selecting previously unselected package libxcb-shape0-dev:amd64.
Preparing to unpack .../27-libxcb-shape0-dev_1.13-1_amd64.deb ...
Unpacking libxcb-shape0-dev:amd64 (1.13-1) ...
Selecting previously unselected package libxcb-xfixes0-dev:amd64.
Preparing to unpack .../28-libxcb-xfixes0-dev_1.13-1_amd64.deb ...
Unpacking libxcb-xfixes0-dev:amd64 (1.13-1) ...
Selecting previously unselected package libxcb-sync-dev:amd64.
Preparing to unpack .../29-libxcb-sync-dev_1.13-1_amd64.deb ...
Unpacking libxcb-sync-dev:amd64 (1.13-1) ...
Selecting previously unselected package libxcb-present-dev:amd64.
Preparing to unpack .../30-libxcb-present-dev_1.13-1_amd64.deb ...
Unpacking libxcb-present-dev:amd64 (1.13-1) ...
Selecting previously unselected package libxshmfence-dev:amd64.
Preparing to unpack .../31-libxshmfence-dev_1.3-1_amd64.deb ...
Unpacking libxshmfence-dev:amd64 (1.3-1) ...
Selecting previously unselected package libx11-xcb-dev:amd64.
Preparing to unpack .../32-libx11-xcb-dev_2%3a1.6.4-3ubuntu0.1_amd64.deb ...
Unpacking libx11-xcb-dev:amd64 (2:1.6.4-3ubuntu0.1) ...
Selecting previously unselected package libwayland-bin.
Preparing to unpack .../33-libwayland-bin_1.16.0-1ubuntu1.1~18.04.1_amd64.deb ...
Unpacking libwayland-bin (1.16.0-1ubuntu1.1~18.04.1) ...
Selecting previously unselected package libwayland-dev:amd64.
Preparing to unpack .../34-libwayland-dev_1.16.0-1ubuntu1.1~18.04.1_amd64.deb ...
Unpacking libwayland-dev:amd64 (1.16.0-1ubuntu1.1~18.04.1) ...
Selecting previously unselected package libegl1-mesa-dev:amd64.
Preparing to unpack .../35-libegl1-mesa-dev_18.2.2-0ubuntu1~18.04.2_amd64.deb ...
Unpacking libegl1-mesa-dev:amd64 (18.2.2-0ubuntu1~18.04.2) ...
Selecting previously unselected package libgles2-mesa-dev:amd64.
Preparing to unpack .../36-libgles2-mesa-dev_18.2.2-0ubuntu1~18.04.2_amd64.deb ...
Unpacking libgles2-mesa-dev:amd64 (18.2.2-0ubuntu1~18.04.2) ...
Selecting previously unselected package mesa-common-dev:amd64.
Preparing to unpack .../37-mesa-common-dev_18.2.2-0ubuntu1~18.04.2_amd64.deb ...
Unpacking mesa-common-dev:amd64 (18.2.2-0ubuntu1~18.04.2) ...
Selecting previously unselected package libgl1-mesa-dev:amd64.
Preparing to unpack .../38-libgl1-mesa-dev_18.2.2-0ubuntu1~18.04.2_amd64.deb ...
Unpacking libgl1-mesa-dev:amd64 (18.2.2-0ubuntu1~18.04.2) ...
Selecting previously unselected package libglu1-mesa-dev:amd64.
Preparing to unpack .../39-libglu1-mesa-dev_9.0.0-2.1build1_amd64.deb ...
Unpacking libglu1-mesa-dev:amd64 (9.0.0-2.1build1) ...
Selecting previously unselected package libqt5concurrent5:amd64.
Preparing to unpack .../40-libqt5concurrent5_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking libqt5concurrent5:amd64 (5.9.5+dfsg-0ubuntu1) ...
Selecting previously unselected package libqt5opengl5:amd64.
Preparing to unpack .../41-libqt5opengl5_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking libqt5opengl5:amd64 (5.9.5+dfsg-0ubuntu1) ...
Selecting previously unselected package libqt5test5:amd64.
Preparing to unpack .../42-libqt5test5_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking libqt5test5:amd64 (5.9.5+dfsg-0ubuntu1) ...
Selecting previously unselected package qt5-qmake-bin.
Preparing to unpack .../43-qt5-qmake-bin_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking qt5-qmake-bin (5.9.5+dfsg-0ubuntu1) ...
Selecting previously unselected package qt5-qmake:amd64.
Preparing to unpack .../44-qt5-qmake_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking qt5-qmake:amd64 (5.9.5+dfsg-0ubuntu1) ...
Selecting previously unselected package qtbase5-dev-tools.
Preparing to unpack .../45-qtbase5-dev-tools_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking qtbase5-dev-tools (5.9.5+dfsg-0ubuntu1) ...
Selecting previously unselected package qtbase5-dev:amd64.
Preparing to unpack .../46-qtbase5-dev_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking qtbase5-dev:amd64 (5.9.5+dfsg-0ubuntu1) ...
Selecting previously unselected package libqt5opengl5-dev:amd64.
Preparing to unpack .../47-libqt5opengl5-dev_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking libqt5opengl5-dev:amd64 (5.9.5+dfsg-0ubuntu1) ...
Selecting previously unselected package libx11-doc.
Preparing to unpack .../48-libx11-doc_2%3a1.6.4-3ubuntu0.1_all.deb ...
Unpacking libx11-doc (2:1.6.4-3ubuntu0.1) ...
Selecting previously unselected package qt5-default:amd64.
Preparing to unpack .../49-qt5-default_5.9.5+dfsg-0ubuntu1_amd64.deb ...
Unpacking qt5-default:amd64 (5.9.5+dfsg-0ubuntu1) ...
Setting up libwayland-bin (1.16.0-1ubuntu1.1~18.04.1) ...
Setting up libopengl0:amd64 (1.0.0-2ubuntu2.2) ...
Setting up qtbase5-dev-tools (5.9.5+dfsg-0ubuntu1) ...
Setting up libgles1:amd64 (1.0.0-2ubuntu2.2) ...
Setting up qt5-qmake-bin (5.9.5+dfsg-0ubuntu1) ...
Setting up libxshmfence-dev:amd64 (1.3-1) ...
Setting up libpthread-stubs0-dev:amd64 (0.3-4) ...
Setting up libdrm-dev:amd64 (2.4.95-1~18.04.1) ...
Setting up xorg-sgml-doctools (1:1.11-1) ...
Setting up libqt5test5:amd64 (5.9.5+dfsg-0ubuntu1) ...
Processing triggers for sgml-base (1.29) ...
Setting up libqt5opengl5:amd64 (5.9.5+dfsg-0ubuntu1) ...
Setting up x11proto-dev (2018.4-4) ...
Setting up x11proto-damage-dev (1:2018.4-4) ...
Setting up xtrans-dev (1.3.5-1) ...
Setting up x11proto-xext-dev (2018.4-4) ...
Setting up qt5-qmake:amd64 (5.9.5+dfsg-0ubuntu1) ...
Setting up libxdmcp-dev:amd64 (1:1.1.2-3) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libx11-doc (2:1.6.4-3ubuntu0.1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Setting up libwayland-dev:amd64 (1.16.0-1ubuntu1.1~18.04.1) ...
Setting up libglvnd-core-dev:amd64 (1.0.0-2ubuntu2.2) ...
Setting up libqt5concurrent5:amd64 (5.9.5+dfsg-0ubuntu1) ...
Setting up x11proto-core-dev (2018.4-4) ...
Setting up x11proto-fixes-dev (1:2018.4-4) ...
Setting up x11proto-xf86vidmode-dev (2018.4-4) ...
Setting up libxau-dev:amd64 (1:1.0.8-1) ...
Setting up libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) ...
Setting up libxcb1-dev:amd64 (1.13-1) ...
Setting up libxcb-glx0-dev:amd64 (1.13-1) ...
Setting up libx11-dev:amd64 (2:1.6.4-3ubuntu0.1) ...
Setting up libxxf86vm-dev:amd64 (1:1.1.4-1) ...
Setting up libxfixes-dev:amd64 (1:5.0.3-1) ...
Setting up libxcb-sync-dev:amd64 (1.13-1) ...
Setting up libx11-xcb-dev:amd64 (2:1.6.4-3ubuntu0.1) ...
Setting up mesa-common-dev:amd64 (18.2.2-0ubuntu1~18.04.2) ...
Setting up libxdamage-dev:amd64 (1:1.1.4-3) ...
Setting up libxcb-dri2-0-dev:amd64 (1.13-1) ...
Setting up libxcb-render0-dev:amd64 (1.13-1) ...
Setting up libxcb-dri3-dev:amd64 (1.13-1) ...
Setting up libxext-dev:amd64 (2:1.3.3-1) ...
Setting up libxcb-shape0-dev:amd64 (1.13-1) ...
Setting up libxcb-randr0-dev:amd64 (1.13-1) ...
Setting up libxcb-xfixes0-dev:amd64 (1.13-1) ...
Setting up libxcb-present-dev:amd64 (1.13-1) ...
Setting up libgl1-mesa-dev:amd64 (18.2.2-0ubuntu1~18.04.2) ...
Setting up libegl1-mesa-dev:amd64 (18.2.2-0ubuntu1~18.04.2) ...
Setting up libglu1-mesa-dev:amd64 (9.0.0-2.1build1) ...
Setting up libgles2-mesa-dev:amd64 (18.2.2-0ubuntu1~18.04.2) ...
Setting up qtbase5-dev:amd64 (5.9.5+dfsg-0ubuntu1) ...
Setting up libqt5opengl5-dev:amd64 (5.9.5+dfsg-0ubuntu1) ...
Setting up qt5-default:amd64 (5.9.5+dfsg-0ubuntu1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
kacper@kacper-komputer:~$ smplayer
smplayer: error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory
kacper@kacper-komputer:~$ ldd /usr/bin/smplayer
	linux-vdso.so.1 (0x00007ffefd1f2000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f6e52f0d000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f6e52bd5000)
	libQt5Widgets.so.5 => not found
	libQt5Gui.so.5 => not found
	libQt5Network.so.5 => not found
	libQt5Xml.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5 (0x00007f6e52999000)
	libQt5Script.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Script.so.5 (0x00007f6e52503000)
	libQt5DBus.so.5 => not found
	libQt5Core.so.5 => not found
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f6e522e4000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f6e51f5b000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f6e51d43000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f6e51952000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f6e5172a000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f6e51526000)
	libQt5Core.so.5 => not found
	libQt5Core.so.5 => not found
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f6e51188000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f6e53752000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f6e50f84000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f6e50d7e000)
	libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f6e50b69000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f6e50961000)
Niestety problem nadal występuje.
Inne aplikacje Qt również się nie uruchamiają.

Kod: Zaznacz cały

kacper@kacper-komputer:~$ kadu
kadu: error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory
arecki
Sędziwy Jeż
Sędziwy Jeż
Posty: 70
Rejestracja: 17 lis 2018, 09:31
Płeć: Mężczyzna

Re: Nie można załadować biblioteki Qt5

Post autor: arecki » 16 lut 2019, 11:49

Wrzuć wynik:

Kod: Zaznacz cały

sudo updatedb && locate libQt5Widgets.so
miodo07
Sędziwy Jeż
Sędziwy Jeż
Posty: 39
Rejestracja: 19 gru 2007, 23:16
Płeć: Mężczyzna
Wersja Ubuntu: 16.04
Środowisko graficzne: LXDE
Architektura: x86

Re: Nie można załadować biblioteki Qt5

Post autor: miodo07 » 17 lut 2019, 01:42

Kod: Zaznacz cały

kacper@kacper-komputer:~$ sudo updatedb && locate libQt5Widgets.so
[sudo] password for kacper: 
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so
ODPOWIEDZ

Wróć do „Instalacja, aktualizacja i konfiguracja Ubuntu”