Dziwny komunikat w konsoli - ponoć są jakieś pakiety do zaktualizowania

Tutaj można zadać pytanie, jeśli Linuksa widzi się pierwszy raz w życiu ;)
Awatar użytkownika
lcoyote
Wytworny Kaczor
Wytworny Kaczor
Posty: 361
Rejestracja: 30 lis 2017, 16:33
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: MATE
Architektura: x86_64

Dziwny komunikat w konsoli - ponoć są jakieś pakiety do zaktualizowania

Post autor: lcoyote » 05 sie 2019, 15:37

Witam wszystkich,
Od jakiegoś tygodnia, gdy wpiszę w konsoli

Kod: Zaznacz cały

sudo apt update && sudo apt update
to pojawia się komunikat, że np. trzy pakiety (lub więcej) są do aktualizacji - ale z konsoli nie można nic zaktualizować

Komunikat w konsoli
Odczyt informacji o stanie... Gotowe
3 packages can be upgraded. Run 'apt list --upgradable' to see them.

Dopiero w graficznym Menagerze aktualizacji - następuje zainstalowanie uaktualnień.
Dawniej w konsoli można było bez problemu przeprowadzać aktualizacje. Teraz coś nie tak się porobiło i tylko graficzny menager.
To Mint 19.1 na środowisku Mate
Awatar użytkownika
Tomfoc
Przebojowy Jelonek
Przebojowy Jelonek
Posty: 1924
Rejestracja: 30 lis 2011, 21:14
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: GNOME
Architektura: x86_64

Re: Dziwny komunikat w konsoli

Post autor: Tomfoc » 05 sie 2019, 17:13

Pierwsze polecenie masz sudo apt update i drugie identyczne, czyli nie każesz aptowi aktualizować pakiety, każesz mu dwa razy sprawdzić dostępność aktualizacji. Ta druga część to powinno być sudo apt upgrade

Kod: Zaznacz cały

sudo apt update && sudo apt upgrade
Graficzny menedżer tego błędu nie zawiera, więc aktualizacji dokonuje prawidłowo.
Laptop: Lenovo Ideapad 300, CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz × 4, GPU: Intel® HD Graphics 520 (Skylake GT2), RAM: 8 GB, HDD: 500 GB
Awatar użytkownika
ffatman
Serdeczny Borsuk
Serdeczny Borsuk
Posty: 179
Rejestracja: 20 sie 2007, 07:24
Płeć: Mężczyzna
Wersja Ubuntu: 18.04
Środowisko graficzne: Xfce
Architektura: x86_64
Kontakt:

Re: Dziwny komunikat w konsoli - ponoć są jakieś pakiety do zaktualizowania

Post autor: ffatman » 07 sie 2019, 02:44

Kod: Zaznacz cały

sudo apt update && sudo apt upgrade -y
Jeżeli wiesz, co robisz.
ODPOWIEDZ

Wróć do „Przedszkole Linuksa”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 48 gości