Odtwarzanie wideo a Compiz Fusion

Awatar użytkownika
vytah
Piegowaty Guziec
Piegowaty Guziec
Posty: 24
Rejestracja: 11 paź 2007, 17:44
Płeć: Mężczyzna
Wersja Ubuntu: 7.10
Środowisko graficzne: GNOME
Kontakt:

Odtwarzanie wideo a Compiz Fusion

Post autor: vytah » 14 lis 2007, 12:55

Źródło: http://forum.compiz-fusion.org/showthread.php?t=1152

Wideo najczęściej nie odtwarza się tak jakbyśmy sobie życzyli, jeśli używamy CompizFusion albo inny, podobny program. Dzieje się to tak, ponieważ obraz nie jest kierowany do menedżera okien tylko bezpośrednio do X, czy sterownika (czy jakoś tak, nie znam się ;)). W efekcie uzyskujemy dziwnie przesuwający się obraz, niczym w Windowsie...

Aby zobaczyć film załamujący się na kostce, trzęsący się wraz z oknem itp. należy:
:arrow: Totem (i inne na gstreamerze) //sprawdzone - działa
- uruchomić gstreamer-properties
- na zakładce Wizja, w polu Wtyczka wybrać X Window System (nie Xv)
- można skorzystać z przycisku Testuj, aby sprawdzić, czy działa jak trzeba
:arrow: VLC //sprawdzone - działa
- włącz VLC
- Wejdź do Settings->Preferences
- rozwinąć menu Video i wybrać opcję Output modules
- zaznaczyć na dole Advances Settings
- z listy wybrać X11 Video Output
- kliknij Zapisz/Save
:arrow: Mplayer //sprawdzone - działa
- włącz Mplayera
- kliknij prawym na ekran i wybierz Preferences
- w zakładce Video wybierz x11 (XImage/Shm)
- zapisz ustawienia i uruchom ponownie Mplayera
:arrow: Xine
- uruchom Xine
- File->Configure->Preferences (albo Plik->Konfiguruj->Preferencje, czy jakoś tak)
- w experience_level wybierz “Master Of The Known Universe”
- przejdź do video
- wybierz driver "xshm"
- zrestartuj Xine
:arrow: RealPlayer
- włącz RealPlayera
- Settings->Preferences
- na zakładce ustawienia odznacz Use X Video
- uruchom ponownie RealPlayera

Poniższe działa na Gutsym, ale nie jestem pewien, czy na pewno jest poprawne i czy w ogóle potrzebne, ale jakby ktoś potrzebował:

Aby poprawnie działało wideo na pełnym ekranie przy włączonym Compizie, to:
- zainstaluj przez Dodaj/Usuń Compiz Config Settings Manager
- System->Preferencje->Wygląd, zakłądka Efekty wizualne, kliknij Preferencje
- kliknij ikonę General Options, zakładka Opacity Settings
- kliknij Dodaj
- w małym okienku na górze wpisz 100, a na dole

Kod: Zaznacz cały

((type=Unknown | Menu | PopupMenu | DropdownMenu | Tooltip | Notification | Combo | Dnd | name=sun-awt-X11-XWindowPeer) | (type=Normal & override_redirect=1)) & !(name=sun-awt-X11-XFramePeer | name=sun-awt-X11-XDialogPeer | state=fullscreen | name=^x11$ | name=^xv$ | name=^xine Video Window$)
- OK i pozamykaj
- nie mam pojęcia jak to działa ale ponoć działa
ODPOWIEDZ

Wróć do „Software-Multimedia”