Snort - działający i młodszy niż 2 lata.

Tutaj można rozmawiać o propozycjach dla Dużego Brata (a następnie je zgłaszać)
Awatar użytkownika
jacekalex
Gibki Gibbon
Gibki Gibbon
Posty: 3842
Rejestracja: 17 cze 2007, 02:54
Płeć: Mężczyzna
Wersja Ubuntu: inny OS
Środowisko graficzne: Inne
Architektura: x86_64

[SOLVED] Snort - działający i młodszy niż 2 lata.

Post autor: jacekalex » 23 kwie 2009, 14:37

Snort - system wykrywania włamań do sieci - system IDS - najpopularniejszy na świecie.
Z jakichś powodów dla Debiana i Ubuntu są tylko wersje 2.7 - ostatnio 2.7.0.22.
Najczęściej nie chcą działać - jest w nich pełno błędów - lauchpad jest pełen informacji o znalezionych błędach.
Z jakiegos powodu Debian, a co za tym idzie Ubuntu również - są uczulone na nowsze wersje tego pakietu.
Wersje 2.8.1, 2.8.3 i 2.8.4 - nigdy nie wyszły w paczkach deb.
Sam wiem - że skompilowanie tego pakietu pod Ubuntu jest możliwe - ale często bardzo trudne.

Moja propozycja - albo nowsze paczki - albo skrypt - który (na wzór ebuildów w gentoo) - automatyzuje kompilację pakietu ze źródeł.

Z całą pewnością bedzie to dla developerów łatwiejsze - aniżeli ciągłe czytanie i często odpowiadanie na posty ludzi - którzy to próbowali zainstalować.

Moim zdaniem - takie paczki są potrzebne.

Mnie nie koniecznie nie jest potrzebne - snort 2.8.3.1 działa u mnie w chroocie zbudowanym na bazie stage3 z gentoo-hardened.

Ale tysiącom ludzi, którzy kompilowali ten pakiet w Ubuntu czy Debianie - takie działające paczki się przydadzą.
Zwłaszca autorom tych postów i stron:
http://www.google.pl/search?hl=pl&q=sno ... Szukaj&lr=
Wyniki 1 - 10 spośród około 79,900 dla zapytania snort bugs ubuntu.
:clap: :clap: :clap:

http://www.google.pl/search?hl=pl&q=sno ... Szukaj&lr=
Wyniki 1 - 10 spośród około 115,000 dla zapytania snort bugs debian
:clap: :clap: :clap:


Krótko mówiąc debian wygrywa z ubuntu 115 do 80 - w kategorii problem ze snortem.
Ale nie wiem - czy jest się z czego cieszyć. :twisted:

To by było na tyle.

Pozdrawiam
;-)

EDIT
W Karmic-u znalazł się snort-2.8.4.1 - widocznie ktoś czytał - może ten post - a może miał dość tego nieskończonego serialu na lauchpadzie - dotyczącego kolejnych wersji-2.7.* :smile:
Zablokowany

Wróć do „brainstorm.ubuntu.pl”